Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Blazer security light blinking and car won't start

anyone have any idea how to reset the seurity system, turn key don;t do nothing
«1

Comments

  • did you ever find out what caused the security light to blink. mine is coming on while i'm driving. :confuse:
  • Mine is being stupid also. The light comes on while Im driving and it also wont start and the light blinks. From what I have been told if you wait 10 minutes it will start. After the 10 minutes if you turn the key on but dont try to start it and the serurity light flashes dont try to start it. If it is on solid then it will start. Im trying to figure out what we need to do to fix it. I was told we had to replace the whole ignition part of the colum cause the key isnt in sync with the passlock system.... Anyone know?? :confuse:
  • i talked to a friend of mine who is going to be working an my blazers problem. he said that as long as the security light doesn't start blinking the vehicle will be fine. But if the light starts to blink then it is going to shut the vehicle off. there are only 2 options to fix the problem either try and get a new key (if the one you have is worn) if that does not work then yes the ignition needs to be replaced. And Yes it costs a pretty penny to get it fixed. :lemon:
  • CHEAP FIX!!! I had the same problem 2 years ago with my 2000 Blazer. I went through hell trying to figure out the problem with many mechanics. If the security light is blinking you have to wait 10-15 minutes for the system to recycle. When the light stops blinking it will start. Here's the issue...the GM security feature is defective and there is no way to turn it off. Don't bother wasting your money on a new ignition because it does nothing (I know because I replaced mine). I got a hunch that if I put in a remote starter I could then bypass GM's security feature and it would be fine. IT WORKED! I put in the remote starter and have not had any issues with starting for over 2 years now. ON THE OTHER HAND!!!!! my 4X4 is faulty. The 4X4 lights on the dash blink or go out and the truck runs like crap. It will be fine for a little while but then the light starts going on and off and the truck runs crappy again. This problem I can't figure out...any ideas?
  • I reget ever buying this stupid thing!!! Mine will run bad when I stop at alot of places shopping when it is hot out side. When I come up the mountain it feels like it is vapor locking. If I have to stop it dies. With the security problem it scares me that Im going to be stuck in the middle of the road and it wont start for 10 freakin minutes. I bought this car for my daughter to drive. We have about 3 months to get it fixed or she'll end up driving my truck, cant have THAT!! So we will try the remote start and go from there!!!
    THANKS!!!
    If you have any ideas on the vapor loack thing let me know!!! :sick:
  • jlflemmonsjlflemmons Posts: 2,240
    Okay, this is a fuel injected vehicle and cannot vapor lock. Not saying there isn't a problem, just that it cannot be vapor lock.

    Several things can cause the problem you are having, including the MAp sensor, crankshaft position sensor, any number of things. The system will only set a code if the problem is a hard failure, or repeats itself. Regarding temperature, if the temps are higher outside, the temps are higher around all those sensors used in the engine control system. Also of note is that the engine and engine compartment gets even hotter when you turn it off. There is no air or coolant flowing, and that chunk of iron just gets hotter before it starts cooling back down. Has a GM dealer checked the vehicle? Not all independents are qualified for the sophistication of an OBDII system and will just keep swapping parts until they stumble across the problem.

    Put a little logic into the problem and observe closely for any other events at the time of failure, or symptoms that may seem unrelated. Just remember that the 4.3L engine and control system is in 100's of thousand of vehicles on the road and has a very good history.
  • Ok here is what happens to mine and please tellme if yours did the same thing. If it sits overnight and I go out to start it, it turns over but doesnt start. If i wait about 10 minute sometimes more and turn it over sometimes it will start sometimes not. It took me over an hour to get it started last week, but once it is started it will turn over everytime after that with no problems. I just want to be sure that you had the same issues before i install a remote start. Because if my problem is different it would be a waste of money. Thank you :mad:
  • Mine was not doing this before BUT now it is.... I dont know what to do at this point.. At time it wont start and the security light isnt blinking. It still does the security thing BUT now it does this also.... OOOHHH and jlflemmons thanks for the info but as I said in my original " It feels like it is vapor locking" I know that it is feul injected and cant vapor lock. I have put a little logic in to the problem and I still feel is it a piece of @#!$..... :sick:
  • So, by remoe starter do you mean a new key fob? I asked at the dealer, I can get one for $70. My alarm sysytem gets set and then won't let me in - even with a key. I've found if I wait, then reset it form inside the car with the key in the ignition after a while it does shut off and let me drive. Otherwise, even with the key, I'm s.o.l.
    The thing is, I'd rather disable the whoel thing. Anyone know how? Is it hard? If I have someoen do it, how much should it run? I'm a former toyota girl and am CLUELESS as to what to do with this!
  • I have been told you cant disable it. You have to fix it. I dont have the keyless entry thing on my keychain..... The remote start is a way to start the car from inside the house or from outside the car. :mad:
  • I traded it off for a brand new Jeep Liberty!!! No more problem for me!! Sorry to the next person who buys it!! :shades: :)
  • Ive have my 01 Blazer ls for about 6 years now. the only major problem ive had happened about 2 years ago. Had to replace the fuel pump(that was fun dyin on the highway in traffic!) and I had to replace the cat converter(made the car run like total crap and actually died on me going up a mountain) which i think might be one of the problems being discussed on here by some. I am also having the "I dont want to start for you today" fight with my truck as of late, I dont have a keyless entry system on my truck so i dont know wtf is wrong with it now. I've put a new fuel filter new plugs, i'm fanatical about oil/filter changes, i've even put a new hot wire to the starter(old one wore out-damn those dirt country roads!) So I hope my fight with my truck might offer some insight into some of the problems you guys are having.
  • I had another blazer before this one and it was doing the cough cough thing when it would get up to normal tempature. I called my grandpa, a chevy man from the begining of chevy, and he told me to change the ignition module. He said there is a jell stuff between it and the distrubutor and if that brakes down then it wont work right. I went to get one, Im a woman, and was told OH NO it cant be that its this...... Over and over and nothing they were selling me fixed the problem. Finally after about $500 I bought the $40 part. My husband put it on and BAM the problem was gone. Should have listen to grandpa from the start!!!!! GOOD LUCK!!
  • kstanekkstanek Posts: 1
    I have a 2004 Chevroletr Blazer. Battery light was on check battery found it was bad. Replaced battery but light stayed on. Moved vehicle and light went off. In this time the gas guage won't work the ABS and air bag lights were on. Left vehicle set for two hours and will not start. Any answers?
  • All right to sum this issue I'm having up....I turn the key and it cranks.I do have spark.However the fuel pump doesn't engage.Not even to prime.Have replaced the keyed tumbler in column as well as ignition switch.Have removed all the after market crap that previous owner installed.So now is bone stock.Have checked relay and fuse.Both are fine how ever relay does not click.Have bench tested the fuel pump.It does work on the bench fine.Have considered adding a backup harness to the fuel pump.(relayed of course.)To engage the pump manually.How ever before I do this, (have done same before in a 90 camaro)I'd like to try changing the oil pressure switch and or sending unit.Have been to auto parts store and seen the switch.How ever CAN NOT locate the blessed thing on the engine any where.Could someone please give me a location and or explanation? Thanx.....Bill
  • 98 blazer won't even crank. The key on you can hear the pump working, also the starter contact relay under hood is engaging, all lights and dash lights come on, chimes work, battery fully charged, The security system has been suposedly removed by some so called mechanic shop. tried to giggle the shifter in the park position and also the neutral position. open for any and all suggestions.....
    Thanks Randy :confuse:
  • jlflemmonsjlflemmons Posts: 2,240
    Starter. I had one do this to me years ago. The bendix will engage, but if the brushes are badly worn, the starter motor will not turn. Most auto parts stores will test it if you bring it in.
  • Thanks, Your exactly right. I performed the repairs on sun eve. The selonoid was bad. after doing voltage tests I removed the starter and tapped on the side....It worked.. I should have trusted my first instinct about this whole thing.... Thanks again
  • max777max777 Posts: 1
    i have a 2001 blazer and i am getting no power to anny of my systoms batery has a charg and is hooked up right and all fuses are good and vehicle wont even take a jump
  • randi0411randi0411 Posts: 1
    edited August 2011
    Quote:
    "Ok here is what happens to mine and please tellme if yours did the same thing. If it sits overnight and I go out to start it, it turns over but doesnt start. If i wait about 10 minute sometimes more and turn it over sometimes it will start sometimes not. It took me over an hour to get it started last week, but once it is started it will turn over everytime after that with no problems. I just want to be sure that you had the same issues before i install a remote start. Because if my problem is different it would be a waste of money. Thank you"

    Hi, this is exactly what my 2001 blazer is doing. It just broke 104k miles. I am a college student and can not afford to fix alot of things that may or may not be wrong with it. Mine came with a remote started. Did you ever figure this out? If you did you would be helping me out a Ton!! Some have said they think it is the distributor cap, but I have no idea. Please let me know, thank you.
    Randi
«1
Sign In or Register to comment.