Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2004 Pontiac Bonneville SE Issues

josiah624josiah624 Posts: 6
ISSUE 1: My oil pressure gauge has started periodically bottoming out. I'll get the "check gauges" alert and then it will return to normal pressure. Sometimes it won't bottom out, but will suddenly dip very low and immediately jump back up to normal when I hit the gas. This usually happens when idling but not exclusively. Is this a real problem or a gauge issue? I know there's been an ongoing issue with many Bonneville owners where the oil gauge will stick at 120psi, but this issue is different.

ISSUE 2: My blower motor (for AC) has a bad vibration. How do I access the motor to see if there may be leaves or debris stuck in it?

Comments

  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,259
    To access blower motor, open the hood. Look on the plastic fascia under the windshield wipers in front of the passenger. You'll see an opening plate with two little tabs. Lift those and remove the plate. If there's a filter inside you'll remove it also, and maybe buy a replacement. With the filter out look down into the opening and you can see and reach the squirrel cage to inspect for debris.

    The Gauges most likely is a voltage problem. Check connections at all points from the battery forwrd. Tighten connections including the grounds at the battery on the floor to make sure there's a good connection. Remember the positive, red, cables are HOT. Do not allow the wrench to touch anything else!

    Then it might be battery or alternator. Most likely second would be battery itself failing. What climate are you in? Very hot much of the year? Cold, cold!?
  • josiah624josiah624 Posts: 6
    Thanks for the blower tip! I checked at lunch today and it has leaves at the bottom (inaccessible with just my hand). I'll stick my shop vac in there tonight and suck 'em out.

    Just curious why a voltage problem would only affect the OPG? Car starts fine and all other electronics (and gauges) are A-OK.

    Oh, and I live in Florida, so... :)
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,259
    There have been a few problems with oil pressure sends. Usually it's going to max. Check connections on it. And I'd think about replacing it. You could always connect a manual pressure gauge to that connection and drive for a while to see if you're getting fluctuation because of the pressure control valve that limits the maximum pressure from the pump.

    It might be worth changing oil to see if a new filter and oil affects the symptoms.

    What does the voltage gauge do during the fluctuations? A few have had a drop in voltage at low engine rpms which then catches and goes back to normal after a second. Alternators work great but there's something in the voltage regulator that's quirky.

    Problems with connections on battery usually cause more than one thing to show symptoms.
  • josiah624josiah624 Posts: 6
    Voltage has been steady. No fluctuations that I've noticed. Usually the OPG drops but then shoots right back up almost immediately. Sometimes when I notice it has dropped, I'll rev the motor and it will shoot back up immediately as well (but it would do it on its own even if I didn't rev the motor).
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,259
    How many miles on the car?

    What does the oil look like? What kind of oil and weight? How long has it been in the car? Miles?

    What filter brand was used?

    I think I would change the oil and filter to eliminate them.
  • tnt88tnt88 Posts: 1
    The bonneville starting having this issue at 96,000 miles. It is resolved, so I wanted to post it here as I come here looking for help sometimes. It would act as if the fuel was being completely shut off, then turned back on for a half second causing the car to "jump" or surge during driving and idling. It was very intermittant. The mechanic found the problem to be the mass air flow sensor. I dont know what it does, but it solved the issue. Hopefully this will help someone else. Also, as a side note, I've been filling up gas every 300 miles since the fuel guage quit reading correctly around 60,000 miles. I had the same issue with my old pontiac aztek.
Sign In or Register to comment.