Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mutifunction switch for 1999 Olds aurora 45000

explore2explore2 Posts: 5
edited October 29 in Oldsmobile
I recently had parking lights fliker and the insterment lights staying on leading to battery drain and buzzing in the stearing colum. I took it to my local machanic and he told me it was the mutifunction switch repair and cost $779 swich being $600

is this possable for the multifunction switch to cost this much? and could it be something le$$ of a problem.

Comments

  • coreyg1coreyg1 Posts: 34
    From my expierience with this same issue. I searched these forums, there is a posting with step by step instructions on how to clean the switch. This worked for my aurora. The estimates that I got were in the same ballpark as yours. I just looked online and found a new part for $400. I had purchased a used, working multifuntion switch on ebay that has remained untouched.
  • explore2explore2 Posts: 5
    Thanks coreyg1
    I found one at a local part store for $322. but the problem being the repairman said it cost him $600 from another vender.

    Have you had any other electrical problems or leaks form antifreeze Dexcool?
  • coreyg1coreyg1 Posts: 34
    I have not had any electrical issues. Currently I am dealing with a coolant leak from the radiator. It is a tiny hole, but it does go thru coolant. I am hoping it remains strictly upkeep. The estimate I got to replace the radiatior is quite high unfortunatly.
  • pscheidpscheid Posts: 190
    Re the radiator and a leak.

    I've used the Dexcool only. I had about 82K on my 1998 when I got the radiator fixed. A slight crack was located under pressure at the top neck by the hose which had probably been that way for about 1.5 years because I was losing coolant very slowly. Could smell it very sporadically but could never see a leak. Crack= it wasn't the Dexcool that caused it, nor had the car ever overheated.

    Radiator part $339 with $187 in labor. Good time to check the water pump, thermostat, and upper/lower radiator hoses if they are original: $246 parts and shop supplies and $170 in labor. My local mechanic is not cheap, but the car comes back fixed first time every time. No bring backs and no breakdowns on the road.

    Jack
  • pfarneypfarney Posts: 3
    My Aurora, after reaching normal operating temp, begins to chime & low oil pressure light comes on at low idle, goes away as soon as I increase the rpm's to about 1,000. I've replaced the oil pressure sending unit,..this problem began right after a GM dealership removed & rebuilt the heads due to excessive oil leaks. The engine never kncks, smokes, overheats, or uses any oil. The oil remains amber colored between changes. Any suggestions?
  • pscheidpscheid Posts: 190
    Did you replace the oil pressure sending unit AFTER you noticed the pressure issue or when you had the head work done?
  • I think this problem was solved and also documented really well with a procedure and photos at the website: http://65.39.242.200/~aghl/Aurora/index.html

    The problem is caused by a small amount of grease inside the turn signal lever slowly flowing over time between the electrical contacts inside the turn signal - intermittently shorts-out the headlights or parking light switches causing them to flicker on and off.

    Cheaper than buying a new Mutifunction switch is to open the existing one and just wipe away the excess grease.
This discussion has been closed.