Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Prizm Maintenance and Repair

24

Comments

  • hruiz617hruiz617 Posts: 1
    hi,
    i myself did replace all of the mounts on my 1995 geo prizm do to that annoying vibration noise, :mad: but it is still there :( ... not as loud as before but still there :confuse: ... anyone else experiencing the same and got to the bottom of the vibration? let me know... thanx...
  • I have owned my 95 prizm for 9 years. Bought it in '99 with 40k and it now has 148k. It has vibrated since the first day I owned it, with very little change. My exhaust guy told me it was probably engine mounts and so I have ignored it since. Otherwise the car has been the most reliable and best handling car I have ever owned. Looks like this problem is pretty common, but does not seem to be too serious. At least in my own experience so far. Here's hoping I can get another 100K out of it without trying to fix this problem, which seems for some reason to be unfixable. I like reading in this forum. Please keep the comments and questions coming. I have learned a lot about the car, even after owning one for a while, and thinking (smugly) that I knew it all.
    Thanks :) .
  • I have spent over $400 on mechanics replacing parts, alt and starter in what seems to boil down to a parasitic drain on the battery. Have traced this down to the fuel injector circuits, i.e. when I pull the fuse for that circuit the drain goes away. There seem to be several electrical connections but can't seem to isolate exact cause. Anyone have any thoughts or has anyone had any similar problems that can enlighten me as to how or what to replace? Thanks
  • My mothers car has simular problems. Manually shifting helps on hills. Her's is a four cylinder overhead cam. The spark plugs are located in the center of the head and about six inches down. The spark plug wells can fill with oil if the seals are getting brittle. Check for oil down where the spark plugs are. This can cause the spark to spark to be weak or completely short it out. If there is oil down there, I would suggest a valve cover gasket kit, new plugs(.042) gap, a new spark plug wire assy and a rotor while your at it. This gave us more power, however there is still a puff at the exhaust. I'm concerned this may be a burnt valve or cam timing issue.
  • Looking for a diagnosis. My mechanic says nothing shows up as problem on his diagnostic machine but I've since learned that my second fan wasn't re- installed when the radiator was replaced.
    It wasn't a problem in winter but now that it's warm my problems began including
    occasional over heating, don't know if there's any relationship. HELP!
  • aiieeaiiee Posts: 2
    Check the compression, sure sounds like one of your cylinders isn't doing it's job. Could be gasket, could be valves, could be rings if your compression is off.
  • Meant to post sooner. The problem turned out to be the head gasket. It was burnt between the #1 and #2 cylinder. Replaced it and it is running fine. The problem started out as just a loss of power and a puff in the exhaust that just was noticable. Eventually the engine began to detonate( spark knock) severely.
  • aiieeaiiee Posts: 2
    Glad to hear you got it fixed. I had similar problems with an old Ford Maverick, so I recognized the symptoms.
  • geobluegeoblue Posts: 71
    Any updates? :confuse:
  • There was a recall on Geo Prizms related to battery issue. You can call Chevy's customer service line, give them your VIN and they'll let you know if your car is one of thousands needing something replaced. No matter how old the recall, Chevrolet will fix it at no cost. Yay for recalls!
  • Thanks for your message. Will check with the Chevy customer service and see what happens, thanks again
  • sharkymozsharkymoz Posts: 3
    1995 Geo Prizm Lsi [1.8L + OD + Cruise] -ABS light comes on and stays on when driven. The system worked fine this past winter... But now I notice that while it still tests itself when the ignition is turned to ACC, the (clicking valves) sound is shorter now... And it doesn't test again when the vehicle is driven off, then ABS light comes on after a short time.
    Also, there is a strange problem with the power steering: the steering wheel shakes at low speeds. (about 0-40 MPH) And suspiciously, both of these problems happened about a month after having the tires rotated.
    I called the place that did the balance and rotation... And they said that the ABS sensors are in the calipers, and that no special steps are required when rotating.
    i dont have enough money to goto a dealer,anything i can do by changing simpe parts,
    provide me wats the problem and solution
    waiting for your reply.
  • When you bring the car to a stop sign and then proceed to accelerate it stalls. It will start back up, but every time you take off from a stop it stalls. Mostly happens after the car warms up. Getting spark, gas and air. The car has a brand new cap, rotor, plugs, wires, battery, terminals, throttle position sensor, and idle air control valve. Need help because other than that it runs really good. Would like to keep it if possible.
  • sharkymozsharkymoz Posts: 3
    guys kindly provide me a solution.m waiting with my problem..cannot proceed further.
  • hdelislehdelisle Posts: 1
    I have a 1995 Prizm and I have the same ABS light issue. It comes on after the car has been running for a minute or so, and then doesn't go off. About a year ago, when this first appeared, I was worried and took it to my local mechanic to check it with the diagnostic.

    The actual problem was not with the ABS or brakes at all, but rather with the diagnostic system and the sensor to the light. He told me that it would be a more expensive fix than it was worth, because the sensors would need to be replaced, just to get the light to go out. I elected to just leave the light on, because I knew I had brake fluid and he told me the brakes and ABS were fine. I'd have them check it, because if you've already checked the brakes and such, it might just be a problem with the light itself.
  • dutchbartdutchbart Posts: 2
    Hello,

    I own a 2001 Chevy Prizm (Toyota Corolla) and found that there's a fuse missing from the fuse box, it's the 50A fuse for ABS, I don't know if there are known issues/problems with ABS on Prizm's, and if so I'd like to know, if there aren't any issues/problems with ABS on Prizm's, then I'd like to know if simply installing that fuse will turn ABS on.

    Waiting for a reply.
  • sounds like the motor is almost burnt up
  • Where is the fuel filter on the 95 geo prism? The Ignition sensor? My car now does not turn over, but clunks and clutters in the engine? at first it just died after it started.
    Help me
    Woolychick :sick:
  • there are 2 EFI fuses under the hood in the fuse box next to th battery
  • When i strart my 2001 prism up in the morning it has a fast idle , what could cause that?
  • i can tell you that any tires you put on a prism will not help in the snow our cars are so light it's pathetic.but if you can look for some 14" rims you can run a slightly wider tire for more traction you can go from a P175/70R13 to a P185/65R14 and it will not affect your speedometer.
  • Karen_CMKaren_CM Posts: 5,012

    Community Manager If you have any questions or concerns about the Forums, send me an email, karen@edmunds.com, or click on my screen name to send a personal message.

  • it idles fast to warm up does it kick down after a bit?
  • wwestwwest Posts: 10,706
    Many of us, me included, disable the ABS except during the winter months.

    I have been involved in 2 rear-enders, me as the "offender", in the past 10 year dues to ABS activation during "panic" braking when short stopping distance was more important than directional control. First was in a 92 Jeep in ~'01 and the second was just weeks ago.

    IMMHO ABS should NEVER activate when the vehicle has VSC, Stability Control, and VSC doesn't activate.
  • jp407jp407 Posts: 1
    Just wondering if you ever fixed the problem with your acceleration issue as I am having the same problem with a 94 prizm
  • hamster65hamster65 Posts: 6
    There is no fuse for the fuel pump that I'm aware of. There is however, a fuel pump relay which should be in the fuse block under the hood on the drivers side.
  • jlash1987jlash1987 Posts: 2
    I am having an issue with my 2002 Chevy Prizm. After driving home from work the other day my wife went to start the car and it wouldnt turn over. There is one click and then nothin else. Originally I thought it was probably the starter, but after replacin it I get the same thing...

    The battery is brand new and the alternator is good. The crank shaft pully isnt locked up either.... I am at a loss here. The only other thing I can think of is the ignition switch, but if it may be something else I dont want to waste the money on the ignition switch when I can put it twords the problem. Any ideas?
  • jlrittenjlritten Posts: 2
    Hi,

    Have a 2001 Chevy Prizm... Starting yesterday it would not shift out of park and the brake lights stopped working. I thought it was the Stop Light Sensor so I replaced that, still not working. I was able to use the saftey override next to the shifter to get it out of Park and drive it home but now I need to fix it. Any ideas of what to check next?

    thanks!
Sign In or Register to comment.