Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Prizm Maintenance and Repair

1235

Comments

  • i need to find the ecu pinout for my 1994 geo prizm and cant find one anywhere i would greatly appreciate some help.
  • Hi Scott, we also have a 94 Prizm with the acceleration problems described. Did you ever find a solution?
  • Hi, we also have a 94 Prizm with the acceleration problems described. Did you ever find a solution?
  • I have a 94 geo prizm lsi and this past november 2010 I ruptured the gas tank and it was a steady stream of leakage so i got it replaced for $600 at a mechanic. My car has smelt strongly of gas for a while but no gas leakage on the floor. today as i pulled into a store the car shut off. when i tried to start it, it wouldnt start and the oil lamp was on in the car. when i checked the gas tank, its now leaking but not severely only in drops. my question: is it the tank again and is it possible to have another gas tank replacement in less than a year?

    When it ruptured last time it would still run even though it was leaking. not this time though. any help?
  • jenn89jenn89 Posts: 1
    I'm a little frustrated w/ my car because this is the second time this happends that everytime i turn on the headlights the car automatically turns off.....CAN SOMONE HELP ME on how to fix this problem...: (
  • I've just got my Geo Prizm 1997, 1.6, A/T. I got C.E.Ll and code showed P0401. I did clean every components and chek them. Looks like everything is OK. Than clear the code and it does not present at this time. But after 25-30 minutes traveling it come back........ Again and again.... Any ideas? Thank you.
  • In August of 2008, I inherited my grandma's 1999 Chevrolet Prizm with only 28,000+ miles on it, now it has 64,000+ miles on it. Recently, whenever it rains, the engine at times would beginning a sort of "rattle sound." It only does it when it's in "Drive" and does not do it all the time. Tonight for example on the way to dinner it did it, and it was raining. When I would start back up after a red light, and reach about 15-20 mph, the noise would start. We live about 25-30 minutes from the restaurant and the noise did not start till we were about 5 minutes from the restaurant. On the way home from dinner, it did not make the noise at all. A friend of mine thinks the serpentine belt may be getting wet and slipping, or may be the belt tensioner going bad.
    Again, it only does it when it is raining, does not do it all the time while it is raining, only does when is in "Drive" and not in "Park", and when it does do it, it starts and stops.
    Does anybody know what could be causing it, and if it something that should be fixed?

    Thanks!
  • shopdog97shopdog97 Posts: 151
    My daughter-in-law's sister has a '99 Prism. The engine light came on quite a while ago and the garage she took it to told her they needed to replace the cannister which they did at a very high cost, something like 800 bucks! The light is STILL on and now they tell her that she needs the Purge Solenoid Valve at a cost of nearly 400 bucks. I wish she'd have call me before she took the car to this place. They did show her on the car this valve and I'm going to take a look at it myself to see just what and where it is. She needs to have this fixed in order to pass our state's emission test. Is it true that this model of Prism is in reality a Toyota that GM just put the Chevy logo on, and if so, what model? A Corolla or a Tercel maybe? If I have to go to a junkyard to find this part, perhaps I can get one from the Toyota if there is no Prism there. This woman really doesn't have a lot of money to spend on this thing, so if anyone can help me with this I'd really appreciate it. Thanks and have a Blessed day!
  • shopdog97shopdog97 Posts: 151
    I had a chance to look at my friend's '99 Prism yesterday and see that the garage she took the car to did in fact replace evaporator cannister at the rear of the car. Then they said she also needed the cannister purge solenoid valve as well to get the check engine light off. This thing is supposed to be another $300 dollars and the guy told her he had the part at his shop ready to install when she had the money. I didn't know this until today because yesterday I went to a local Chevy dealer's parts dept. and they printed out some info for me that from the way I see it, it looks like you have to remove the gas tank to replace this solenoid valve. Is this true? This mechanic told my friend that it only takes a few minutes to replace this part. I just don't want her to be ripped off by this guy. Another thing I was told at the dealership is that this part has been discontinued. If that's true, where did this mechanic get the one he has? I know he had to go to the dealer to get the cannister he replaced. That part cost $550 dollars and the mechanic jacked it up a hundred bucks to make some money off the part. That's standard proceedure to make money off parts, I get that. So if anyone can tell me that this Purge Solenoid valve is in fact on top of the fuel tank, I'd appreciate it a lot. I'm going to go see this mechanic(his shop is only a few blocks from us)and ask him to let me see this valve he says he has and we'll go from there. Thanks again for any help.
  • I just changed the oil on my 2002 Prizm, and noticed leaking oil adjacent to the oil pan - between the two halves of what appears to be the engine block. It's where two large pieces of metal come together, and are sealed together with a gasket. Is this the proverbial head gasket, and what does that leaking oil portend? It does not appear to be severe, but there is noticeable oil wetness at the bottom part of where these pieces join.

    More importantly, what am I looking at in terms of repair costs, if that is warranted at this time? I have never had a head gasket repaired/replaced, but have always heard it is expensive.

    Would appreciate any feedback.
  • have you checked the heat shiled for the converter? i had an escort with the same problem and was a loose heat shield
  • 1996 Geo Prizm Base 1.6L

    Recently replaced turn signal, side marker and parking light pigtails driver side after small fire.

    Problem now is Hi-Beams and DRLs not working. The hibeams were working after I rewired pigtails, etc. Every bulb is new. Tried alternate 9005 HiBeam bulbs so not bulbs.

    Headlight/Turn Signal switch still turns on lo-beams, operates turn signals and the Flash Lights works but no HiBeam (dashboard) indicator. The DRL dash indicator still lights up but no DRLs. Prior to this HL/TS switch was operating perfectly.

    All fuses checked and two replaced. Awaiting one last side marker pigtail and side marker assembly.

    Any thoughts or suggestions appreciated.......could it be the DRL relay?

    Is there a method to bypass/jump the hibeams and work my way back to switch to eliminate and discover what's causing problem?

    Thank you so very much for any help
  • Kirstie_HKirstie_H Posts: 10,824
    You might have better luck getting a response in Edmunds Answers: http://answers.edmunds.com.

    If you post there and want to return to check for feedback, just go to that URL and click the "my answers profile" link.

    MODERATOR
    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

Sign In or Register to comment.