Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Expedition Engine and Performance Problems

grntdgrntd Posts: 7
I own a 2005 Ford Expedition and as the engine revs up when im pushing it, there seems to be a valley in the powerband, it stays strong down low until around 4000rpm, and then there is this sudden boast in power around 5000rpm, but then suddenly the transmission shifts and then the cycle restarts. Why would the power kind of just go away in that 1000rpm range. It confuses me as to why the Ford engineers whould set the reline so low on this engine. They sould have pulled much more available power out of this 5.4 liter V8. Is there any mods I could install to overcome this annoyance? Thank You

Comments

  • tyriptyrip Posts: 13
    i have a 97 ford expedition 4.6L&4x4- at 145000 mi.....how many more miles can i expect to get from this engine.....and also is this engine equivalent to the Lincoln Town Car?????
  • The 2003 Ford Expedition 4.6L 2WD idles fine when cold at about 1000 RPM, but upon warming the idle drops to 700 RPM. When the throttle is past 1/3 the power flattens out. The Freeze frame data from the past 5 times the Check Engine Light came on shows the following items (results side-by-side):

    OBD2 P0 Codes 171&430 P0171 420&430 171&430 P0430 P0171
    Fuel Sys1 CL CL CL CL CL CL
    Fuel Sys2 NA NA NA NA NA NA
    Calc Loan% 92.94 79.61 50.98 90.20 71.76 88.63
    ECT (f) 89 89 90 92 90 94
    STFT B1% 3.13 7.03 -6.25 5.47 -2.34 9.59
    LTFT B1% 24.22 29.69 14.06 24.22 8.59 24.20
    STFT B2% 0.00 1.56 -0.78 3.13 -4.69 -2.34
    LTFT B2%-12.50 -14.64 -9.38 -10.16 -9.38 -12.50
    Eng RPM 2608 2970 1278 2723 1434 2621
    Km/h 94 37 59 100 54 61
    Spark Adv (0) 20 18 38 23 31 21
    IAT (C) 6 18 7 17 21 15
    MAF (g/s) 78.01 81.22 18.77 70.98 25.00 63.62
    TPS (%) 61.96 45.88 22.35 56.08 27.45 49.40
    O2S B1 S1(v) 0.75 0.10 0.87 0.14 0.80 0.09
    STFT B1 S1(%) 3.13 7.03 -6.25 5.47 -2.34 8.59
    O2S B1 S2(v) 0.79 0.12 0.82 0.21 0.72 0.25
    STFT B1 S2(%) 99.22 99.22 99.22 99.22 99.22 99.22
    O2s B2 S1(v) 0.76 0.90 0.76 0.11 0.26 0.78
    STFT B2 S1(%) 0.00 1.56 -0.78 3.13 -4.69 -2.34
    O2S B2 S2(v) 0.82 0.83 0.19 0.37 0.55 0.75
    STFT B2 S2(%) 99.22 99.22 99.22 99.22 99.22 99.22

    P0171 = System too lean (bank 1)
    P0420 = Catalyst System Efficiency Below Threshold (Bank 1)
    P0430 = Catalyst System Efficiency Below Threshold (Bank 2)

    I had just replaced a bad fuel pump and filter. The two hoses going from the exhaust to the EGR EVP keep blowing out when under a full load, perhaps the catalytic converter is shot and is blocking the exhaust?

    I put the new PCV valve on the wrong valve cover so it ran with two PCV valves and an extreme amount of vacuum for a while, not sure if that messed something up.

    Any ideas on what is causing the problems would be appreciated.

    Thanks!

    John
  • You need to change your cats. I was having the exact same issue took it in and all 4 cats are gone. Had aftermarket ones put on for $1,000 and back to normal.
  • ctopctop Posts: 2

    @grntd said: I own a 2005 Ford Expedition and as the engine revs up when im pushing it, there seems to be a valley in the powerband, it stays strong down low until around 4000rpm, and then there is this sudden boast in power around 5000rpm, but then suddenly the transmission shifts and then the cycle restarts. Why would the power kind of just go away in that 1000rpm range. It confuses me as to why the Ford engineers whould set the reline so low on this engine. They sould have pulled much more available power out of this 5.4 liter V8. Is there any mods I could install to overcome this annoyance? Thank You

  • ctopctop Posts: 2

    I have a 2005 Expedition and when I accelerate harshly, It seems like something is holding back my Ford until it hits the later rpms which is usually too late. After numerous inspections and going through many forums, I was able to fix the problem. Very simply, the catalytic converters. Don't buy a Ford replacement (too expensive), but get a magna flow for each side (2) for usually around $105.00 a piece. I took it and had them installed around $200. More horsepower than before but I did upgrade the exhaust to a magna flow (around $600). Worth it. Much more power and sound!

Sign In or Register to comment.