Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda CX-9 Rear Entertainment System

13»

Comments

  • will_vwill_v Posts: 1
    Did anyone try the ribbon cable suggested buy catxnj above?
  • I did not try that one, only the one originally posted, and it lasted about 12 months before it failed (cracked). Luckily, I had ordered two cables at that time in case this would happen (pat my own back!) so I just added two layers of electrical tape to this second one before installing it and everything works fine again. We'll see how long it lasts this time around. So I guess I'd recommend you give it a try, even order two, and make sure you just solidify it a little since it is probably cheaper plastic than OEM: all you stand to lose is 5-10$ and a half-hour of your time, and if it doesn't work, you just keep the console aside until you can try something else, you can still use the car. Oh yeah, I also filed the very sharp edges of the plastic holes through which the cable runs to reduce possible wear on the cable and slightly staighten the cable's path.
  • treyi20treyi20 Posts: 5
    I am having the same problem, i noticed a small break in the strip but my dvd monitor comes on when the monitor is half closed, do you think this is still caused by the strip or would it just be a sensor that got displaced, I am also very apprehensive about pulling the dvd cover off it is very tight and i'm worried i will break it, i don't see any visible screws to remove does anybody know where any directions with pictures or videos that have the removal of this included.
  • I know it feels like it's gonna snap but have faith and just pull down on the cover as best you can and it will come off in one piece! And it's definitely the cable, no question, based on your symptoms. If it ever fails on minute again, I will make a video, but search YouTube !oand someone may have beat me to it! It's easier to replace than you think, plus no one will do it for you at the dealership, so you have nothing to lose. Good luck!
  • treyi20treyi20 Posts: 5
    do you have the specs on that cable, i click the link someone posted earlier but the listing has been removed.
  • treyi20treyi20 Posts: 5
    I found this one, it's a little longer but the width is right, heres the link http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=111030888888&fromMakeTrack=tr- ue&ssPageName=VIP:watchlink:top:en
    do you think it will work? and when pulling the cover off do you have any recommendations of hand position to pull?
  • treyi20treyi20 Posts: 5
    I found this one, it's a little longer but the width is right, heres the link http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=111030888888&fromMakeTrack=tr- - ue&ssPageName=VIP:watchlink:top:en
    do you think it will work? and when pulling the cover off do you have any recommendations of hand position to pull?
  • treyi20treyi20 Posts: 5
    Came off just like you said, I went with the ribbon cable i posted just waiting for it to come in them start the reassemble. thanks for all the help
  • theheydeytheheydey Posts: 1
    I have a same screen problem. I got cable, so I was trying to pull out the screen. BUT it is not as simple as you described.
    I pull it down as hard as I can, but I can pull it down.
    Can you describe more detail for this? Or if possible, can you make a video for that?
    Please help me. I need to fix it ASAP. My kids is waiting for it.
    Thanks.
  • campucampu Posts: 2
    Hi treyi20, did it work for you? i tried but it's either a wrong cable or i did something wrong. Thanks
  • I just fixed my res with a new cable but the first one I ordered didn't work because it wasn't same sided so ia ordered a new one that was same sided. Just installed it yesterday & it works perfect!
  • Hi bird02,
    What cable have you bought? Could you share the link?
    Thank you
  • We bought and replaced the ribbon cable and still not functioning. We had the same problem as described previously-dvd player worked when screen was only half open. Now-nothing. Any ideas? How can a replacement actually be $4500?!
    HELP! please...
  • Hi moniqc,

    perhaps you installed the cable upside-down, with the unexposed side of the ribbon facing the connection? I am about to replace mine for the 3rd time and will try to post a video.

13»
Sign In or Register to comment.