Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Envoy Noises and Sounds

This past weekend after driving my Envoy a few miles it started making this very loud clicking noise in the rear passenger side near the back gate (wheel well area). It isn't as loud on the outside as it is inside but its loud enough that I thought it would wake up the sleeping kids. When the car is off it goes away.

Since then its been doing the clicking noise whenever the car is started and then goes away after about a minute. Doesn't seem to care if the car is moving or not. The night it started we had been parked on a slope for a few hours and had the emergency brake on (we usually do this at a friends driveway that is steep). Any clues on what this? The car drives fine, no Check Engine lights either. Just a loud clicking noise!

Any help or suggestions are greatly appreciated.

-John House

Comments

  • crpndethcrpndeth Posts: 1
    I pulled out the blower motor out of my 2003 GMC Envoy cause of a noise and think I found the source of the noise, but am looking for more information on how to fix it. The sound is connected to the motor that moves this flap that moves when you switch from fresh air to recirculating air. It seems like flap always has pressure behind it and the noise occurs whenever the flap is not in motion (a kind of whine); so I was thinking either there is a clutch or sensor that needs to disengage the motor once it's in the correct position or that motor is going bad and making that sound. Any suggestions?
  • Is your Envoy equipped with the rear air suspension? If so, it could be related to the air pump, which is located in the area you speak of. The air pump runs whether the car is moving or not if the sensors indicate that the system needs air to be level. Check it out and let us know.
  • Thanks 'hardhawk' I'll check that out. I'm not sure if the car has the rear air suspension. Hopefully its nothing ridiculous to repair!

    Thanks again,
    John
  • I purchased a 2006 Envoy Denali, by and large all seems to be working fine on the vehicle. However, I am experiencing a noticeable and recurring popping/creaking noise that appears to be coming from the front end. Perhaps drivers side. It seems to occur at lower speeds, over bumps, sometimes in turns and sometimes when breaking. The vehicle drives well, alignment seems to be fine and there is plenty of wear left on the breaks. Any ideas or input would be greatly appreciated. Thanks in advance. falcon33
  • Have the front suspension links checked. These wear out as they cannot be greased because they don't have grease fittings on them. I have replaced all of mine as they failed and grew noisy. This is a common issue. Mine were replaced under warranty so I got new ones like the old ones. Next time I will get the aftermarket links that have grease fittings. Hope this solves your problem. If not, then look at the front driveline for issues. Good luck.
  • beelerbeeler Posts: 1
    fan stays on over 80 degrees I have replaced fan clutch 3 times.
  • At times when I am driving forward into a parking space for instance at approx. 3-5 miles mph; the car will accelerate. I immediately apply the brakes and the car stops. However, it is a concern for me. I would appreciate an answer and solution from someone. Also, the brakes squeak and it has gotten louder when applying the breaks moving forward or in reverse. My mechanic has checked them at least five times and tells me that the brakes have at least two years or wear. The mileage on my car is 26,500. Thank you very much.
  • I have a 2005 GMC Envoy SLT. The CD is stuck in the player. I am trying to avoid paying for someone to take it out. If anyone outthere knows how to fix this problem - please advise me. Has anyone else had this same problem?

    Thank you.
  • Please if you know of anyone who has responded to this or knows of the problem, let me know. I am having the same problem and have been for at least the last 20K miles. Some have said that its a fuel injection system...others exhaust intake.
  • when i bought my 2004 envoy, there was a cd stuck in it. someone at the dealership got it out and i put another one in and now its stuck in there as well
  • I thought you should know that while the cd was stuck I pressed the eject button at least five times to see if the cd would come out. I also drove over some speed bumps just a couple of times to see if that might jar the mechanism holding the cd. I do not know which or if both or if anything helped but about two weeks ago (last week of January 2010) the cd finally popped out. I took out the CD and decided never to use this great option again. Maybe some day I'll take the chance again - but right now money is too tight and I do not want to pay a dealership to pop it out.
  • steverstever YooperlandPosts: 40,228
    There are some tricks to try in the How to Remove a Stuck CD guide.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • frank_demfrank_dem Posts: 1
    edited March 2010
    My Wife's car is doing the same thing, after the Toyota problem I am concerned. If anybody has a clue to get this fixed, we have complain to the Dealer but it never happens when they have the car. The gas petal has a clicking noise. Maybe it has to do with the electrical problems, ie. fuel gauge, lights flickering, cruise control intermitting working,
  • I hate to say that I am having exactly the same problem, any ideas are welcome.
  • gmcustsvcgmcustsvc Posts: 4,068
    pmiranda,
    I would recommend taking your vehicles in to the dealer to have them diagnosed. Please keep me updated on your progress.
    Christina
    GM Customer Service
  • My Envoy starts making a loud noise at about 30 mph. It sounds like the transmission hasn't shifted into gear but at 60 mph the rpm's are only 1,800. Any ideas what could be making the noise? The spark plugs have never been replaced. I have fairly new Michelin tires, might that have anything to do with anything. The 36,000 mile warranty is looooong gone.

    esctothelk in Michigan
  • cparisecparise Posts: 33
    My 2002 Envoy with 130K on it just started doing this. Did you ever find out what this was? I checked my trans fluid (and other fluids) and saw it was pretty dark, but not burnt smelling. I should change it but the transmission shifts fine. The noise I am hearing could be tire whine as I replaced the OE Michelins with Firestone Destination LE's and they are clearly not as good and probably now have 30K on them. So maybe it is the tires or a tire.
    Yes, my Michelins lasted 100K and I probably could have gone longer but the ride was starting to feel compromised.
    Any input on what your problem was is appreciated.
    Chris
  • sfrancsfranc Posts: 1
    Took my 2005 Envoy to 3 different mechanics and still not fixed. Make loud whining noise and gurgling noise, it pulls the truck hard when on.. New belt and they still can't figure it out.. One of the tech said when looks at the belt in motion it hits the compressor and they say the pulleys are good.. Any suggestions?
  • Just got home turned the truck off and heard this whirling whizzing noise (airplane turbine) The vehicle is off so i went to restart it and POOF the vehicle will not start now ...all power stuff seems fine radio horn electric windows no dimming or such...Can not stop the whirring noise unless i D/C the battery reattached batter and whirring continued....
    Im stumped....
    Ignition switch stuck maybe??
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    ceichele79,

    While I can't help with troubleshooting, we can look into your vehicle's information to check for any open recalls, or provide any details about your existing warranty coverage. Please send an email containing the last 8 digits of your VIN as well as your Edmunds username and we'll be happy to do so.

    All the best,
    Sarah
    GM Customer Service
  • Just got the truck back from the shop here is the diagnosis...It appears that the GMC Envoy has a bad rap for starters...Apparently my starter blew out in the on Position....Since the starter is connected straight to the battery the relay switch on the starter itself had shorted causing it to run 24/7 unless the battery itself was DC'd
    Price of new starter...OMG $190.00
    Hope someone else may find use from this post :surprise:
  • garweegarwee Posts: 1
    I HAVE A TICKING NOISE BEHIND THE GLOVE BOX. IT IS A RANDOM SOUND AND GOES OFF FOR AWHILE . IT SOUNDS LIKE A CLOCK TICKING.ENGINE RPMS DO NOT CHANGE SOUND.I HAVE TURNED OFF RADIO,A/C FAN,NO CHANGE
  • marifranmarifran Posts: 2
    I bought my 2006 Envoy Denali in Nov. 2005. It has everything, heated seats, leather, air compressor in the back for camping, bike tires etc., 4 wheel drive, V8 engine that will go to 4 cylinders on the hwy, everything you can think of and I paid ALOT for this car. I started to hear a ticking noise. Took it to the dealer. I was told that the right lifters were out. This is on a Friday. On Monday at 3:00 I am told that the Cam shaft is out too. This car is 6 years old and only 41,038 miles on it when I took it in. This should not happen. Luckily I paid for the extended warranty and it was covered. The warranty is up in 4 months. I had the truck less than a year and it died twice in an intersection. Had to have the starter replaced twice, the driver electric seat went out, I got a recall in the mail for the fuel sensor. This truck gets the tires rotated every 5 thousand miles and the oil changed every 3 thousand miles. It is well taken care of, this should not be happening. I think this model of a car is a complete lemon and I am sad to say that I am currently looking for another car due to all the problems this car has and is only going to get worse.
  • marifranmarifran Posts: 2
    Any ticking noise on the GMC is not good, I just found out. I would take it in to make sure it's not anything with the engine like the right lifters.
Sign In or Register to comment.