Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Older Grand Prix Maintenance and Repair (1999 and earlier)

Hi,

I'm new here but am hoping to find help with a problem... the window in the rear passenger side door started falling down about 2-3" by itself. Also the switches don't seem to work, not the main panel rocker on the drivers door for that window, or the switch on the rear passenger door itself.

All other window switches work fine and other windows move up and down as usual.

We can push it back up into place, but it falls again once we drive a few miles...

I have had to replace the drivers side window works before [motor, rails & cable setup] but it never fell on its own ;-)

Any and all help is appreciated.

Thanks
«1

Comments

  • somehow the inside door clips fell off and now my passenger side door won't open from the inside or outside. any idea how i can get this door open??
  • I would try to take off the inside door cover somehow, then reach inside to the locking mechanism, if possible, the same thing happened to me too. :)
  • mine did the same and you have to buy anew motor and regulator for it.
  • when the temp is down on the car it blows heat fine, but as soon as the temp rises above 100 it blows cold air. it has a new rad,heater core. i put 3 new thermostats in to see if thats the prob, but no, new hoses. the head was checked to see if it was cracked or the head gaskets were gone, but they are fine. it is not air locked. and the whole system was fulshed about 3 times. i had it to 3 garages but they can not find the problem. help 3 kids ,winter time, and a car that blows no heat.
  • I have the same problem. Is there anyone out there that has the answer?
  • Howdy I have a 2004 Grand prix GT and my driver side passenger window did the same thing, i rolled it downed a little and tried to roll it up and it made a crunching sound and didn't do anything. It would go all the way down but then gave up and now it drops on it's own and both control switches (driver and passenger switches) don't do anything. I had to tape it up until i get it fixed.
  • i still have no heat,and i am at my whits ends.anyone have a match and some gas lol.
    nitstud have you found out the problem
  • Yes I just found out yesterday. It was the coolant. I had it flushed real good.

    Thanks you
  • Same thing just happened to me after replacing the door handle (4th one, no less!). The door opened/closed just fine, but then after the auto-lock activated, the door wouldn't open, even when it was "unlocked". I did manage to get limited access by pulling the top of the panel, but not enough to get to the problem. I ended up tearing off the door handle, then manually operate the linkages with needle-nose pliers and reach in and pull the inside door lever to get the door open!

    Coincidently, after replacing both LH/RH door handles (the RH was broke), now I have the same problem with the passenger side!
  • 04 grand prix gt blower works fine at any speed. had radiator, manifold and heater core flushed and refilled with new coolant, not the red stuff but the green coolant. worked fine for a few days and then no heat at all. i changed out thermostat and again heat for a few days then no heat at all. made sure there were no leaks and that coolant level in radiator and resivoir were full. any thoughts?
  • szaflstaszaflsta Posts: 2
    1997 Pontiac Grand Prix 3.8 engine

    My Cars cooling fan for the engine will not turn on, it should turn on when it reaches 200*f but it is turning on when the meter hits 250*f and it is to late.
    I have already replaced the fan and the censer, but the fan still wont turn on until the meter reads 250. What could the problem be?
    Anyone else face these problems?!
  • mrbonezmrbonez Posts: 2
    i have a 1996 grand prix with a 3.1 motor. i also had over heating problems but that was due to a faulty lower intake gasket that goes every 2 years, i am not sure if this will help you. i went in and the mechanic said it costs $1000 to fix it, i did it myself and i got new heads for $400. I am also looking for a 1996 3800 motor, NOT SUPERCHARGED. the supercharged ones catch on fire. if you know anyone that would be willing to sell one please let me know.
  • esoneesone Posts: 3
    Hello everyone. First off, thanks for taking the time to read my post.

    I have recently bought a 1998 Pontiac Grand Prix SE 3.1 for $600.
    When I purchased it, it had the Low Coolant light on, and check engine light on.
    I knew right off the go what the coolant light was. Damage to the intake manifold gasket due to the DexCool that was in the cooling system. I had that replaced. The Low Coolant light is still blinking, I'm thinking it is a bad sensor because I had also just replaced the radiator cap and upper hose, no further leaks are found in a pressure test. Oil was changed when intake was replaced as to get out all the coolant/water from the engine oil. This is not my main problem.

    The main problem is the car has a somewhat of a rough idle. More now than before.When you start the car (It starts fine by the way) the RPMs fluctuate from 500 RPM - 1000 RPM. It doesn't die out, but sounds sluggish. It is fine while moving, and when it slows back down to idle, it fluctuates only minorly.
    The Check Engine light I am getting is for a Camshaft Positioning Sensor.
    I know where it is, and how to change it. But, would this be the reason of why it is acting so strangely?
  • eefyeefy Posts: 1
    Yes, a faulty camshaft position sensor will cause engine to run erratic, eventually it will cause the engine to not start.
    I am in the process of replacing the head gaskets on mine but dont know the head bolt torque settings, can you help?
  • duartduart Posts: 4
    I have a 1998 Grand Prix with a 3800 engine and the colling fans will not run, regardless if the air is on or not. ( The system curently doesn't have freon in it major leak )
  • mrbonezmrbonez Posts: 2
    try checking all the wiring, you would be surprised how many problems arise due to poor connections. also make sure the wiring did not get caught in the fans and ripped off. if not, try getting an external power source and connect to the fans directly to make sure the fan motors themselves are not burned out, and also check all the fuses.
  • ken620ken620 Posts: 3
    My 97 Grand prix GT, auto, will not shift out of 2nd until I reach 45 mph. It does not have the sport shift button(option), standard 4 spd auto. I get down to 38 or so and it goes back into 2nd. The fluid level is good and the fluid looks good. I have no other issue with the trans. I have owned the car now for about 6 months and it"s done it since i bought it. I dont know if the filter has ever been changed. I'm thinking so since the car has 263954 miles on it. It still runs strong and doesn"t use much oil (engine). Could this be a pcm issue or maybe just needing a new filter.
  • dlucoredlucore Posts: 1
    have broken shift cable that goes from the steering coluim to the transmission. cant find an replacement cable new used or after market. Any ideas?
  • rach514rach514 Posts: 2
    I have a 98 grand prix gtp that sort of does the same thing. I mean I was told by my transmission guy that my 3rd gear was gone. I just took it to him yesterday. I just bought my car about 3 weeks ago. I didn't notice the problem until I had it a couple of days. It runs smooth but I when I get going about 35 to 50 mph my rpms are running between 2 1/2 and 3 grand then it shifts and everything is ok. But if I am going through town and only need to run between 35 and 45 mph it doesn't shift. I don't know what to do with mine. Maybe we could kinda help eachother out with any info we get. Thank You and I hope it will be a cheap fix.
  • rach514rach514 Posts: 2
    Hi I have a 98 grand prix gtp I just bought about 3 weeks ago. When I was driving home the other day I don't really know what happened but thats when my problem really started. My car if I am running between 35 to 50 mph my rpms run about 2 1/2 to 3 grand and then suddenly it shifts but if I have to only anywhere between 35 to 45 mph my poor cars rpms are running way to high. I was hoping maybe someone had some answers or suggestions for me. Any and all would be greatly appreciated. Thank you
  • 1stsgtrock1stsgtrock Posts: 2
    Okay, I know there are probably several discussions regarding starting issues here. But here is my situation. My 96 Grand Prix Coupe will turn over but does not start. My wife was the last one to attempt starting it. She said that the Battery light came on. So I charged the battery. Attempted another restart and still same situation. Now my Fuel gauge reads full yet I just added about 2.5 gallons of fuel to the car. Still will not start. Anyone have any suggestions as to the problem? Is it a fuse? Pump? Crank sensor? Would any of these things cause the fuel gauge to read full?
  • i have a 92 grand prix. i have replaced so many things over the last few years including: timing chain, the housing, the gears, spark plugs and wires, alternator, starter, a helio coil for the spark plug. but what i am trying to get at is this, after my timing chain broke and had it repaired, the car won't idle unless you have your foot on the gas pedal. it will start no prob but won't stay running. does anyone know why this is? is it something internally wrong with the motor? is it something i can fix easily?
  • bishop03bishop03 Posts: 1
    i have a starting issue as well...my car ran rough for a while like a few days wouldnt stay running in idle. this morning i went out and it wont start at all...could be so many things wrong...where do i start?
  • thatazguythatazguy Posts: 9
    Get some dielectric gel, high heat if they make it, and do all the harness connections you can, starting at the firewall connection (in the cab) all the way to the computer. (TCM) Please let me know if this helps. The old mechanic that had me do this also was blasting the backs of the harness connections with PB Blaster to eat any other green (corrosion) that we couldn't see on the connections. Gel 1st though. Squirt a bunch on, then wipe excess. I tried to keep the tip of the gel square with the plugs to force the gel into the connections. My Dodge now shifts from 2nd to 3rd much better, until it gets hot. =)
  • tinag1tinag1 Posts: 1
    My car keeps over heating I have replace thethermostate and radiator the radiator cap water pump and I'm still overheating.when I pull over and unscrew my pressure values nothing but air comes out also my antifreeze. goes back into my overflow
«1
Sign In or Register to comment.