Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





a/c and heater fan not working.purple wire not connected.

johnnybravo3johnnybravo3 Posts: 7
edited May 30 in Chevrolet
I have a 1997 Cav.4cyl.2.2 I just bought.The a/c,heater fan and control lights don't work.Theres a purple wire laying on the console coming from under dash in middle of car. Does this wire run the a/c , heater fan? Another question when driving at lower speeds(30 to 40) car temp is over the halfway mark, as I go faster the temp. starts to climb to the red line.Is this a thermostat or plug radiator problem? Where does the purple wire go?Thanks John.

Comments

  • I have a 1997 Cav.4cyl.2.2 I just bought.The a/c,heater fan and control lights don't work. Another question when driving at lower speeds(30 to 40) car temp is over the halfway mark, as I go faster the temp. starts to climb to the red line. After it stays in the red line for about 15 to 20 mins.The guage drops to zero stays there for about 2 or 3 mins. and goes back up to the red line.Could it still be air in lines?The engine fan runs all the time.Change the thermostat and flush out the system.Bleed the air out using the bleeder screw.Thanks
  • My over heating was from the head gasket.Had it replace ,no over heating. Still can't find out whats wrong with the a/c,heater fan and control lights that don't work on the controls for a/c.Thanks
  • Well here is what I've done so far.Tested fan motor-ok,replaced resistor,still no fan speeds. replaced relay under hood.Check all fuses.Changed fan speed switch. Did I miss something?? Still no power. thanks.
  • wes26wes26 Posts: 1
    The heater in my '86 Suzuki Samurai does not work. Fan OK, replaced thermostat, and replaced heater control valve, heater still doesn't work. Any ideas
This discussion has been closed.