Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Wrangler Maintenance and Repair Questions (1997 - 2006)

1333436383961

Comments

  • look on the turn signal lever for it
  • :lemon: I posted earlier with problems with my new 2007Jeep 4x44dr having a problem with what is called the "death wobble" It has now been back to the dealer 4 times and the last time someone from Chrysler actually came in and replaced the steering dampener. I am still having the problem and I now have a lovely $30,000 lawn ornament. Has anyone had any luck under the lemon law for the death wobble? :lemon:
  • I have a 2001 Wrangler. This morning I thought it felt like the fan was blowing cold air even though the heat was on. I noticed on the way home after work that as long as I am moving the air is hot, but then when I stop it gets cold. I've ready a bunch of different things about the heat core and vent flaps and such but wanted to know if anyone could help narrow it down for me before I blow a lot of money fixing something that maybe isn't needed!
  • I HAVE A 97 WRANGLER 4 CYL. I AM HAVEING A PROBLEM WITH A ENGINE LIGHT COMING ON. THE CODE AT ADVANCE AUTO IS FUEL SYSTEM LEAN. I HAVE HAD A O2 SENSOR RP\EPLACED A BOUT 6 TIMES SINCE MARCH.
    CAN ANYONE GIVE ME ANY IDEA WHAT MAY BE GOING ON. THANK JD.
  • I have a 1997 Jeep wrangler 4cyl. When i start my jeep up it runs fine for about 30 sec then starts to idle very low and rough. It continues to do this for about a minuite or 2 then starts to idle ok again. The same thing happens when i first start the jeep and drive it. It drives ok for about 10 sec then starts to run rough and backfire if i dont let off the accelerator. If i do let off the accelerator it does the same as i explained in the first sentence. If i dont let off the gas it wont accelerate and backfires. If i press in the clutch and rev it up for about 5 sec it will stop doing this and drive fine. Also, The engine has to turn over more than it should to start it, it lags a bit. The problem occurs mainly when the engine is cold or hasent been driven in half an hour or so. Please let me know if anyone knows the problem.

    Thanx.
  • I have replaced every sensor under the hood connected to the throttle body even the tps sensor. But when i come to a stop the engine idles around 1100rpm then drops down too 900rpm all the time. any suggestions?
  • check your timing. make sure it's in spec. make sure it's not retarded too much.
  • roadburnerroadburner Posts: 6,673
    But when i come to a stop the engine idles around 1100rpm then drops down too 900rpm all the time.

    My 1999 Sahara does the same thing- especially when ambient temps are over 70F. It drives me nuts.

    2009 328i / 2004 X3 2.5/ 1995 318ti Club Sport/ 1975 2002A/ 2007 Mazdaspeed 3/ 1999 Wrangler/ 1996 Speed Triple Challenge Cup Replica

  • I have a 2004 that the instrument cluster just went out. The fuse is good, and i checked all the wire harness and did not find a smoking gun. I look to try the instrument cluster disconnect but could not find it. Any help? Also, the overhead lights do not work.

    Thanks
  • erickplerickpl Posts: 2,735
    You may want to do a physical check while it is idling and see if the throttle cable is returning to full closed position. I have a hand throttle and if I forget to turn it all the way off, it has a similar effect.

    If it is idling that high and the cable is good, perhaps take it to Autozone while it is running and have them check to see if any codes are being thrown.

    -Paul
  • erickplerickpl Posts: 2,735
    1. Remove cover over defrost vent. Pries right out.
    2. Remove 3 screws underneath holding on top of black dash cover.
    3. Remove knee panel with 2 phillips screws.
    4. Remove metal panel under knee panel with 2 phillips screws.
    5. Remove 2 screws holding on lower portion of black dash cover and remove cover.
    6. Remove 2 screws holding on dash. Pull out.
    7. Check contacts for wear/oxidation/dirt. Clean with denatured alcohol and q-tip. Be sure all pins are straight. Coat with dielectric grease for good contact.

    Reattach is reverse.

    For overhead light, ensure Fuse #4 is installed and good.

    -Paul
  • roadburnerroadburner Posts: 6,673
    If it is idling that high and the cable is good, perhaps take it to Autozone while it is running and have them check to see if any codes are being thrown.

    Cable is good and no codes. I also cleaned the throttle body, no joy...

    2009 328i / 2004 X3 2.5/ 1995 318ti Club Sport/ 1975 2002A/ 2007 Mazdaspeed 3/ 1999 Wrangler/ 1996 Speed Triple Challenge Cup Replica

  • Man I had the same problem for years!!!!All you have to do is disconnect the o2 sensor! I know sounds wierd but thats all it is . Next time you start it up and it starts its crap, go underneath the jeep and disconnect the sensor ( it's pigtailed so it will just unplug) and thats that! The only down fall is your check engine light will come on . Now on mine there is a pre- catalytic and post catalytic O2 sensor but they run in sequence! So undo 1 and it wil overide the other! Trust me give it a try it took me years and all my patience to find this bug!!!!!
  • My airbag light recently came on on my 97 wrangler. At the same time I noticed my horn was no longer working! Iv'e checked the fuses and they look o.k.I even removed the airbag module from the steering wheel to see if the wires were broken or severed....nothing. Any ideas other than replacing the whole system....can get quite pricey?
  • Your JEEP idles rough and backfires because it is caught in the money sucking vortex of The Dodge Chrysler JEEP Corparuption.

    I have had the O2 sensors replaced replaced on my fine 99 three times.
    I think the solution might be to put an "Off Road Only" exhaust system on and stab the check engine light with an ice pick.

    ...ice pick, ice pick, ice pick. I might have found the perfect tool for negotiating with the smiling non-Service Manager- at My Friendly JEEP Dealer.

    ????Dealers????

    Why do those who sell cars go by the same name as those who stand on the corner an sell crack?
  • The shifter used to shift gears with makes rattleing noises all the time...like something is loose where the shifting actually goes on. This happens while driving and already in gear or changing gears. Is this normal for a Jeep or could this be problems? If so, what kind of problems and what is the fix for it? Something a mechanic would have to fix or something a novice could do? Repair cost? Thanks for your help!
  • erickplerickpl Posts: 2,735
    Your transmission mount, that attaches the transmission to the skid plate, may be loose or broken. It is NOT a hard fix and the part is not expensive at all (less than $30.00 IIRC).

    -Paul
  • Paul, thanks for emailing...how do I get to this in order to replace it (inside of jeep or underside)? Do you by chance have any instructions? Thanks so much, Vicky
  • I am having the same exact issue w/ my 1997 Wrangler as well. Did you receive any info on what may be the issue or a possible solution yet?

    I have to take mine in for inspection next month, was hoping it is not a pricey fix ;-)

    Any info is greatly appreciated - thank you!

    Craig
  • The only response I received was to pull the boot/console off and check the skid plate that attaches to the shifter and make sure nothing is loose and that it's not broken. I'm just not sure how to take that apart! :)
  • is that in reference to my reply about the air bag light/horn not working????
  • mac24mac24 Posts: 3,910
    The transmission mount has to be replaced from under the vehicle.
    If you look underneath below the doors, you'll see a large plate about two feet wide that goes from one chassis rail to the other. The plate is attached to the chassis by three bolts on each side.

    In the center, on top of the plate, is the transmission mount, and on top of that is the transmission. The transmission mount is attached to both the plate and the transmission by bolts.

    To remove the mount, first support the front of the transmission where it joins with the engine using a jack stand or blocks. Next, remove the bolts that secure the mount to the plate. Then, while supporting the plate, remove the three bolts on either side that secure the plate to the chassis and carefully lower it out of the way. Finally, unbolt the transmission mount itself.

    Reverse the procedure to replace it. You can easily do this job yourself if you have a floor jack for the support and lowering of the plate, otherwise you'll need the help of a friend.
  • mac24mac24 Posts: 3,910
    This is invariably an issue with the clockspring, which is a device that allows the steering wheel to rotate while maintaining electrical connections to the column.

    Either a faulty clockspring itself, or a poor connection to it, usually the ground.
  • Hi Mac24...the sound sounds like it is right there inside the Jeep where the boot that covers the shifter is. Do you still think it's the transmission mount or could it be something loose inside that boot? If so, does the boot pull off easily?
  • mac24mac24 Posts: 3,910
    If the mount is bad it can allow the whole transmission to vibrate, which in turn will cause the shifter to shake and make noise.

    However, there are a few other things that can cause the same thing but unfortunately, while they can be fairly easy to rectify, most of them require the transmission to be removed to access them.

    To remove the boot you just need to unsnap the bezel, then the pull the boot up the shaft. You should then be able to see (a) which (if any) parts of the shifter or its mating parts in the shift tower have excessive movement, and (b) how little room there is to do anything at all through the hole in the tub.
  • erickplerickpl Posts: 2,735
    Vicky, basically, you need to support the transmission with a floor jack or jackstand, then remove the 6 bolts holding the transfer case skid on the frame (aka the shovel) as well as the 4 bolts holding the transmission onto the skid plate. Once you remove those 10 bolts, you can remove the skid. The mount is on the bottom of the transmission and just bolts on.

    -Paul
  • skyking49skyking49 Posts: 112
    I noticed that the knob that selects the direction of the heat may open vents. I make sure its all the way to the left now and will see if that was the cause of my water problem. When I turn it all the way to the left you an almost hear the vents closing. Who knows?
  • I've got a Stright 6, 4.0 2005 Wrangler Unlimited.
    Yesterday my CEL came on. I was able to get the Diagnostiv Code just not sure what it means in English! Help
    P2096 Post Catalyst Fuel Trim System Low Limit
  • Ok, So I have been looking online until my eyes have crossed, and am really not coming up with much. I have found references for Dodge ect, but nothing really referencing Jeep. Anyone have any experience with this code and thier Jeep!
  • erickplerickpl Posts: 2,735
    Take it to autozone (or call em) and ask em what it means - they read the codes for free.

    -Paul
Sign In or Register to comment.