Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Isuzu Trooper TOD and 4WD Problems

2

Comments

  • chappechappe Posts: 2
    Thanks Claudiok! I will have the vacuum hose checked. I appreciate it! Hopefully it will not be an expensive repair.

    Best of good fortune in 09!
  • Maybe no big problem, but...99 trooper with new tranny and rear end, all works great but the rear wheel indicator light on TOD display does not light (front wheel indicator is fine). Could this be a bulb or something in the switch? Light actually stopped working before differential was changed and months after transmission was rebuilt. Any suggestion welcome.

    Thanks,
    sparky39
  • brentb1brentb1 Posts: 18
    if the check light is flashing(red)pull your codes yourself manually this will lead you in the correct direction.i have a 99 trooper tod and have been going through all this to.have learned a great deal on how and what to do so far.if the tod doesnt work(4wd high)shift into low and see if you have 4 low that will help isolate the issue also.let me know..
  • brentb1brentb1 Posts: 18
    i have a 99 trooper with a tod code 31(electromagnetic coil)has anyone had this and what was the fix.the only thing i know is to replace the t-case and hope its good.is there a way to check the coil?could it be wiring also?thanks......id hate to swap out t-cases and have the same issue but i need the 4wd high(tod)fixed asap.........
  • I have a similar problem. 2002 Trooper, 105k miles, just had trans rebuilt, now at 40mph or faster, when coasting (foot off gas pedal) the 4WD kicks in full 4WD (meaning all four wheel lights on dash are lit in full). It does not matter if TOD auto is on or off. Problem exists either way. I can hear and feel the 4WD kick in. If I just reapply the gas the 4WD disengages and goes back to original setting (TOD auto or 2WD). If I am breaking and the speed drops below 40mph then the 4WD disengages and goes back to original setting.

    Could this be a vacuum problem? Others have said there is a breather on the transfer case, and that if the diff lock comes on while driving it could be the breather is blocked, causing some sort of pressure or vacuum inside the diff that activated the diff lock. The guy at the trans shop is puzzled, he thinks it is something electrical, perhaps a feedback sensor that passes through the trans that is telling the computer the rears are slipping and to go into full 4WD.

    Any help is appreciated.
  • Thanks for the help. I will try that tomorrow. The 4 wheel drive works fine it's just that the light no longer shows how much torque is going to the rear wheels. The light was okay till I had the wheel bearing on driver side replaced. The new tranny and differential seem to be fine, but the light bugs me! After spending so much I guess I just want everything to work. Glad to have help from someone with same trooper. Not many here in Connecticut. Thanks again...
  • brentb1brentb1 Posts: 18
    i have a 99 trooper and have tod code 28 which says axle disconnect output & axle switch output abnormal.can anyone tell me what this means,where its located and what i can do to fix it.thanks.
  • popz1947popz1947 Posts: 4
    Hi
    When I push the Torque on Demand button on the dash of my 2000 Trouper instead of the display going to Auto and everything turning green, I get a red error where it usually would show Auto.

    Does anyone have any thoughts as to what is no working correctly? and hopefully it won't cost a fortune to repair the problem.

    Thanks for any of your help.

    Popz
  • isu2isu2 Posts: 8
    i have the same issue
  • rfleminrflemin Posts: 5
    I've got a '98 Trooper with TOD. Several times lately, it has "paused" while on a bumpy alley -- it didn't completely die, but the POWER, etc. lights came on and it seemed to be driving at a lower gear, then back to normal. Once it died, but restarted once I shifted to Park. About an hour and a half ago, it did the 'pause', but kept running. Ten minutes later, it died, would not restart, and the TOD Check light came on and flashed. I put an OBD II tester on it, got a "Link" display, but nothing else. I coasted down to a parking spot and walked home to do a little research. I'm going back to see if I can find loose hoses or wires around the transfer case and to pull the battery cable. Anybody got any idea what could cause both the TOD Check light and Won't Start? And what I can do about it?
    Oh yeah -- about three months ago, the transmission died (no second gear) and I had a used one put in. This happened out on the boonies and the transmission mech said he couldn't get rebuilds, so to go with the used one. It's been a little cranky about shifting into Park ever since. Maybe something wasn't installed as tight as it should have been? Thanks for any advice.
  • Tod check light on my 2002 Trooper flashes codes 13, 14, and 24.

    Bought a shop manual on CD.

    Shorted pin 8 on C-63 to ground and generated aforementioned trouble codes. Presumably, the code 13 (reference short circuited to ground) is causing the other 2 speed sensor codes.

    Per shop manual, pin 15 on the TOD Control Unit is connected to pin F-11 on the Powertrain Control Module through connectors B-49, H-12 and H-57 respectively. Disconnected wiring harness from TOD control unit and read direct short to ground on pin 15 of plug B-49. Went to pin F11 of connector E-54 on the Powertrain Control Module and read no continuity to pin 15/B-49 or short to ground. I did have continuity between F11/E-54 to pin 16 on what I believe to be connector H-57. The connector between H-57 and B-49 is H-12.

    DOES ANYONE KNOW WHERE H-12 IS LOCATED? I have practically torn the car apart looking for this connector. The parts location page in the manual is of little or no help. I am ready to rig a jumper/bypass wire from pin 15/B-49 to pin 16/H-57 and hope for the best. All suggestion are welcome.

    p.s. I have just replaced the second transmission in two years. I am presuming that someone pinched a wire during the process causing the TOD short circuit issue.
  • anywayanyway Posts: 6
    I have a 1996 isuzu trooper and for some reason my dashboard is making this clicking noise and the battery light brake light and other lights come on. Then when the clicking starts my sensors to show if i am over heating or if the battery voltage is low starts to go back and forth like crazy. Can someone please tell me what that is and how to fix it. I am just hoping that i am not on the freeway driving and my car stalls because of this problem. :sick:
  • I think my car is stuck in 4 wheel drive. I got in the car today and the Torque on demand rear wheels are lit up green, I have no idea how this happened or how to fix it.
  • rfleminrflemin Posts: 5
    Whenever this happens to me, it's because I hit the AUTO button on the dash instead of the Hazard (4-way flashing lights) button that is right next to it.
  • I just bought a 2002 Trooper with 95K miles on it. The TOD display is blinking all four wheels and the CHECK light below the display. I read a bunch of the posts here and figured it was the VSV like others have talked about. The Blue swich was broken so we replaced both of them. The problem is still the same.

    the Auto switch does nothing. If you have the 4wd shifter in 4 wheel high truck drives fine. Can't get it to shift into 4 wheel low but if you put the shiter into Neutral (I assunme this is correct) the truck is literally in neutral no matter what gear the column shifter is set for. I am about to lose my mind with this thing... Can any one help me with this? Could it be the TOD ESM? The speed sensor I read about? Also the ABS light is lit, could that have any significance?
  • Just to follow up: I replaced a relay and got the Trooper started, but it kept acting funny and finally died. I had it towed to a shop where they said that the battery had overflowed (don't think so, cause it was fairly new and I had just washed off some corrosion) and the fuse box was badly corroded. They cleaned and rewired the fuse box and replaced the battery and the Trooper has run fine ever since.
  • I just bought a 2002 Trooper with 95K miles on it. The TOD display is blinking all four wheels and the CHECK light below the display. I read a bunch of the posts here and figured it was the VSV like others have talked about. The Blue swich was broken so we replaced both of them. The problem is still the same.

    the Auto switch does nothing. If you have the 4wd shifter in 4 wheel high truck drives fine. Can't get it to shift into 4 wheel low but if you put the shiter into Neutral (I assunme this is correct) the truck is literally in neutral no matter what gear the column shifter is set for. I am about to lose my mind with this thing... Can any one help me with this? Could it be the TOD ESM? The speed sensor I read about? Also the ABS light is lit, could that have any significance?
  • Hello,
    I have a 1999 Acura Trooper, I mean Isuzu SLX, no Acura SLX yeah that's it Acura Slx that I am have problems with the TOD/AWD system. The first thing is when it is in 2wd the rear wheels on the TOD display blink instead of being permanently lit all the time. then after driving for a few minutes the red check light starts flashing. When you hit the TOD button the auto light and the front wheels light up on the display and the check light goes off. Then the second thing is when you engage the AWD and drive for a few minutes you feel a clunk and the AWD dis-engages and the light on the front wheels of the display go out and the auto light starts flashing and the check light goes on. If you stop the car the AWD will engage again for a few minutes then you feel that clunk again and it dis-engages again. Does anyone know what is going on here and can help me with this problem. WInter is almost here and I basically have a 2WD car now.

    Thanks,
    Bill
  • I have a 1999 Trooper with 180k miles and the front wheels will not engage when the 4WD button is pushed. The shifter seems to do it's job, but nothing will get the front wheels turning. I would love to think it's a vacuum hose, but I really don't know and am looking for hints.
  • isu2isu2 Posts: 8
    there was an article earlier about the small plastic gear on the front axle that engages the 4wd. apparently it gets all gummed up and needs cleaning.
    there was an internet article on how to remove and clean and reassemble.
2
Sign In or Register to comment.