Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Hyundai Accent Hatchbacks

1424345474858

Comments

  • phillbillphillbill Posts: 93
    Rear speakers, easy!
    Just undo the four screws holding them in (assuming the design is the same as my 1999 accent where they're either side of the rear shelf, not hidden behind any trim or anything), the speaker will come out, pull the old wires off, and bin the old speaker.
    Now get your new speaker, connect the wires up (making sure the negative goes on negative, and positive on positive), screw it back in, and you're ready for some subwoofing sound :D

    Now the front door pannel...caused me some grief when i had to replace my window regulator....but there's a nack!...

    Get a thin flat head screw driver, push it down the side of your window winder, turn the handle, you may hear some clicking, then POP...a lil horse shoe clip will come off, so the window winder will jus pull off.

    Now there's another tricky bit...the door handle, took me ages to figure this out...you undo all the screws (for me it was two in the big handle, two in the pannel near the hinge, and onw in the pull handle) also unscrew the plastic door lock, pull the door trim away from the door so as to un-pop all the lil clips, and now here's the trick, turn the trim though about 90 degrees, now you should be able to push the lil door handle through it's hole, bit of a sqeeze though.

    Now unscrew the old speaker, bin it, and put the new speakin in as before. For me i had to make a wooden frame for the new speaker, (which took quite a while) as it had different mounting points.

    Once the speakers in and connected, just put the trim back on, pop the lil clips in, put all the screws back in, and you're ready to put the window winder back on...just put the horse shoe clip back in the handle (u'll see where i mean) and push the handle back on, it should clip back into place. Screw the lil lock thing back on....and you now got a neat sound system to really annoy the neighbours with :mad: lol
  • przehoprzeho Posts: 10
    Thanks for the detailed info. I'll tackle this project over the weekend. It looks like it might take a while. I'll let you know how it turns out.
    Thanks again. There is always a trick of the trade! Your info should make the project a lot easier.
    Paul :)
  • phillbillphillbill Posts: 93
    not all the time, but every now and then, when i'm going slowly in one of my gears, like 15mph in 3rd for example, i hear a small grinding noise coming from the drivers side of the engine bay (right hand drive car), could this be the CV joint worn out? It's the only obvious thing i would think of, but when it went on my sisters car it was more of a clicking sound when turning the car on full lock.
    I've had a look at the CV joint...but cant see any obvious signs of wear.

    The sound goes away again once the engine speed picks up. It also seems to slow down (got a lil bit of a rythem to this grind lol) as the wheel speed slows down...

    I changed the gear oil as scheduled about 2 months ago with Castrol SMX-s, as instructed by my manual, engine oil's been drained flushed & re-filled recently along with the filter, so i doubt it's to do with poor lubrication of major engine / gear components.

    Sounds like one of them sounds that comes about when a components tryin to say "i got a good few 1000 miles in me still, but i'm gettin tired, and when i pop im gonna make a real mess...so you better replace me now!" lol

    So any help on what could need replacing given the symptoms would be usefull...thanks
  • geeragegeerage Posts: 3
    My tail lamps are just not coming on. Niether when my lights are on nor when I depress the brake pedal. The third brake light still works when I hit the brakes though.

    I have a 2001 Accent GS Hatchback I have changed out the bulbs, relay and fuse
    still nothing.

    Any guesses?
  • phillbillphillbill Posts: 93
    On my 1999 Accent, i can see three fuses to do with the rear brake lights / side lights.

    There's the main fuse, in the fuse box that's in the drivers side of the cabin, then there's two other fuses, one for each bulb. On my car these are in the relay box in the engine compartment. Try changing these two, you may have been unlucky and had both of them blow at the same time....good luck....near me police are stopping people and handing out heavy fines for faulty bulbs etc.
  • paul02paul02 Posts: 1
    Does anyone know about which factory head units can swap between years? I have a 2002 Accent with a cassette player and would just like a factory CD player in its place.
    Thanks.
  • geeragegeerage Posts: 3
    Thanks, but I tried changing the bulbs, fuses AND replaced the relay with an OEM one. still nothing I am really nervous about getting pulled over cause I am broke!!
  • lakesidelakeside Posts: 1
    My alternator went over the weekend on my 2000 Accent (3 door, auto, 1.5) and I'm debating whether to buy a new alternator or a used one. The car has 248,000km/154,000 miles, mostly highway, and for the most part it's been good to me. I've keep all my service records and have a detailed summary record in Excel. Besides the usual maintenace (tires, brakes, belts, plugs etc), the problems I've had have been mainly electrical, like air flow sensors and diodes. I had a coil replaced a month ago after I lost power while driving. This weekend I was driving near home and lost power while driving again but had enough juice to get home. Got a boost and drove the car down to the garage where they say the alternator is shot. Should I bother buying a new alternator and risk it making the rest of the engine work harder or go for a used one as am leaning on getting a new vehicle in the summer/fall.
  • phillbillphillbill Posts: 93
    First of all actually make sure the alternater is actually bust if yr gonna replace it...there's a technical test we use in car ellectronics called 'the wriggle test'....just locate the wires coming off the alternater and give them a quick wriggle, somtimes it's simply a case of a wire that's become loose over time, or a bit of muck that's got lodged between the connections...see, i warned you it was a very technical procedure...

    If this is no use, i'd go for the replacement alternator, i dont think it'll make a difference if it's old or new when you think about what it is, it's just a big spinning magnet that cuts through three coils of wire to produce a current. As long as the unit works, a new one should cause no more strain on the engine than an older one. If you're fiting it yourself, which you may as well, i replaced one on an escort within 45min. (luckily there were no extra pullys for power steering, air con etc, was nice and simple like on my 1999 accent :D , i know someone who works for Subaru, it's a whole different story with modern performance cars, takes ages, the fan belt snakes half way round the engine bay via various pullys lol)

    You just gotta make sure the belt is at the right tension, which i can't remember off the top of my head, but it'll be in your car manual, or a hyundai accent haynes manual. Too loose and it'll slip, sounding like a squeeling cat, too tight and it may cause some strain....hope that answers yr question?
  • benricksbenricks Posts: 1
    Does any one have info. on miles per gallon on the new 06 ACCENT? Should be improved with the new CVT engine.
  • phillbillphillbill Posts: 93
    For lakeside who's alternator's packed in on his 2000 Accent...

    If you don’t fancy spending up to £250 (if you go to your dealer that’s probably what they’ll charge, however there are places that will sell some makes of alternator off for just over £20 if you know where to go) on a new alternator you could do some fault finding…

    Remove the alternator by loosening the long bolt that you see as you look down on top of it, until the belt is slack. Unplug the leads coming off the alternator, unscrew the remaining bolts holding it on, and the alternator should come off.

    Now get a marker pen, and draw a line down the side of the alternator, this will allow you to line the two halves of the alternator up the right way round when putting it back together. Because some alternators are universal, and can be put back together two ways, so that they can fit on an engine where it fits on the front, or on the back.

    Remove the regulator, this is a small, almost rectangular, about one inch by two inches big device, it regulates voltage at 14.5V. Just undo the small bolts holding it on, unplug the lead, and slide it out, you should see two brushes: rectangular rods of copper. Now, (a) check they’re both there and are the same length (b) make sure they’re in good condition (c) make sure you can push them in easily and that they repel back out fast. It may just be this that needs replacing.

    Regulator’s ok…then dig deeper…there should be three large screws holding the top half of the alternator on (the half that doesn’t connect to the fan belt), they stretch the length of the alternator. Take the nuts off these, and the nut that holds the wire down that’s connected to the rectifier, a device which turns the AC current into DC, inside the alternator. This should now pull off to reveal the Stator (lots of colourful windings of copper wire, green on my Accent), the rectifier, which looks like two or three layers of plastic with many electrical components welded together on it with three copper wires coming out of it at the base, and the rotor, more copper windings which act as an electromagnet. The magnetic force gets amplified by those teeth like steel structures surrounding the rotor.

    Now check the actual bearing pack on the cover you’ve removed, on most alternators, if this needs replacing you can get a load of grease, put it in where the bearings are, get a chunky rod of metal that's a flush fits, get a hammer and hit the rod of metal down, the pressure build up pops the bearing pack out.

    Now look at the two rings which the brushes brush against on the rotor. They should be smooth and perfectly circular.
    If not, this can usually be pulled off and replaced.

    If there is lots of scorching / burning on the rings, it is showing that the brushes are bust, they’re not moving in and out fast enough, causing sparks which leads up to build ups of impurities on the brushes and rings. Don’t just give it a polish and put it back together like they might do down your local garage which will give you only a few 1000 more miles of happy motoring, replace the brush unit and the copper rings (slip rings) if they're bably damaged, the brush pack should separate from the regulator, depending on make. Otherwise the whole regulator needs to be replaced.

    You won’t get these parts from your local auto store, you’ll need to go to a specialist.

    Well hopefully this will have sorted your alternator out, these are the easy to diagnose faults, and these little parts, like a bearing pack are only like £5, rather than a few hundred for a new alternator. However, this is just the tip of the ice burg when testing alternators.

    I can go into how you can test individual diodes in the rectifier pack, test for voltage leakage from the stator windings and the rotor, continuity in all the wires & windings, but this involves unsoldering parts and getting into a bit of a mess if it’s your first time at anything like this, especially when soldering near diodes, they don’t like heat! Just ask and I’ll tell you the tricks of the trade though.

    Putting it back together, do the exact reverse of taking it apart, remembering to align up the two halves, and making sure you slide the regulator in last, after the cover's been bolted back on, or you’ll snap you’re bushes off if you screw it back onto the cover before putting the two halves back together.

    Put it back on the car in the same way it came off, and using the big long bolt, tighten the belt up to the correct tightness….oh and re connect the wires going to the alternator…always helpful :D

    If you’re thinking of taking it off in the first place and looking for the fault, then you should really know how to test the individual electrical components, which I will happily dive into. Even though it takes a lot of explaining, the tests are all very simple to do and can be done within half hour. However if you’re planning on spending £70 or so getting your alternator serviced by specialist, or putting a new one in then I may as well shut up here.
    Word of warning though, I’ve never taken off and replaced the alternator on my Accent, only done it on a ford escort while studying vehicle electronics at college, and I’ve only ever stripped down an alternator from a Mercedes, so I can only guarantee that what I’ve said in this message is correct for those makes and models, the procedure may be slightly different for Accents, but it should be pretty much the same.
  • phillbillphillbill Posts: 93
    Geerage, you could try some fault finding on your brake light system...

    Can’t really think of any other components in the brake light / side light system that could be faulty, because the actual brake light switch must be working if your middle brake light still comes on, only thing left are the actual wires and connections...unless the more modern Accent is all posh with multi plex wires...gets kinda tricky then :cry:

    If you’re not planning on spending a fortune at a garage getting someone to tell you there’s a loose wire, check it out for yourself. If you haven’t got a multimeter, I would advise you to get one, they’re only about £15 second hand.

    Start off at the bulb, check the filaments are ok. Now check the connections, they look nice and clean yeah, nothing in the plug looks bent, or snapped off, or corroded? If it all looks good, stick the negative terminal of the mulitmeter to earth, any part of the car body where there’s bare metal, dig it in and scrape around a bit to get a clean connection to earth. Put the positive lead on the feed to the bulb...Making sure the side light switch is on, and the brake pedal is depressed to activate the circuit. You may want to borrow the Hyundai Accent Haynes manual from the library so that you know what colour wire’s are the brake and side light feeds, under the wiring diagram section of the book. If there’s no current reaching the block that connects to the light cluster, then go further back. This is where knowing what colour wire you’re after is useful. Now you simply follow the wire back to the battery, checking for current reaching each component in the circuit, eg. Fuse or relay or switch. You will soon find where there’s a loose wire or a bad connection.

    Hhhmm…..if only it was that simple, on my 1999 accent all the wires to the back of my car are hidden behind the trim. When wanting to make a neat job of the wiring to my new rear speakers I had to make a right mess of the inside of my car, removing trim panels etc.

    If I’ve not explained summit clearly or u wanna no summit else to do with the light circuit on your accent, let me know n ill try ma best to help you, and anyone else with a similar problem out.
  • phillbillphillbill Posts: 93
    Thought all units were universal, i mean i've now got a CD player in my car that came out of a Suzuki (the model of Suzuki that's trying to look like a 4x4, cant remember it's name), the only thing you may need to play around with is the trim to remove the unit and to make it look pretty!

    I know on my dads old Xsara, about one inch of the head unit was hidden behind trim, and you wouldn't be able to remove the old unit without taking the dash board off i don't think.

    But no, i think all sterio's are the same size, weather they're radios, tape or CD players. Just gotta play around with the trim.
  • geeragegeerage Posts: 3
    Thanks a lot man, I kind of figured that was what I would have to do, I guess I was just in denial. This project will take some time and it's 112°f (44°c) during the day here. Sounds like midnight by the streetlight it is!! Seriously appreciate the help, your explanation was quite clear.
  • phillbillphillbill Posts: 93
    No prob's, just make sure if you do do it yourself, that if you use a voltmeter that it's turned on to Direct Current (DC) mode rather than Alternating (AC), somtimes catched people out.

    Dont know if you've used these voltmeters before, if not heres some guidence.

    Voltage is the electrical pressure in a circuit, (a battery produces a voltage in the same way that water has the potential to flow down a pipe cuz of gravity if it's connected to a resevoir up in the air) before starting voltage tests, check the battery Voltage, click your multimeter onto voltmeter mode (never put an ammeter accross a battery, or accross a component in a circuit, always put them in seris with the circuit, otherwise you'll frazzle your multimeter & possible damage the circuit) and put the black wire on negative terminal and red one on possitive, for a fully charged battery you should get between 12.6 and 13.2 volts.....not 12V, it is flat if it has gone down to 12V, many people think 12V is fully charged....WRONG!

    lets say you got a battery voltage of 12.9V, in a working circuit, the voltmeter will read 12.9V in every part of the circuit up untill the component (bulb in this case), where it will drop down to 0V while the circuit is turned on....if it is the only component in the circuit, which it will most likley be in a brake / side light circuit, so may as well keep this simple.

    If the voltage drops before the component, for example if the voltmeter read 12.1 V when you got the red lead just after a part in the circuit where there are two wires joined together, and the black wire on an earth, then it would suggest that join is faulty and needs looking at.

    When connecting the black to earth, make sure it is well into the metal, any paint or dirt or grease will act as an insulator.
  • 100356syl100356syl Posts: 1
    MY 2000 HUYNDAI ACCENT BURNS TO MUCH OIL I AM PUTTING OIL IN EVERY WEEK BESIDES THAT WHEN I AM DRIVING MY CAR WILL PULL BACK WHY IS THAT
  • phillbillphillbill Posts: 93
    Firstly, make sure that you're using the right grade of oil, for my 1999 hyundai accent i use Semi Synthetic 15W 40, i've had no problems with that. Just check in you're owners manual.

    Then get under your car and check for leaks, the oil filter may be loose, so if it's dripping from your oil filter tighten it up. Or is it's not been changed for more than a year, change you're filter, the rubber gasket may be perished that seals it flush to you're engine.
    I managed to change my oil filter without having to drain the oil, but have a large pan ready for any oil that may drain out with removal of the filter.....if it needs changing.
    Or it may be the sump nut that's loose and needs tightening, the nut that you remove when draining the oil.

    Could be you're rings that are worn out, letting more oil than there should be to leak into the engine and get burnt. Is there blue smoke coming out of your exhaust?

    Oil gets burnt in the the engine naturally, every time youre engine turns over some oil gets pumped in to lubricate the pistons so they can move up and down easily, there's always some oil left in the engine chambers, hence some oil will get burnt naturally in a 'healthy' engine. Upto one litre every 1,500 miles is ok, but saying that my car gets through nothing like that, about 3/4 litre a year.

    Hope that's some help!
  • jackson33jackson33 Posts: 14
    I have done some research on the 06 Accent and I can tell you that the mileage should considerably improve. IMO I would expect 33 City, 38 Hwy at this time. More acurate figures should come soon.

    The pictures of the new Accent look pretty sweet for an entry level vehicle. I am also not aware of another sub-compact with 6 standard airbags. They say the price will remain close to the same but I figure it will go up just a bit.

    Now some of you may go up in arms over a price increase but why wouldn't you wanna pay just a little bit more for a much improved entry level vehicle.

    Hyundai is on the right track, faster than most really. Are you gonna catch the train?
  • accentpaulaccentpaul Posts: 15
    Question about the 2005 Accent--

    Does the GLS with base package come with a tach and a clock yet?

    I'm budgeting to finance a new '05 next year (when the dealers will want to push them) and I just wanted to know if the '05 base models still have that "cell phone pouch."

    Let me know... thanks.
  • beliverbeliver Posts: 155
    Paul: The base car is not dubbed "GLS", Just plain ole' Accent, at least that's the way it was when I got my 2005 GT. The mid level cars (GL) are equipped with a tach and a clock. Upgrade "extras" are groups or packages for power windows, locks etc. IMHO a stick GT with power option is a great deal, at just about $12,500 MSRP before any incentives or dealer discounts . Log onto "fitzgerald Auto Mall. com to see typical out the door prices from their stores on the east coast in Maryland and Penna.

    Believer
  • muffin_manmuffin_man Posts: 865
    What research did you do to obtain this mileage?
  • jackson33jackson33 Posts: 14
    I stated that mileage as an opinion. Those numbers are not that far off from the current numbers of the current 5 speed manual tranny Accents. Those are 28 city and 33 hwy. With the new engine they are introducing, I would believe that these numbers are more than capable. The new 2.4 Sonata has about a 5mpg change from the last gen 4 cyl. Sonata.

    Like I said before, the mileage was stated as an opinion "IMO". Sorry for any confusion on that.
  • muffin_manmuffin_man Posts: 865
    I think it would be great if the next Accent hit that mileage, I thought you might have some inside info that we don't. 33/38 would be Civic mileage, which would be excellent.
  • accent01accent01 Posts: 1
    Hello!

    Please, I need some advice.
    I own an 2001 Hyundai Acent 1.3, 75 HP, 5 gear manual shift. My mileage is about 50000, and haven't expirienced any troubles untill now. Fuel economy is great and car runs smoothley. My problem is: I have changed engne oil and oil filter 5 days ago and checked the air filter but didn't replace it. I have also managed to spill some il o the engine block. After that I drove abot 50 miles when jellow check light went on. Gas cap was tight. I have checked spark plugs, they are all tight. Car still runs smoothley, :confuse: only thing I noticed is that when the engine starts it turns on 1500 RPM untill it worms up a little. I went to service and they adviced me to exchange the air flow sensor mentioning that this was common problem on Hyundai engines. In the mean :confuse: time the light perished. Should I listen to them or does anyone have any ideas...
  • phillbillphillbill Posts: 93
    hhhmmm....funny warning lights...the first thing i would always check is for loose wires, you dont wanna get all yr bits n bobs changed in the engine area only to find out one of your sensor leads wasnt plugged in properly.

    you got the one sensor going to your air box....another going to the throttle (the door which opens when you put your foot down, about 15cm up from the air box), another which detects the position of your pistons, located on top of the gear box where its bolted onto the engine, you got the lambda sensor coming off the exaust manifold straight out of the engine, i might have missed one.....anyway, just make sure they're on tight, give them a lil wiggle.

    If one of these were loose it would explain the 1500 rpm, becuase the ECU wouldnt be getting all the info it needs to make the engine tick over @ 100% efficiency from a cold start.

    The lil oil spill, i doubt that will have done any harm...was a bit clumbsy with my engine coolant once, no harm done...

    I've heard that the air flow sensor goes wrong a lot on subaru impreza's too....if it is that that needs doing, don't let the dudes at the garage change it unless you want your wallet emptied, i wouldn't purchase it from a hyundai dealer either.

    Eg, i needed a track end rod for my accent, it cost £36 to buy from the Hyundai garage, and they'd charge over £60 to fit it.....got one from an independant car parts dealer for £11, and it was only a case of cracking two nuts off to fit it....saving of £85 :D

    will be the same with the air sensor, will be ever so easy to replace if you look at how it's fitted in...hope this post is some help
  • rconwayrconway Posts: 1
    Hi all,

    I am the current owner of a '98 Hyundai Accent 2 Dr 5Sp. It's been bar none, the best car I have ever owned, even if it is a wee bit underpowered. The car has 270K KM's on it, and still going strong (I bought it brand new from the dealership). My question is, does anybody know where I can find a detailed engine diagram for this car? I'm hoping to replace the O Rings and one of the gaskets where there is some seepage, to try and curb the oil burning that the car is going through right now. I figure if I've gone as far as I have without having to do any major maintenance (I've only ever had to replace the Ignition Coil and Water Pump, and the radiator when the heat shield broke away from my manifold and punctured the rad core), that it's time to do some preventative maintenance, hoping to get another 60K out of it. So far, I've got 4 brand new BF Goodrich Tires, new brakes front and rear, new sway bar link kits, and getting ready to install new rear struts and front ball joints. Any help finding a diagram so I know which gasket it is that I have to replace would be great.

    Thanks
  • Just replaced the motor in a 2000 Accent & a few days later the cooling fans both stoped working. Cannot find any bad fuses or relays. Where can wiring diagrams be found?
  • Update on fans, I did some tracing & located a blown fuse for the ECU 1. As soon as I turn the key on, it blows instantly. I tried pulling out all the A/C & fan relays & unplugging the wiring from the fans & themo sensor & it still blows. Where else does this ECU fuse feed power so I know where to check. I'm waiting for some wiring diagrams to arrive.
  • phillbillphillbill Posts: 93
    For wheel lug nuts there's a torque specification for them, to get them just the right tightness...is it important to get these spot on? or do they just need to be on nice and tight so they don't come loose. I havn't got a torque wrench unfortunatley.
    Planning on rotating my tyres you see...

    Aslo...anyone know where i can get my hands on the tracking data for my 1999 Hyundai Accent 1.3i that's been lowered 30mm? I'm toing in on the front and toing out on the back wheels a bit....the bloke at the garage said i'd have to run my car on a roller to find out it's tracking info now the suspension's been set up differently...
  • smokey75smokey75 Posts: 434
    If you don't get them tight enough I guess it's obvious what could happen. Too tight & you can warp your rotors or break the wheel lug, but I think it would be hard to do this by hand. Usually this happens with an impact wrench. The most important thing is to tighten them in a star pattern alternating sides.
Sign In or Register to comment.