Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2005 Mitsubishi Outlander engine or fan runs after being turned off

illusions229illusions229 Posts: 1
edited April 16 in Mitsubishi
Hello, I just bought a used 2005 Outlander with 41k miles. When I turn it off, the engine shuts down but there is a noise, hard to describe, like something's still running. It shuts off after 10 seconds (yes, I timed it! and you can laugh). I'm going to call a Mitsubishi service dept tomorrow but was hoping someone here may have an idea if it's a problem or not. I bought it at a Toyota dealer and they said it's normal when I called them earlier. I really love it and want to keep it but not if I'm going to have a lot of problems with it. I just got rid of a Hyundai with multiple issue..

I appreciate your help

Lisa

Comments

  • I don't know about the 05 Outtie but I have an 07 and the electric fan is designed to run for a certain period after the engine is shut down in order to keep the coolant from overheating and possibly doing some serious damage. Sounds like your 05 is doing what it is designed to do....Good luck....
  • jflorjflor Posts: 20
    TSB #07002 addresses cooling fan controller in Outlanders MY 2003-2006. Maybe this is related to your current problem.
  • pog4pog4 Posts: 13
    My 03 Outlander had the same issue. One day after tuning the car off the fan continued to run for about 10 seconds. I also noticed the fan would turn on randomly when the engine was still cold. After researching online I found the TSB and decided to order the part and replace it my self since the Mitsubishi dealers near me went out of business. Once I received the new fan controller I did the swap in about 5 minutes. The problem went way and the fan is working normally.
  • ggillesggilles Posts: 2
    I have a 2003 Mitsubihi Outlander. Neither or the 2 radiator fans is running. Can it be the controler or the fans.How can I check it out.

    ggilles
  • I have a Mitsubishi outlander 2003. Recently I am having a lots of problem with the cooling fans. When I am stocked in heavy traffic the fan does not kick in, therefor the temp. gage rises to red, which in that case I have to shut the engine off for few minutes until it cools down. 6 months ago I replaced the double fan assembly, worked for few weeks only, the problem stated again, it stop working, I replaced the magnetic switch controller, again worked for few weeks and back to the same problem, at last I replaced the thermostat, it worked for few weeks again now same problem is back.
    Has anybody experienced a similar problem, if yes what needs to be done to fixed this.
  • I had the same problem,then I contact the Mitsubishi dealer. There is a recall on that model for the cooling fan controller. Please check with your dealer.

    Jerry Gilles
This discussion has been closed.