Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mitsubishi Montero Sport Maintenance and Repair

1246710

Comments

  • miguel10miguel10 Posts: 1
    I have a similar issue, I bought my Montero Sport new from the dealer, and have had great service out of it with the exception of changing the battery out with the dealer a few times. As far back as 2005 it started not shifting into gear in the morning, or after it has sat up for a while. I took it to the dealership and had the 90,000 mile service done to include a full transmission service. I received the vehicle back in the same condition and was told it was fine, and that they have slow warming transmissions? In most cases I can reverse out of my driveway, and then upon putting the vehicle in drive, it seems as though it's in neutral and then the vehicle jolts into gear and then it's fine for the rest of the trip? I've also since had the issue with the neutral light blinking and in some cases staying on for a while, but it has over 120k miles and it's still going.
    If this is an issue with so many vehicles how can it not be some type of defect?
  • HI  my 2001 mitsubishi  montero all of sudden the horn started going of , i disconnected both of the horns it helped . connected them back had no luck horn stays on on on on... any one out there w/ same issue.       thanks                                                          
  • My 1999 Montero Sport {218,000 miles} will suddenly strongly jerk as though the gear is shifting. However it stays in drive, continues to drive, but the Neutral light begins to flash on the dash. It stays flashing until the vehicle is shut off. This happens at any speed and is totally unpredictable.
    I've have a free transmission diagnostic test run and they found no problem. They did however there were further tests they could do for $125.........

    Any recommendations??
  • hello everyone, I have a 91 Montero 4X4 (auto) and recently getting into gear from park has been difficult. I have to force it into reverse or drive from the park position. But going from drive to reverse and vise/vera or into park, I have no problem. Also I have noticed that sometimes it takes a little longer for the transmission to switch gears when driving. Does it sound like a new transmission is in my future? I appreciate any input. Thank you, Joe
  • My check engine light came on of course a month before my registration was due. I took it to autozone to have it analyzed, they said it was an EGR low oxygen sensor fault. So, simple enough I changed out EGR valve..Light still came on...So I changed out Egr valve solenoid...Light stayed off for a few days , but came back on...So I then changed out EGR control solenoid..so far so good and it passed inspection and emissions...Just giving you my experience in case somebody else may run into same problem...I looked and couldnt find similar situation or it would have helped and saved me some time and money...But I love this SUV and hope it runs for a long time.....BYE.
  • jfegolfjfegolf Posts: 1
    Ready to replace front rotors and pads on my '01 MS 4X4. Looks like the rotor will not fit over the cap on the end of the axle. I've removed the bolts holding the end cap but it seems tight. I've never messed with the 4X4 axles before and was wondering if it is ok to just pop off the end cap on the front axle. Does this require a puller or is there any alignment marks that I need to make.

    Thanks,

    JFE
  • ledzledz Posts: 1
    Hello People,

    I have a 2005 Mitshubishi Montero Sport and for the past few weeks The Neutral Sign has been blinking and well the gears are not shifting like they used to.
    The computer test for the gear box determined that the Input Speed Sensor needs to be changed ...
    Does anyone know where i can order this part from ? Cause the dealership takes over a month to get it ...
    Any help would be appreciated
    Regards
  • siopaochisiopaochi Posts: 1
    hi, i have a 2001 montero xls and my dealer is charging me $141.53 for the freewheel clutch solenoid, i would love to have your local dealer's tel. # if they will charge $85 with shipping, to los angeles or even more for shipping. thank you!
  • jakerw14jakerw14 Posts: 4
    Yes i just recently bought a 2002 montero sport xls and my check engine light is on. I have had it analyzed and it says the same thing with EGR insufficiant flow or something.....So i guess i just shouldnt worry about it???
  • jakerw14jakerw14 Posts: 4
    Clean the idle control valve with some carb cleaner.....google it....that may work
  • jakerw14jakerw14 Posts: 4
    well....i got mad and punched mine haha and it stuck....had to disconnect the horn also....sucks
  • redsox058redsox058 Posts: 4
    the only problem is that it wont pass emissions. i just replaced those 2 solenoids and havent had any problems since.
  • jakerw14jakerw14 Posts: 4
    oh ok thanks, but it shouldnt affect the way my montero drives?
  • redsox058redsox058 Posts: 4
    I didnt notice any problems at all with mine, and i drove mine for 7 months until it was time to renew my registration and imissions.maybe u are lucky and are in a place where u dont have to do imissions and it wont be an issue at all for u.....good luck
  • juju007juju007 Posts: 1
    Hello ... my 2000 Montero Sport has the 4x4 indictaor light flashing all of a sudden. . The anti lock brake light also appears after driving the car for 5mins now, not sure if its related. Im wondering if that can be the "freewheel clutch solenoid valve" Can somebody help me please...
    Thank you
    Anthony B
  • That's exactly what our Montero was doing (4x4 flashing, anti-lock brake light coming on after a few minutes of driving). You need to replace the "Freewheel Clutch Solenoid valve" part # MR263723.
  • shavonnashavonna Posts: 1
    I absolutely cannot believe that so many others are having this same exact problem that I am. I have taken my montero to the shop two different times (once last week and again today) and they have absolutely no idea what is wrong with my vehicle. The Mitsubishi dealership that was here closed so I'm not sure if anyone would be able to fix it....any advice? It amazes me that so many people are having the same exact issue. I'm glad to have found this website. Thanks for the information!
  • micky8micky8 Posts: 1
    Have you got any solution?. I have same problem.
    Regards
  • trabtrab Posts: 5
    SOUNDS LIKE THE SAME TROUBLE THAT I AM HAVING WITH MY 2001 MONTERO. I AM SURE THAT I CAN REPLACE THE FREEWHEEL CLUTCH SOLENOID VALVE IF I KNEW WHERE ON THE VEHICLE IT IS LOCATED. I AM PRETTY HANDY ON AUTOMOBILES THAT ARE 10-20 YEARS OLD. I NEED A LITTLE DIRECTION ON THE NEWER ONES. ALSO, ARE THERE ANY SPECIAL TOOLS REQUIRED FOR THIS REPAIR? THANK YOU ALL FOR SUCH A GREAT WAY OF GETTING HELP WITH THE THINGS THAT SOME OF US DON'T UNDERSTAND!!
  • I too am pretty mechanical and probably could have fixed my problem. But the dealer was pretty "cryptic" about the repair. That, coupled with the relativley low price led me to just let them do it. It's been two years now and I have not had another issue.

    The mitsu deal replaced two parts MB596608 Switch Stop lamp (75.54), and MR263723 Valve, Frewheel C (122.10). Labor was 250, so it took them damn near 4 hours to do something!!! But hey that was the first 400 that I spent on my rig outside of routine stuff in years...it has been an awesome truck. Hope this helps.
Sign In or Register to comment.