Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mitsubishi Montero Sport Maintenance and Repair

1457910

Comments

  • therosetherose Posts: 2
    I have a 2000 Montero Sport 2 whl drive 3.0 automatic. I was not having any problems with it untill I had a service center change the trans filter an fluid. Now it jerks bad an the neutral light flashes. If i pull over a kill the vehicle, an re-start it will work for a few minutes. I have had trans ppl look an can not figure out the problem! I like many other people are at my wits end! If anyone can help me, I would so appreciate it!
  • therosetherose Posts: 2
    What do u mean dealer part only? Well I mean, what part are u referring to? The speed sensor?
  • Sports are a necessary part of life. And in all of them basic rules of sports need to be firmly followed particularly if we talk on the subject of safety. This site http://www.basicsportrules.com/ provides basic rules of very game. Which
    helps in playing safe games.
  • this was the same problem i was having, your information here helped me fix it in about 10 min. and only $115.00 . thanks for your input.
  • kaseydrtkaseydrt Posts: 1
    edited October 2010
    i have a 95 mitsubishi montero and i was driving it on the freeway to tak my kid to school and there was a loud squeal sqeek noise then there was knocking what the heck is going on !?!please help!!! :mad: :mad: :mad: :confuse:
  • gk123gk123 Posts: 2
    edited October 2010
    Hi.... I have a 2001 Montero Sport Limted 4x4 for which i have changed the front differential which coasted me lot of money. Now after 3 months both the Anti lock and 4x4 light are flashing. Can anyone let me know what can be done.
  • gk123gk123 Posts: 2
    Hi.... I have a 2001 Montero Sport Limted 4x4 for which i have changed the front differential which coasted me lot of money. Now after 3 months both the Anti lock and 4x4 light are flashing. Can anyone let me know what can be done.
  • Hi gk123,
    I have the same problem before and this forum helped me a lot. I want to help and give it back. It would be the freewheel solenoid valve. It is located just below the air cleaner box located in the passenger side of the engine bay. I forgot the part no. but you may try to browse the previous messages and I'm sure you will find it.

    Hope this helps.
  • Hi, I have a 02 Montero Sport, 2 wheel drive, the vehicle runs and shifts great but I noticed when I take off on a cold start for the 1st 10 to 15 min's the 3rd shift before going to OverDrive has a bit of a Flare up, so for example it gets to about 3,000 RPM and right before going into overdrive the RPMs kinda slip to about 3400 or so and then come right back down, it only happens for just a split second or so and its still shifts smooth, theres no jerks or hard shifts it just seems like it slips or flares up for just a second on the last shift from taking off, Is this normal or is this the start of a problem? Any help would be great, Thanks..<
  • ibby2ibby2 Posts: 1
    Hi, I have a 2001 Montero Sport 4x4, with 180K miles on it. My first suggestion is you probably have a lot of miles on the truck, let it warm up, I have started to 'baby' my baby, and she does much better, after getting some temp gage movement prior to driving. As far as the slipping transmission problem I thought I also had at one point. I had a trans flush done and I believe it fixed the problem (I drive in severe conditions 6 mo out of the year and 17-20K miles). I recently had a severe trans leak, the seals were all shot, those were just replaced about 6 months ago. Now the truck has put itself into "fail safe" mode and will turn over but there is no getting her to drive. The dealer stated it was the upper valve body and solenoids (which you can't get one piece without the other now, as the upper valve body is 'obsolete'). So it is now at a private mechanic before we go down the path of repairing, replacing anything having to do with the transmission. I had heard from another Service Manager (one who did not get our business since I live out of state now, but did when I lived close) all my questions on repairs went through him since I didn't trust my local dealership. He stated he's never had to touch an A/T on the Montero Sport in regards to major overhauling. So if I'm reading everyone correctly, the most logical place to start is replacing sensors? And this does fix the "grinding" or something is broken noise? Thoughts or suggestions?
  • The car has a tow rating of 5000 pounds. To tow over 3500 pounds you'll need to install a brake controller and have trailer brakes. Most places that install trailer hitches can probably help with the hitch the wiring harness and the brake controller
  • THANK YOU!!! I've been searching for a week on what could be an economical fix and thanks to your info I too was able to workaround the horn issue in my 2003 Montero Limited.

    Very happy to get the horn back and still pass inspection without being out a lot of money!
  • it the o2 senor that why is doing it
  • go to autozone or pepboy they will have it n could be o2 senor to have that checked it happen to me
  • Can you pleeaaaasssee contact us? We are having the same problem and are clueless on how to proceed...need to get inspection ASAP....thanks!
  • No way I'm drilling holes and splicing wires.... Isn't there an easier way? Is there an easy way to check the horn relay?
  • Was wondering if you ever had this problem fixed and what it turned out being! Just bought a 2001 and it is doing the exact same thing!!
  • Just purchased a 2001 Mitsubishi Montero Sport 4x4, it has 136000 miles on it already. I know buying a used car you always get what you pay for and then some!! We thought it was a great family car... now when you drive around 20-50 mph she begins to shudder like she can't find the right gear than you hear this racket that sounds like when you drive over the wake up strips on the highways (we don't have those so I know it's not actually that, just sounds like it). Took it to the mechanic he said it was showing a catalytic error code. I am wondering though if this is the catalytic converter or a sensor tricking the converter into thinking it is bad.
  • grolngroln Posts: 1
    I was washing my 02 Montero Sport AWD and i lean against the shift switching it from AWD to the neutral postion, now i cant place it in any of the postion... the vehicle drives well but i just cant get it to go into 4H or 4L or AWD it just wont go its like its disconnected or jammed. has anyone had a problem like this?
  • It was the oxigen sensor on the catalyctic coverter system...The system has 4, it was the first one, before the catalyctic . $ 48.00 for the sensor
Sign In or Register to comment.