Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Safari heat problem

sammycastagnasammycastagna Posts: 28
edited April 18 in Chevrolet
I thought I had a bad thermostat at the beginning of this heating season. This Safari is a 2001 with 64000 miles. I put in a new thermostat flushed the system. Replaced the heater control valve, no luck. Ordered a new heater core had it installed. No luck. Took it back to shop they replaced all bad vacuum hoses took nipple out that feeds heater core said all look good motor clean. I have about half the heat I should have. When I stop to idle heat goes to almost nothing. Shop foreman says he does not know anything else to do. I am not getting enough flow but nobody knows why. GMC has no technical support. I was thing of drilling out the nipple that feeds the heater core. It is a 1/2 inch nipple with a 5/16 inch hole I thought of making it 3/8 inch. Guy at shop says the larger I make it the more risk of blowing heater core.

Any ideas

Sammy

Comments

  • dlm1954dlm1954 Posts: 57
    You've got a vacuum hose leaking that opens heat baffle when manifold pressuse falls,ie at an idle or slowing down,it has nothing to do with the heater itself,it's a vacuum leak.
  • I had all the vacuum lines replaced and checked out by dealer still would not heat correctly. I took a water hose and flushed out the heater core and back flushed into the engine. I do not know if there was a piece of trash in there somewhere or what. But now I have 140 degree F heat and AC is 39 degrees F on max. I took it back to the dealer Friday and got them to unblock vacuum on my heater control valve. In my opinion the dealer did a sloppy job.

    Thanks for your reply; Sammy Castagna
This discussion has been closed.