Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Venture

1106107109111112123

Comments

  • Must be one of those years! I own a 2003 venture, that wont start after it is parked for more then 5 hours. I have changed the battery and checked the alternator, all is fine! I have pulled different fuses at night for options, and checked in the morning, but battery still no start. Run out of things (options) it could be! I jump it with my car and it starts right away! However my car has to be running, If I jump it without my car running it will not start it, almost like it needs more then 12 volts to start! Has anyone else had this problem?
  • hhua1hhua1 Posts: 41
    Make sure your battery connections have good contact especially at the battery positive terminal (especially the little wire from engine fuse box to the battery positive terminal).
  • done did it awhile ago!
  • bt1221bt1221 Posts: 3
    I have recently purchased a 2000 Venture WB edition. And I was wondering if anyone out there has attempted to replace the VCP for a DVD player. Didn't know if the wiring was too difficult for DIY or if the monitor would not accept the video from the DVD. Or if you could plug into the VCP on an Input or something that way?
  • hhua1hhua1 Posts: 41
    I know you said the connections are checked. Just to be 100% sure of that because in my case, the positive terminal looks perfect until I really bent the little wire to findout there was a litle corrosion, it didn't take much. After a good cleaning everything good again. Let us know if that helps or not.
  • We have started having numerous electrical issues - first it started with headlights and dashlights fading (never really going out - just sort of flickering). Then the van just wouldn't start. Drove it for a while, stopped at the store and came out - and it was completely dead. Now, the fan for the air conditioner has a mind of it's own. Driving down the road it just came on full blast and we couldn't turn it off. When we stopped and turned the vehicle off - the fan continued to run, until my husband pulled the fuse. Hubby is very handy repair, but at a loss with these issues now as he is unable to locate a specific cause. Any help or insight is GREATLY needed.
  • boga228boga228 Posts: 50
    I had the same problem with the flickering, it was the alternator gone bad. They said it was a bad ground in the alternator.
  • 2000 Venture WB A section of LED lamps in the third stop light assembly at the top of the tailgate are not working...4 or 5 lamps not working the rest of them do. Wondering if anybody else has ever had this problem. I haven't dug into it yet...when I do will pass on what I find out.
  • orv1orv1 Posts: 1
    How in the world do you replace a headlight or running light in a Chevy 2000 Venture? I just can't see how to get into where the bulb/s are! I know I'm overlooking something, but I've studied and studied and still cannot come up with how to replace a burnt out bulb. Can someone help me?
    Thanx,
    "Orv"
  • Can any of you hear the DVD player running when there is no disc in it? It's not loud but I would like to know if its normal. I can hear it after I turn off the engine and as soon as I open the door it stops. I don't have kids so my DVD player never gets used.
  • I parked my van in the garage and about 30 minutes later I went to start it and got nothing no clicking or noises. I tried the other key and still nothing. I took my other car and about 2 hours later I tried the van again and it fired right up. The radio however reads "locked" and a solid red light is on. The DRLs and instrument lights do not come on and when putting the car in gear I get no light to tell me what gear I am in. I believe it is in the anti-theft radio but I am no sure. Does anybody have any clues on what I should try??
  • I have a 98 Venture, the backup lights do not come on and the gear indicator in the instrument cluster is also not working. I just replaced the switch on top of the trans under the shifter arm with no luck. Anybody have any ideas?? :mad:
  • indrgbindrgb Posts: 115
    bt1221: I have experience doing this. Let me know if you want the details.
  • bt1221bt1221 Posts: 3
    indrgb: If you could give me any information that would be a great help. Thank you.
  • indrgbindrgb Posts: 115
    I have a 2000 Silouette. The VCP broke and I tried to replace it with a DVD player. I bought a DVD player from Crutchfield and installed it myself. There was a problem with the video signal to the monitor. Every so often the picture on the monitor would scramble. Sometimes it would play okay for a few minutes, then it would scramble for a few seconds. I ruled out a problem with the DVD player and monitor by trying multiple DVD and VCRs. Any VCR worked fine, but no DVD player would work in the front. However, if you plug the DVD player into the AUX. jacks (next to rear HVAC controls), it worked fine. There is something different about the video wiring from the front to the monitor. I called 2 dealers, an automotive custom video shop, and the manufacturer of the origianl VCP to see if anyone could explain the problem. They were all completely clueless. If I remember correctly, the dealer wanted some ridiculous amount of money to exchange the VCP with a refurbished one.

    To make an already long story shorter, I bought a new automotive VCR from Crutchfield, Clarion model VDH910. It works fine. I doubt Crutchfield still carries it.

    If I were to replace it today, I would probably install a DVD player and then snake and hide new wiring to the AUX jacks by the monitor.

    I'm not an expert on this subject, but let me know if you need any more info.
  • My husband was out of town, my outside air temp sensor wasn't working. I found your website, someone posted not only HOW to fix it but pictures to boot! I was able to order a part and fix it myself, I was thrilled. Love my Venture, still looks new and is reliable. Hate having to move the engine to do a tune up however. Nothing much is easy to repair except the temp sensor. I couldn't even find what it's really called in the repair manual but your site gave me all I needed. Thanks! :)
  • could someone repost the fix that she is speaking of. My outside temp sensor reads "oc" and I'd sure like to get it working.
  • Have you had any luck with correcting your PO449 check engine light yet? I have the same issue.
  • jrjtljrjtl Posts: 2
    I have a 2002 Chevy Venture WB Edition. We had to replace the AC in March, but that has worked fine this year. Suddenly today, 21 October 2006, while sitting in a parking lot, the vehicle overheated. I had no previous problems, we had only been on the road about 10 minutes when this happened and the AC had been on for less than 5 minutes. The coolant reservoir was empty, so I added a pre-mixed solution to the reservoir. It seemed to help some, but the temp would still increase fairly rapidly if I were in slow traffic or stopped at a stop light. I am looking for some suggestions as to what the problem could be. I intend to check the coolant level in the radiator tomorrow morning while the engine is cool to see if there could be leak. Please let me know of anything else to look for.
  • Has anyone ever installed fog or driving lights on a Venture? I have an '01, bought in '02. I like it and it's been good to me, but I DESPISE the headlights...they stink, and the awful white dash lights are the worst. I want to install, or have installed, a nice set of fog or driving lights, but I'm not sure where to mount them due to the front grill/air dam is not very cooperative. If anyone has any ideas or suggestions I would love to hear them.
Sign In or Register to comment.