Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Venza Transmission Problems

124»

Comments

  • These three lights were simultaneously lit 2 weeks ago but I noticed no driving or shifting issues. Dealer has had my car for one week and I really have been given no info about what is wrong. Supposedly the master technician has a call into Toyota regarding my car. I am pretty worried about this. Anyone have any imput?
  • wwestwwest Posts: 10,706
    What's the weather like when this happens....COLD ?

    ATF volume expands a fairly great amount with a rise in temperature.
  • wwestwwest Posts: 10,706
    Low brake fluid reservior level, or failing level sensor, will result in "brake" indicator illumination and that in turn will disable some of the brake use functions, VSC, etc.
  • wwestwwest Posts: 10,706
    It sounds to me as if the Toyota factory is cutting corners, cutting COST corners, by only marginally filling fluids, ATF, brake, etc.

    With size/volume of the ATF sump having already been reduced, by design, to the absolute minimum for purposes of FE, even a slight underfill could result in these problems, especialy on COLD weather conditions.

    The actual factory fill level may even be selective based on ship destination, Canada/Alaska = COLD = higher fill level.
  • Took the vehicle in, dealer hooked it up on the computer.....$1200 for the part plus labour.

    Anyone else seen this?

    They said that with the light permanently ON, past weeks it was intermittent, means the AWD feature of the vehicle is disabled.
124»
Sign In or Register to comment.