Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Cherokee Sport HELP!

jayjay813jayjay813 Posts: 2
Where do i begin? i have a 2001 Jeep Cherokee Sport w/ 4.0L 6-cyl automatic, 110,000 miles... I recently had some issues with it overheating due to bad water pump, which blew my head gasket. I had all that fixed, but one problem that started when it was overheating was my oil pressure gauge started reading zero when the engine got hot, but would go back up when i gas it. Even after cooling issues were fixed, gauge problem continues. i'm not leaking or burning any oil that i am aware of, gauge just reads zero when engine is warm and idling.

Also, my check engine light is constantly on. error codes are for "evaporative emissions system leak (large)", and occasionally "cylinder 3 misfire". i have had numerous hoses replaced, and replaced my gas cap, but problem persists. also had plugs and o2 sensor replaced at 100,000 miles.

AND (oh yes, theres more!) sometimes when i start it it runs really rough. it will idle low and act like its gonna stall, but doesnt. if i try to drive through it, it continues running very rough until i stop and turn it off and back on. usually then, (but not always) it runs fine after restart until the next random time it decides to do it again. happens both on cold start and after sitting for only 10 minutes, but only occasionally, only a few times a month.

AND when i start it, theres a knocking sound. nothing too deep or loud, and it usually goes away or is barely audible after warming up. pretty sure its a lifter sticking, but figured id put it on here for a second opinion.

and, FINALLY, this is the least of my concerns, but im wondering if this is a common problem. my a/c quit working in 2004 when the prior owner (a family friend) had it. she had the compressor and condenser replaced and it worked for a while after being charged, but eventually stopped again. someone told me that evaporator cores are known to go bad on cherokees, and im wondering if this is the likely culprit.

Well, thats where im at at the moment. any info or suggestions at all would be greatly appreciated. For some God awful reason im ridiculously attached to my Jeep and am not ready to let it go!

Thanks so much!

Comments

  • Last summer I tried to add refrigerant to my non working a/c, It worked for about a day, then no cool air would come out. My mechanic noticed dye coming out of the drain tube and said he had to pull the dashboard out to fix the evaporator core, a four hour job.

    While they were at it, my clutch was going bad. I had to buy the compressor at the same time, because they would not offer a warranty. I also had to buy the dryer, because I was told if it went bad, it would take out the new compressor.

    When he removed to dash to replace the evaporator core, he said the heating core did not look that great so it was replaced also.

    It took about $1600.00 to fix the problem. but I have not had any problems by having almost a brand new system in place.

    This happened with 120 K miles on the jeep. If anyone is thinking of buying a Cherokee Jeep, it would serve them well to have someone check for leaks in the a/c system, especially the evaporator core. Rog
  • tidestertidester Posts: 10,109
    Thanks for the report. That could save someone a bit of grief down the road. :)

    tidester, host
    SUVs and Smart Shopper
  • I just replaced the head gasket on my 99 Cherokee. Easy job, no problems but when I started it, the engine revved to full throttle. I double checked everything, it all seems fine but when I start it, it immediately goes to full throttle and stays there. The IAC was old and carboned and had been setting a code prior to the head gasket. I replaced that but no change. It maxes out the engine speed. Any ideas?
  • I have a 93 cherokee with the straight six 4.0 has 124300 on the odo and the coolant is coffee black. I noticed this a few days ago and had it flushed today made sure they used the chemical cleaner before adding the new coolant. Checked coolant today and its still coffee black I can't figure out what is going on and what my next step should be. I need this thing to keep running its all I have right now and cannot afford for it to freak out on me now. Anybody with any suggestions or suggested repairs I would greatly appreciate the help if I got to spend money to fix it I.E. radaitor, water pump, hoses, ect I will do it its a good vehicle and would like to keep it running.
  • jflint2jflint2 Posts: 1
    edited November 2011
    @toetrucker
    • I just replaced the head gasket on my 99 Cherokee. Easy job, no problems but when I started it, the engine revved to full throttle. I double checked everything, it all seems fine but when I start it, it immediately goes to full throttle and stays there. The IAC was old and carboned and had been setting a code prior to the head gasket. I replaced that but no change. It maxes out the engine speed. Any ideas?
    Did you ever solve the problem to your jeep throttle. I am having the exact same problem with my 2000 jeep? please help? shoot me a email at j.flint1200@gmail.com if you get this and can help?
Sign In or Register to comment.