Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2006 Jeep CRD Battery goes dead

buckmcbuckmc Posts: 4
My 2006 Jeep CRD has a problem I'm trying to find. The problem is that if you don't drive it everyday,then the battery goes dead.Have replaced the battery,still same thing.I installed,a disconnect switch on the negative side,of my battery,and have found that I have a .076 draw from my battery,with the disconnect,in the off position,any idea's?

Comments

  • caribou1caribou1 Posts: 1,349
    Have you checked the alternator? If the charge voltage isn't above 14 Volts, the battery is never completely charged.
  • buckmcbuckmc Posts: 4
    Hey thanks for the reply,I checked my alt,and it was putting out 13.23,so I need to pull it off,and either,get it gone through,or get another.
  • sthogesthoge Posts: 28
    Do you have the tow package on your rig? We had the same thing happening to ours and since it was still under warranty, we took it to the dealer. They found that the relays for the tow package was connected incorrectly. They are supposed to be connected to key-on power, but were connected to always on power instead. The dealer fixed it, then replaced the battery and since we have been able to leave it for over a week and no problems.
  • buckmcbuckmc Posts: 4
    Thanks for your reply,was that at your fuse box,on the side of your dash,or under the hood?
  • sthogesthoge Posts: 28
    I'm not really sure where it was connected at, just that they were connected to the wrong location. I wasn't the one to pick up the vehicle so I could have them show me.
  • caribou1caribou1 Posts: 1,349
    On my truck there is a dedicated 'leg' of the wiring harness hidden behind the left side panel, inside the trunk. This is where the trailer lights should be connected when using the official equipment. There should be a set of solid state relays to provide connection instead of ordinary 'Faston' connections.
  • sastrisastri Posts: 1
    I have the exact same problem. Did repairing the Alternator work?

    Sastri
  • This is great information. I had a hitch added to the CRD when I bought it. I've had to plug a battery maintainer in the cigarette lighter if I don't drive the vehicle for 3 or 4 days or the battery will be dead. The problem is more pronounced in colder weather.
    The maintainer has been easily able to supply the load so I figured it was a trickle draw.

    Solid state relays sound like a trickle draw - milliamps can discharge a battery.
  • sthogesthoge Posts: 28
    On our 05, the tech writer said that they found the installation instructions were wrong tying the relays to always on power instead of key on power. This caused a constant draw on the battery and would run it down. Since they fixed it and replaced the battery three years ago, it has not been a problem since.
  • I had this problem on 2 of my Liberty's. Dealer couldn't find the problem, so after 3 batteries, Chrysler sent out a recall notice that identified a computer problem that would occasionally kill the battery, they uploaded the newer software and it hasn't happened since. Anyone else run into this?
  • I've not had the Jeep sit for more than a few days in the months since I last checked this forum. I bought the biggest battery I could from the auto parts store a couple of years ago. Well - it wasn't big enough. My Jeep sat outside in 20 degree Fahrenheit weather for a few days and the battery ran down. I pulled each fuse out one at a time and checked for zero volts (sign of dead circuit) while the vehicle was off.

    Sure enough - The cigar lighter circuit had 12 volts across it. When checked for current draw across the same fuse terminals, I found 140 milliamps draw. I figure my trailer hitch must have been wired to this circuit by ignorance or by mistake because I've had no other changes made to the wiring.

    Thank you Sthoge

    I'm glad I don't smoke cigars. I can function without the cigar lighter for a long time until I decipher the vehicle's wiring further.
  • sthogesthoge Posts: 28
    Glad the information was able to help you out. The dealer had installed the tow kit from the factory and followed the directions on where to connect the relays. Turned out it was wrong and another dealer had already discovered it and changed it on our rig. So I can't tell you what wire to move. You should be able to trace it to the relays, then find a junction that is key on only and move the wires to that location.
This discussion has been closed.