Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Engine or transmission?

My wife and I test drove an '01 Pontiac Montana w/78000 miles and when you went to pass or accelerate hard it would downshift and the RPMs would go up, but it wouldn't move or pick up speed. It just kept going at the same speed, but w/the engine sputtering like it couldn't breath. Told the dealer and they fixed it. It was the MAS and a ?? sensor. Took it out for another test drive and problem solved.

Fast forward to today, my wife and I are now looking at an '02 Grand Prix GT w/70000 miles and it does the same thing as the Montana. Does anyone think it could be the same issue? We want to buy the car, but only if it's not the transmission.

Comments

  • Have the same thing happening to my 1999 Grand Prix GTP. Seems to happen after the car is warmed up, seems to sputter as if it needs more fuel or air. Originally was thinking it was the fuel pump now leaning towards Mass air flow sensor or Throttle position sensor. Periodically the check engine light would come on but clear after 10-20 miles. Was the problem the Mass air sensor?
  • avo3avo3 Posts: 2
    This happens to me also, but only if my gas level is low
  • It turned out to be the MAF sensor and something else. $200 fix and all was good. Didn't get the van though.
  • pop4466pop4466 Posts: 1
    when I start the car it runs fine,but when I rev it up it spits n sputters. Please advize what 2 do.

    Thank You! :confuse:
Sign In or Register to comment.