Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Cadillac SRX Loss of Acceleration Problem

dpowell3dpowell3 Posts: 1
Purchased 2004 cadillac and while driving looses acceleration, no warning if I stop and shut off car and restart problem goes away. Intermittent pro blem. Problem will pop up again without warning. Car dealership cannot fix the problem, car has been into dealership several times. Can anyone help to troubleshoot this problem? I did bring car in when problem was happening they retrieved the code but it did not indicate the error. Now the car needs a #3 ignition coil and I am trying to find out instructions for replacing this part. Car is sitting in my driveway inoperable.. If anyone has any information would greatly appreciate the help.
«13

Comments

  • bigham1bigham1 Posts: 1
    edited March 2010
    Did you ever find out the problem? I am having the same problem, along with many others! The Stability engaged message is coming on, the rpms rev up whenever I start the engine ( it stops when I put it in gear). I have had it to the shop every other month for the past year. The only thing they can find is crimped wired. And this doesn't take care of the problem.
  • I had this problem on my 2004 SRX. Dealer troubleshot with me over one phone call. This was the description on the work order...

    Check engine light on. No power at times, after shutting car off and restarting problem may go away. Scan system code P0221 stored found internal short in TPS in Throttle Body Assembly. R&R TBA and new harness soldered.

    Total cost parts and labor - $502.82


    Hope this helps.
  • Just put mine in the shop this morning - same problem except #5 ignition coil and spark plug. I am told I have 6 coils and that when one goes, others may follow. Labor is the same for 1 or 6. Cost about $75 each coil + Labor. Mine acted the same way - no code, turn off and problem goes away etc. I opted to do the whole thing as I trust my mechanic and figured may save me money in the long run. Lesson learned - never buy the first model year. Only one problem of many since purchased new.
  • My wifes 04 SRX check engine light came on. No big deal I figure gas cap right? On the way home from dinner when accelerating it would sputter and delay. The RPM were there but the response from the engine were not. When we got home I popped the hood and white smoke was coming from the engine with a bad odor. Not oil or antifreeze. I called my local mechanic took it in and it was an ignition coil. Total cost with labor $374. I had them replace all the spark plugs too. Total cost of that $150. I'm learning quickly you need to be rich to drive a cadillac!
  • Hi,

    Has any one experieced problems with the 2007 model where the accelerator appears to stick on during over run and the vehicle speeds up on its own even when the brakes are applied.

    I would be greatful if anyone has experienced this to let me know what happened, what the experience was like and how you compensated for it.

    Also what did the repair consist of to rectify this and was it carried out under warranty.

    If anyone has suffered this was there a service recall for the fault?

    Thanks in advance for your interest and help,

    UK_Police
  • gmcustsvcgmcustsvc Posts: 4,057
    uk_police,

    Could you please email me your VIN and current mileage? I would like to look further into your situation.

    You can get my email by clicking on gmcustsvc.

    Thank you and have a great weekend!
    Caron, GM Customer Service
  • I noticed many people are starting to complain about the electrical system in the Cadillac SRX’s. Well, I just brought mine after returning from Iraq a few months ago, for my wife and family to have a larger vehicle to get around in the city while I’m gone to work. Just recently, she complained that the electrical panel would completely turn on and the “Engine Power Reduced” alert would come on and the vehicle would completely shut off in middle of the road. Not a safe situation at all. She would glide onto the side of the road or push the vehicle; Try to turn the vehicle over and it would turn over after sitting for a while, and then try to make it home. I started to take the car to work to see how it was acting. Driving below 50 mph it would do the same. While gliding with no power I would throw the car in Neutral and continue to try to restart. Sometimes it would catch and sometimes is wouldn'T’t, which left me in middle of the road with my emergency lights on until it finally did catch.



    I have an extended warranty on the vehicle so I brought it into the Cadillac Dealer yesterday. The dealer said it had many codes that came up but he thinks one code, specifically, maybe causing all the others: Freight Booster Hose is busted. $175 plus tax to fix. Warranty does not cover it. I was kinda relieved that he may have found the problem until I read this forum on Edmunds.com. My family will be riding in this vehicle. Am I looking at a Doomsday Situation; a forever permanent problem that will never be resolved? I expected more out of GMC…not to mention a Cadillac.
  • gmcustsvcgmcustsvc Posts: 4,057
    cnw1979,
    I apologize for your frustrations. Can you please send me your VIN, complete contact information, current mileage, and involved dealer? I look forward to your response. Thank you for your service!
    Christina
    GM Customer Service
  • Well the car was acting just fine for one whole day. The next day, the check engine like came back on and the same problem occured. The Hose was replaced, but, obviously that did not fix the electrical problem. My warranty company is having some issues at the moment so they told me to wait 2 weeks before I make another claim so looks like I'll have to let it sit until then. But it is starting to look as if my SRX is going down the same path as all the others. I checked the recall list and did not see anyrecalls about electrical issues, but all these problems are reoccuring.

    Are there any direct options? Maybe someone has figured out the exact problem somewhere.
  • gmcustsvcgmcustsvc Posts: 4,057
    cnw1979,
    I would recommend continuing to work with your dealer. If you continue to experience concerns I would recommend setting up a case with Customer Assistance.
    Christina
    GM Customer Service
  • I am having the exact same problem too. I have had the throttle body replaced, had the catalytic converters done on the recall, ECU flashed, and numerous $$$ spent in diagnostics. Does anyone have a solution to this problem?? This is a major safety concern as I do not want the engine dying on a highway corner and not to mention the hassle of dealing with this vehicle.
    04 SRX with 160,000kms
  • I notice that several people have had the same problem with their Cadillac SRX that I have had and am wondering if GM has done anything to assist them. I seem to be getting the run around from GM and am thoroughly disappointed with the service they provide.

    In June 2011, I coasted out of my driveway, coasted down a hill to a stop sign and coasted down another hill to another stop sign at a busy road. When I went to turn left and accelerate the car the dash was completely dark and the check traction control light was the only thing lit and I could not accelerate the car. This is completely unsafe and scary when there is traffic coming behind you and you can't move. I rolled it over to the side of the road and shut the car off. Once I started it again, I still could not get the car to accelerate while it was in drive. I shut the car off again, waited 10 mins and started it again at which time I was able to drive the car. That day we took it to a dealership 25 miles away from my house in Hendersonville. The dealership was not able to replicate the problem and said the car was in working order. At this point, I accepted what the dealership said and figured it was an isolated incident.

    Sometime in the fall of 2011, this car did this to me again where the whole electrical system in the dash was completely black and I cannot accelerate the car. Luckily I was leaving a parking lot so having traffic around me was not a huge concern. The fact that it was the second time that his car has done this became somewhat of a huge concern to me. This time my husband took it to our personal mechanic who handles all of our company trucks. Once again, the problem could not be replicated and the diagnostic didn't show anything. He did, however, find a long laundry list of issues that have been reported with this year, make and model that have yet to show any recalls.

    Last week, March 13th, I was driving home from taking my child to school and the same thing occurred while I was in motion. I was able to pull the car over to the side of the road and had to shut it off and turn it on several times before I could get the car to accelerate again and get it to my house.

    One time - isolated incident....two times - something is not right....three times - this car is a HUGE SAFETY ISSUE. I called my leasing company, Ally/GMAC to tell them my issue and to see what it would cost for me to terminate my lease earlier than the end date - $9,737.88. I told the girl that I spoke with what was going on with the car and she transferred me to General Motors. I spoke with a person by the name of Ben who was helpful and understanding of my concerns with the safety of this car, especially since I have a child in the car with me the majority of the time. Ben aided me in contacting a different dealership in Asheville for me to take my car to try and locate and repair the problem. He offered to have it towed for me but the cost of the towing would only be covered if I took the car to a different dealership - the first one I took it to when the problem first arose. I wasn't interested in taking the car to that dealership since they were unable to locate a problem to begin with and I wasn't interested in absorbing the towing costs to get it to a different dealership, so I drove the car there myself avoiding the interstates in case it happened again. Ben arranged for me to take the car to the Asheville dealership via a conference call with a service tech at that dealership. I was told they could give me a loaner car and they would see if they could figure out the problem. I took the car and left it, completely unhappy with the poor quality loaner car I was given from a rental place.

    The next day, the dealership called me to tell me my car was ready and that they couldn't duplicate the problem. Not a big surprise....I can't replicate it because there is no rhyme or reason as to when the electrical system will shut off. I also advised the dealership that I frequently get a loud pop out of the stereo system and it will also shut off as does the entire center console, including the air conditioning/heat system. The disc will eject itself and if I pull it out and reinsert it, the stereo will come back on. Again, they said they can't duplicate the problem.

    So now it was back to dealing with Ben at GM. I expressed to him that my concern for the safety of this car was my number 1 issue and that I wanted to terminate my lease. The car was a gift for my 40th birthday from my husband - it was exactly what I wanted and loved in a vehicle. Up until this issue started, this car needed nothing but oil changes and tire rotations. Once these issues started the love for the car started a fear of driving the car, especially with my family in it. He had stated to me that I could possibly get a different one or that terminating my lease shouldn't be a problem but that I needed to be assisted by a senior or district specialist.

    Enter Jim, the district specialist, who is nearly impossible to get a hold of. On March 19th, Jim called my office and left a message for me to call him with his extension number. He never bothered to reach me on my cell phone even though it is part of the case number. I have made more than 70 attempts to reach Jim on his extension to no avail. I have left him several messages to return my phone calls and he has failed to do so. Once I got a hold of an actual person at GM, I was told that I was scheduled to receive a phone call on Friday, March 23rd between 4 and 6 by Jim. Again, Jim has failed to call me. I hate to think that this person is a specialist in the field of customer care for General Motors because his customer service leaves little to be desired.

    Today, March 26th, I was able to get a hold of an actual person named Elizabeth. She connected me with a different specialist by the name of John. John reviewed the case briefly and proceeded to tell me that since the dealership could not duplicate the problem with the vehicle that there was not a problem to fix and that is the resolve to my issue and GM could not help me any further. I expressed my concern again with the safety of this car for myself, my child and my husband and he really didn't seem to care. I was told, in no uncertain terms, that is the resolve on GMs end. He refused to connect me with a supervisor and told me I needed to wait until my scheduled call this afternoon with Jim between 2 and 4 and would have to talk to Jim's supervisor, who incidentally has no extension number to be reached. Now I am irate! I asked him if General Motors is going to assume liability if I am injured as a result of this acceleration issue. His response was rude and uncaring. When I told him I wanted the lease terminated, his reply was again rude he basically said they can't do that.

    I find it hard to believe that I am the only person who is having this issue
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    hollyw108,

    I understand how concerned you are with safety from your post, and want to apologize for any unsatisfactory interactions you have had with our Customer Assistance Center. What is your case number? I would like to look through it to make sure that everything has been handled appropriately.

    Regards,
    Sarah
    GM Customer Service
  • Sarah,

    I am glad you understand how concerned I am for the safety of myself and my family in one of your products, apparently the people I have dealt with do not. According to Jim, GM has done all they can do and recommend I should continue to work with the dealership. I will NOT drive an unsafe car.....it is being parked until my problems are resolved to my satisfaction - I am the person paying for this car after all. Case no. is 71-1048003541.
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    Good morning hollyw108,

    Would you mind sending me an email? I have looked up the case and would like to ask you a few clarifying questions. Please send it to sarah_grace@gmexpert.com

    Talk to you soon,
    Sarah
    GM Customer Service
  • I have a 2011 SRX and am having the same problem. Brought it to the dealer 8 times over the course of a year for various electrical issues, three times it has completely shut down - I get free law service at my company and I honestly think thats where I am now - Car is one year old.. and I just want them to take it back! I am petrified of driving it, afraid its going to shut down and I will get killed... its a nightmare - never a cadillac again.
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    michele61601,

    I'm sorry to hear you describe your SRX as a nightmare, although given the details you have posted I understand. If we can look into this further with you, please send an email to socialmedia@gm.com with more information, including: your name/Edmunds username, phone and address, the last 8 of your VIN and current mileage, and the name of your servicing dealership. If you would also please include any details you recall about visits to your dealer for the electrical issues you alluded to, that would be helpful as well.

    Best,
    Sarah
    GM Customer Service
  • stwallstwall Posts: 1
    edited April 2012
    I am the original owner of a 2006 SRX. I have had multiple prpblems from just turning off to replacing the front axels at 80,000 miles, they were knocking. Last June the engine light come on at 95,000 miles. There was a lose of power and rattle under the car. I spoke to the caillac dealership, they said "catalytic Converter. However, the warranty ended at 80,000 miles, not to mention the parts were back ordered for at least 4 months. Therefore, I took it to a local tech. He placed bothe catalytic converters, and the sensors. $1700+. Now 5 months after getting out of the shop, the engine light is back on, and power loss, same low engine roar, and oil coming back to the air filter. To top it off, I have found where now after the fact GM has extended the warranty on original equipment to 12 years, 200,000 miles. HELP!!!!
  • gmcustsvcgmcustsvc Posts: 4,057
    stwall,
    Thank you for taking the time to post your concerns. I apologize for your frustrations. Can you please email me your VIN, current mileage, and GM dealer of choice? Where did you have it fixed last time? Have you spoke with the dealer since it started again? I look forward to your email.
    Christina
    GM Customer Service
    SocialMedia@GM.com
  • Sounds like we are all having the same issue with this vehicle. If anybody gets a solution, please post. Mine is about to the dealer again for a re-flash of the computer; hopefully that will fix the problem instead of having to purchase a new ECM.
    Has any one at GM figured this issue out yet? It's hard to imagine that with their available resources they can not nail down the issue. I'm not looking for warranty, I'm just looking for a solution.
«13
Sign In or Register to comment.