Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee ABS Light

gallettigalletti Posts: 1
Hi,
I own a 2006 Jeep Grand Cherokee Laredo with a 3.7L V6. About two weeks after the warranty expired, the ABS light started coming on and staying so any time and hard brake occurred. Now it's pretty much all the time. I'm thinking it's the ABS sensor being dirty or gone bad. Any ideas?

Comments

  • ghost_oneghost_one Posts: 11
    .Mostly this is what it is, bad wheel sensor, inexpensive to fix, (Caravans are also prone to this).

    2008.5 GC Laredo diesel
  • yompasmomyompasmom Posts: 1
    The ABS light is always on in my GC. Two mechanics told me that it could cost me several hundred dollars after diagnostics and replacing some computer part.
  • papaman3papaman3 Posts: 1
    WHEN DRIVING, MY ABS LIGHTS UP AND READS OUT, SERVICE ELECTIC BRAKE SYSTEM.
  • 4x4jeep4x4jeep Posts: 13
    auto zone has the abilities to read for codes i suggest go there and down load any codes and then take appropriate action from there. good luck :shades:
  • The ABS light has come on the dash and computer readout states "service electrical brake system". This has stayed steady since it came on last week. The brakes seem to work fine, is this a real problem or can I leave it for now? 116,000 miles.
  • bean_jeansbean_jeans Posts: 1
    edited December 2010
    I had my front brakes done ever since when I reverse and turn the wheel to the right it feels like the right front wheel is dragging. Give it gas and it makes a loud bang and releases and away I go. Except the ABS light comes on, The Traction controll light comes on and it states "service electric brake" The brakes are fine. If I baby it and don't turn the wheel hard when I reverse this does not happen! What is going on!!!
  • Just got done replaceing the head gaskets on my 2000 JGC 4.7. everything went fine. after all was done my ac compressor is not coming on. check all conectors. disconnect the ac switch and jump it compressor came on. replaced the ac compressor switch. still not working. did not disconect any of the ac system when doing the heads. plus check all fuses in the engine comparment. good. is there something else that i am missing, besides replacing the computer, because i think that would be the next thing. any help would be cool thanks.
Sign In or Register to comment.