Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Quest/Mercury Villager problems

1109111113114115

Comments

  • gsusinmegsusinme Posts: 12
    I was planning on cleaning out the air intake path up to the throttle body too... I hope one of these things is it. I got some BG cleaner for it; I heard their additives were good. Can anyone substantiate that? At any rate, it says on the can it will clean out dirt, carbon, varnish, etc. w/o damaging any plastic parts, so I'm going to try it.

    Thanks, Steve. Now all I need is time. ;)
    -Adam
  • gsusinmegsusinme Posts: 12
    Has anyone replaced the left (or either) of the CV joints that could tell me how long it will take to change out the left side?
    The Haynes manual I have mentions a prybar as the only tool out of the ordinary (sockets, wrenches, star hexes, etc) that I would need to take it off. Are there any suprises that await me?
    Any info would be appreciated.
    -Adam
  • gsusinmegsusinme Posts: 12
    This won't be the cheapest thing to do, but you could replace the rusted parts. That would probably be better in the long run anyway; especially if you plan to keep the van.
  • stigmatastigmata Posts: 10
    I have replaced the left side on my 99 villager. It actually wasn't too bad to do. The only real suggestion i have is that I removed the ball joint to make the removal of the axle easier for me. It gave me a little more room to work with.
  • steverstever YooperlandPosts: 39,971
    I did my passenger side a year ago (new axle and boot). It was pretty straightforward but I had a mechanic friend help. I remember reading somewhere that the driver's side axle "pops" in and out more firmly than the passenger's side.

    Steve, SUVS and Speed Shop Host

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • gsusinmegsusinme Posts: 12
    That's what Haynes says to do too. I had someone tell me the job should only take about an hour, but I've never changed out amy CV before. It looks a little more daunting than to just be one hour. I'll probably end up doing it today or Sunday though.
  • gsusinmegsusinme Posts: 12
    Thanks, Steve. I think it was the throttle body. It was covered in gunk on the inside... I cleaned out everything from the throttle body and tried to get what I could from the intake manifold. It already seems to have made a difference. Even if that wasn't totally the problem, it needed to be done... it was very, very dirty. Now I can save that other fuel filter I bought for when it needs it. :shades:
  • athiker95athiker95 Posts: 4
    I was curious as to whether you found out an answer to your squeaking when upshifting. I recently bought a '95 Villager GS with 187K and it does the same thing - just a momentary tiny squeak when it upshifts into 3rd I believe. Anything to be concerned about?

    Thanks,
    Mark
  • athiker95athiker95 Posts: 4
    I have a '95 Villager with 187K on it - the shifter on the column is pretty sloppy. And it gets pretty hard sometimes to shift from P into R. Usually it goes past R and into N and then I have to back it up to get it into R. Anyone have similar shifter problems and is there an easy fix?

    Thanks,
    Mark
  • lexx3lexx3 Posts: 1
    I own a 97 villager, with 240k on it. a very reliable van. the rear heat/ac system is controlled by a small relay on the front control curcuit board. a bad design i think, because mine went and when i checked the board, i noticed where the relay was the board showed signs of burning from the high current flow. i replaced the relay with higher current model and it worked.i'm having problems with the wipers as well,but i think my problem is with the control module in the engine compartment.i've replaced the power lock motors on the pass. and side doors when they started to give me problems,they work great now. my only real problem right now is the egr insuffinent flow. i seem to have vacuum problem because my egr valve won't move but if i place a vacuum to the valve it moves.i'll check it out soon.
  • phil16phil16 Posts: 2
    I've have the same make, model and year with the same noise. I've tried to locate the problem but no luck so far. Have you been able to fix it?
  • budman007budman007 Posts: 3
    I have a 2000 Nissan Quest Van, The problems are...it runs very heavy and sluggish most of the time. However, the last few months there is a new twist, If your going say 50 mph on the road normally, all of a sudden the van loses all gas and everything just shuts down(power wise) you have to put it in neutral and hold it down to the floor for it to keep drawing gas, then it takes off again. I think it would die if you didnt pop it until neutral. This has happened going from the slowest 30mph up to the other day at 80mph on an open highway....it feels like you just take your foot of the gas and starts slowing, then as you pump or hold the pedal, it tries and and tries to get gas. Now, I have saw posts about the throttle bottle and I am going to attempt to clean it myself this week(thanks for the instructions I found on this site), but I think they maybe more then this. Last time when we took it in after the first year for it being sluggish they charge 400.00 to clean the injectors and say it's the same thing, but I can't believe it....any ideas? Air filter is a bit dirty, but not that bad...Also gas milage is a scary 15 hwy, 12 city!!! HELP!!!
  • budman007budman007 Posts: 3
    I have a 2000 Nissan Quest Van, The problems are...it runs very heavy and sluggish most of the time. However, the last few months there is a new twist, If your going say 50 mph on the road normally, all of a sudden the van loses all gas and everything just shuts down(power wise) you have to put it in neutral and hold it down to the floor for it to keep drawing gas, then it takes off again. I think it would die if you didnt pop it until neutral. This has happened going from the slowest 30mph up to the other day at 80mph on an open highway....it feels like you just take your foot of the gas and starts slowing, then as you pump or hold the pedal, it tries and and tries to get gas. Now, I have saw posts about the throttle bottle and I am going to attempt to clean it myself this week(thanks for the instructions I found on this site), but I think they maybe more then this. Last time when we took it in after the first year for it being sluggish they charge 400.00 to clean the injectors and say it's the same thing, but I can't believe it....any ideas? Air filter is a bit dirty, but not that bad...Also gas milage is a scary 15 hwy, 12 city!!! HELP!!! :confuse:
  • gyatesgyates Posts: 55
    I have a 1996 Villager. The rear air quit working some time ago. Recently, I replaced the front a/c control unit with a "recycled" unit, and the rear air worked perfectly. For about 1 week. Now the rear air does not come on until 5-10 minutes after I have started the van. Once it does start working, it works great. Any ideas?
  • bill321bill321 Posts: 2
    I have a 2002 Mercury Villager. I have to replace the passenger side side view mirror. It looks like I have to remove the interior door panel to do this. Any tips or tricks for doing this?
  • steverstever YooperlandPosts: 39,971
    My driver's side mirror has broken again so I'll be taking the door panel off soon to apply yet another coat of epoxy to it.

    After removing the screw under the plastic cap in the door handle area (assuming your trim is similar to my '99 Quest's), you pop the retaining fasteners from the interior panel. I start at the bottom edges and work my way up, usually just using my hands.

    You'll probably break a few of the fasteners, but I hear that replacements are available at the big box department stores. I'd guess there are 8 or 10 fasteners to pop loose. My panel seems to fit fine even though a couple are missing now.

    Once the fasteners are loose, the panel lifts upwards and then away from the window. I usually remove the power window/door lock switch before doing this to get it out of the way.

    Then you should see 3 bolts holding the mirror assembly on the door frame. Once they are out you can disconnect the wiring and ease the mirror assembly off the sheet metal.

    Where did you find your replacement and how much did it cost? Epoxy isn't getting any cheaper. ;)

    Steve, SUVs & Speed Shop Host

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • steverstever YooperlandPosts: 39,971
    Check this link under subtopics - usually it's a bad solder connection at the rear blower motor relay:

    http://home.earthlink.net/~vqfaq/.

    We really should get that info in here in case that link ever goes down...

    Steve, SUVs & Speed Shop Host

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • stephen16stephen16 Posts: 4
    Today I was rear-ended while sitting at a stop light and the other driver took off. The police officer who filled out the report said the bumper looked pretty good, and probably didn't need any repair as he filled out the report. The only definite damage I can see is a small scratch. The bumper feels solid when I push on it from behind, but when I push on the sides where it connects to the van it seems a little too loose.

    I can't tell if there is any serious damage or not. Does anyone have any experice with rear bumpers? I know my insurance will cover any repairs, but it infuriates me that it will probably result in my insurance premium going up because of some jerk driver. I'll take any advice I can get in trying to decide whether or not to take the van into a shop.
  • bill321bill321 Posts: 2
    Thanks for the info. I wasn't sure if it was possible for mere mortals, or if I had to go to the dealer ($350!).

    The best price I found was at www.automotivemirrors.com. It's around $75. But I didn't look very long, and didn't look into shiping, etc. I have never dealt with them, so I can't really recommend them, but I think I'll give them a try.
  • fljewelsfljewels Posts: 2
    Have you tried replacing the fuel filter(s). My Villager died in the middle of the road 2 years ago. We had the fuel filter replaced and everything worked fine.
This discussion has been closed.