Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Quest/Mercury Villager problems

18788909293115

Comments

  • arkiegirlarkiegirl Posts: 1
    My 99 quest has had just about every part of the braking system replaced by the dealer. Still the left front brake will stay on while you are driving and have taken the foot off the brake. This has resulted in a burning smell and a very hot tire which alerted us to the problem and we took the car right over to the dealer. The company was called and all their suggestions have been tried. Today they are replacing the master brake cylinder for the second time. Anyone else had this problem. Thanks Arkiegirl
  • Claire@EdmundsClaire@Edmunds Chicago areaPosts: 968
    Welcome to the Forums, arkiegirl! You might also want to ask about this in the Stop here! Let's talk about brakes discussion in our Maintenance & Repair Forum. I think the members there might have some valuable feedback for you.

    ClaireS, Host
    Coupes & Convertibles | Vans & Minivans

    Claire

    HOST

  • After much research, I purchased, two weeks ago, a '99 Villager Estate with just under 17,000 miles on it. All seems well and good, but has anyone found a practical way to bring the fuel mileage above 20 mpg? And, is there anything about which I should be wary?
  • steine13steine13 Posts: 2,409
    >20 mpg? Easy. Put the cruise on 70 mph and don't move it. 24.1 mpg on my 2000 w/ 83k.

    I understand this isn't always possible in town...

    -Mathias
  • kymikekymike Posts: 115
    My '99 Estate has about 89,000 miles on it. No major problems to date, just the normal minor annoyances of rattles from the middle seats and the middle side window latches not wanting to hold the windows closed tight.

    I struggle to get better than 21 MPG on the road and 17 MPG in town. Still on the original shocks/struts - about time to consider replacing them. I have found this vehicle to be very reliable and a pretty good value.
  • toomanyfumestoomanyfumes S.E. Wisconsin Posts: 892
    I get 17-18 MPG in town with mostly stop and go driving. I just took an 800 mile trip with a mixture of interstates, four lane highways, going through some small towns, and getting stuck in traffic. I got 22.5 MPG, and I had the van fairly loaded up. I have a 2001 base with 39K.
  • reedbrreedbr Posts: 2
    It's OK, the Vehicle Speed Sensor (VSS) part is only $35 from the dealer. It's one of the better deals. Mine died the exact same way last summer on a road trip. The only killer is that the cruise control won't work if your on a trip, and after about 30 miles of it not working, the CE light will come on since the computer uses road speed for some of it's calculations. After replacing the VSS, the CE won't go off until you reset it with an OBDII scanner.
  • reedbrreedbr Posts: 2
    I haven't thought much of this until I read your post. As part of my 60K mile maintenance (done slowly over the course of 6 months and 5,000 miles) I replaced the spark plugs, distributor cap, rotor, and plug wires. I was getting 20mpg on road trips with the van loaded down and running down the road at 75mph. I just finished a week on vacation and was surprised when my milage was better than 23mpg on every tank, again loaded down. I didn't put the two together until just now.

    By the way, I used offical dealer parts and they were expensive. However, the fit was perfect which made the installation a breeze.
  • crit2crit2 Posts: 6
    I wish the cost was only $35. I paid $147 at the dealer for the sensor... Called all of the junk yards in the area and they had none. It appears that it corrected the problem. "fingers crossed"
  • agape2agape2 Posts: 1
    I have recently become the owner/driver of a '93 Villager.
    It is in pretty good shape, and I like it well enough - except for just
    2 things - I am used to a smaller, less thirsty vehicle....but that is
    just a fact - my question is about the 2nd thing - the central locks
    work, but the driver's door lock cylinder is jammed, maybe with a
    broken key fragment inside, so, my question:

    Would someone tell me where the relay lives that controls the
    locks when the lock/unlock button is pressed ?
    I have a nifty little remote unit I would like to wire in so I don't
    have to take apart the driver's door OR always unlock the
    passenger's door to get in each time.....

    Thanks !

    mark
  • jblake3jblake3 Posts: 2
    I have a 94 Villager LS with 101,000 miles. I was informed by the dealer's service department that I have no braking at all with my rear brakes due to a broken proportioning valve. Price for part and labor for a new valve is around $375.00.

    My question is. If I have no braking with my rear brakes wouldn't my brake warning light go on
    whenever I pressed on the brake pedal? The brake warning light does come on and then
    goes off when I start the car. I did some research today on the function and how the hydraulic proportioning valve works. From what I understand, the valve doesn't stop hydraulic fluid from going
    to the back brakes, only limits the amount of fluid going to rear brakes during hard braking to prevent the rear brakes from locking up.

    Is the service department trying to rip me off? What are your opinions?

    Thanks John
  • lifesavinlifesavin Posts: 2
    I recently purchased a 95 Nissan Quest XE. I'm having problems with the van dying. The van runs absolutely perfect except OCCASSIONALLY when I slow for a stop sign or corner, the van dies. It doesn't putter or make any noises, it just dies.

    Any ideas would be greatly appreciated! I really don't want to take it somewhere and get totally ripped off if it's something small I can fix myself (or honestly so my husband can fix it!).

    Thanks!

    :cry:
  • duaneh1duaneh1 Posts: 1
    The rear fan stopped working several years ago on my 96 Villager. The fix is relatively simple. The following instructions may be slightly incorrect, I'm doing it from memory.

    The problem (at least on mine, I think it was fixed in later models) is that the high current line for the fan power goes through a PC board trace in the control unit. The trace just isn't large enough to reliably handle that much power. If you pull the control unit (dash) you'll probably find a burned trace. The fix is to just replace this with a soldered in wire. I think the fix on later models was to change this signal to control an additional relay that switched the high current.
  • tchutchu Posts: 1
    I have a 96 mercury villager with 124, 000 miles. Today I replaced a new throttle position sensor, and afterward I went for a test drive. I noticed that the acceleration was very slow from first gear to second. It was not like that before I replaced that sensor. So I decided to put the old TPS sensor back and went for another test drive. The slow acceleration is still there. I was wondering if there is a trick to install the TPS sensor or it was just coincident that a new problem exist.
    So I tried isolating the problem by putting the vechicle from a dead start and put the transmission on D1 and shift to D2 and to D. The van accelerate fine by maual shifting. Can this be a problem in the transmission or a cable need adjustment?

    Thank you,

    Tony
  • I have a 2002 Quest which I had one of the front motor mounts replaced 3 months ago. I took it back to Pep Boys today and they say now I have a front and a rear motor mount broken. Not sure if it is the same front one or not as of yet. This car only has about 35000 miles and I have owned since it had 27000. Is this to be expected? Also, I wonder if the dealer would know a trick to repair where they will not break again or can I assume Pep Boys knows what they are doing?? Thanks.
  • off_momoff_mom Posts: 1
    My husband was driving our 96 Mercury Villager GS on the interstate (70 mph) when the "back end tried to pass him". He spun around and hit a concrete divider with the back passenger side. Fortunately he was uninjured. He has no idea what happened, except when you look under the rear passenger side of the van, the suspension is broken. Someone has told him about "catastrophic suspension failure". I wondered if anyone out there knows anything about this.

    P.S. The van was purchased in 1998 with 65K, now has 177K. No other major problems. We've only replaced the compressor for the a/c in addition to regular maintanence.
  • richbalrichbal Posts: 1
    I'VE BEEN DEALING WITH NISSAN ABOUT THE FAULTY CRANK THEY INSTALLED IN THE 93-95 MODELS FOR THE PAST 20 MONTHS AND HAVE A COURT DATE NEXT WEEK TO RESOLVE MY CLAIM. I HAD MINE FAIL AT 160K BUT SINCE THEY WERE REPLACED BY A LARGER CRANK(25TO32MM) IN THE 1996 MODELS I FEEL THEY ARE PARTIALLY RESPONSIBLE. I WILL BE TRYING TO CONVINCE A WOMAN JUDGE SO ANY SUGGESTIONS ANYONE HAS WILL BE GREATLY APPRECIATED. THEY HAVE GIVEN ME THE SILENT TREATMENT SO FAR AND THE $3500.00 BILL NEEDS TO BE ADDRESSED. THANKS FOR YOUR HELP!
  • joenuke1joenuke1 Posts: 1
    Did anyone ever find a solution to disabling the security system on the quest??? Mine is having many issues and I just want to lock the door by key without it setting off the alarm.
  • tod13tod13 Posts: 1
    I too had a problem in heat last week driving into high altitude. I have 1995 Villager with over 100,000 miles. Van just died while driving with air on and into hills. Tow truck driver said I was six vehicle that day with similar problem. He suggested that it was "Vapor Lock," however, I have heard this does not exist on newer vehicles anymore. Even though, he turned the gas cap slightly and the van worked okay for remainder of weekend in altitude. Also suggested that after filling up tank in lower elevation and than rising to over 7000 feet contributed to problem. My mechanic did not think this was problem but will not be able to recreate problem in lower elevation. So, is it a vacuum issue, emissions problem, gas cap, anyone have a clue?
  • Claire@EdmundsClaire@Edmunds Chicago areaPosts: 968
    Good luck, Richbal. By the way, typing in ALL CAPS makes it look like you're shouting at readers, so it's best to take your caps lock when you post.

    Claire

    HOST

This discussion has been closed.