Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Subaru Impreza Outback Sport & TS

1959698100101103

Comments

  • Yeah, it was fixed. SIA employees immediate family members get some good rebates from SOA. i got invoice for the VIP plus 1500 rebate for being an immediate family member. Thats rebate on impreza since they're made in japan, not in the us. same goes with forester. [hope i'm not hung for this] now, the US made cars, legacy, outback, tribeca. get a larger rebate, at least for SIA employees, etc. [the reason i'm worried about giving this information is the cars101 site was asked to take its info on the VIP program down. and if i'm out of line, i'll surely edit my post.]

    if you're simply a 'friend' or non-immediate family member. it should be invoice plus 2% off.

    current offers and specials for VIP are even greater if you're getting an 05. often invoice plus a certain cashback offer. then, any rebates for friends and family on top.

    i tried hard to find an 05 OBS SE before settling on the 06. but i'm happy. and by the way, my dealer has taken care of my issue with getting the VIP info from SOA. my car is on the carrier and will be here this week! pictures forthcoming. i've been driving on a donut for a week. ;)
  • raybearraybear Posts: 1,776
    Not "always" but when I bought my OBS, 4 out of the 5 offers from internet salesmen were below the "invoice" price.

    Depends on who's quoting...around here most of the guys will go below invoice also, but a few of them have a no-quote policy. I always quote the same way regardless of who the customer is.
  • the regal blue pearl outback sport SE 5 speed with short throw shifter has arrived. picked it up today. the whole dealership was commenting on the colour, the blue and grey really look striking in daylight [and night-light]

    the "260 watt" sound system is quite lacking in the high-end... some distortion at higher volumes. eh, oh well.

    took me 2 hours at the dealer to get everthing taken care of and i'm just glad its in my hands now.

    i went from a 98 mitsu eclipse to this and it is night and day. subaru definately has a rumbleish sound to the engine that i still can't get used to, but i'm sure i will. i'd be a bit more worried over this noise, but the three other imprezas i've test driven since 04 have all felt/sounded the same. i'll miss the low ride and comfortable seats of my eclipse, but i'm in love with my new subaru. i'll try to snap some photos and post them soon. too bad the break-in period is a whopping thousand miles. yikes! and she already stalled on me once. :cry:
  • rshollandrsholland Posts: 19,724
    My son also just took delivery of a new '06 Outback Sport SE the other day too. His is a Steel Gray/Crystal Gray automatic version, and he loves it. He traded a '96 Impreza Outback, which he had for 10 years (and had over 132K on it), so he's really able to see—and appreciate—all the improvements made over the last decade.

    Good job Subaru! :)

    Bob
  • cbmortoncbmorton Posts: 252
    Don't worry about the engine sound - it's normal. You might even start liking it. I sure do. Gives it character. There's a sweet spot above 4000 rpm on my '04 where it's pulling strongly and sounds great, but even at lower speeds I enjoy the rumble. Congrats on the new car.
  • ateixeiraateixeira Posts: 72,587
    I love the sound. Very Porsche-like (water cooled Porsche).

    -juice
  • well, after this break in period, i'll enjoy that 4000+ rpm sweet spot. i accidentally hit 4 grand today pulling into traffic. yikes! but yes, the bump in power was there. i'm loving the car and my only gripes are the sound of the stereo and the brakes are very different. took it around a bunch of twisty/bumpy roads today and i thought it handled quite smoothly/nicely without a lot of roll.

    the steel grey top/crystal grey bottom was my second choice when i was looking for an 05, but since i decided to go with the 06, i would have nothing but the regal blue pearl. i almost don't like the attention the car is getting because i tend to shy away from that, but it does instill a feeling of pride. especially from the other subaru drivers around here.
  • ateixeiraateixeira Posts: 72,587
    Yours is an 06, right?

    I like the new front end, the more I see it, the more I like it.

    -juice
  • aye, 06. i'll take some better pictures and post links soon.

    tonight while driving home, i was coming up an embankment in 5th gear, 50 mph, and the rumbly tick of the engine was gone. all i heard was that nice whine. so, now i'm curious what sound i'm hearing in 1st-3rd gear and early in 4th. aside from the standard subaru break-in, is there anythign else i should be doing? i did have one nasty stall on a steep incline at a stop light. scared the crap out of me.
  • ateixeiraateixeira Posts: 72,587
    Try not to lug the engine, i.e. revs too low for the conditions. 50mph in 5th going uphill is probably putting more of a strain than necessary.

    -juice
  • hey all. i'm getting some condensation in my tail lamps in the mornings and after washing my car.

    whats the best protocol in this situation?
  • ateixeiraateixeira Posts: 72,587
    That happened to our old Mitsu Mirage right before we sold it.

    I removed it, aired it out to dry, then replaced it.

    If I were going to keep it, I'd probably add some sort of sealant, maybe silicone or the black stuff used for RVs.

    -juice
  • if thats the case, since it's only a week old, i may ask the dealer if they will replace both of them.
  • ateixeiraateixeira Posts: 72,587
    Just replace the one that is condensating, unless both of them are?

    -juice
  • Hello all!

    I'm new here and I hope I'm posting this in the right place. :) I bought a 2002 2.5 TS wagon last year and I love it to pieces. I only have one issue with it, when the weather gets cold the clutch gets a little funny and the car chugs when I take off. I've heard that the Impreza does that, but why? Is my clutch slowly destroying itself?

    Thanks,

    Ben
  • rshollandrsholland Posts: 19,724
    Hi Ben. Unfortunately clutches do wear out, and it sounds like yours could be on the way out. BTW, it's not just an Impreza problem, as most if not all clutch-equipped cars will eventually run into this.

    Bov
  • ateixeiraateixeira Posts: 72,587
    There is a TSB about this, though I doubt adjustments will help.

    Oddly, it doesn't seem to affect longevity of the clutch, only the operation. The chatter should stop once the powertrain is warm, or if you do a couple of burn outs in reverse.

    Not that I'm recommending the latter. :surprise:

    -juice
  • Back again, after another long absence, and I'm looking for answers......... again.

    I'm wondering how critical the wheel offset is to wear on the wheel bearings?? I've tried to read all the wheel charts presented on I-Club and other sites, and it appears that if the wheel and tire combo will fit without tire contact with the wheel well, then owners will go with what looks good to them. Yet, in the Suby service manuals, a specific wheel offset is called for on each individual model.

    I want to use an older Impreza RS sedan wheel (offset 53mm) on an '03 Impreza OBS wagon (spec offset 55mm). Can anyone tell me, based on experience or technical knowledge, if this small difference is going to have any long term bad affects on my wheel bearing wear??

    TIA for your input, and best wishes for a Happy and Prosperous NY to you all..........Terry
  • Ben, my first Suby was an '02 OBS, and it was plagued with the so called clutch shudder/chatter or whatever you want to call it. Many "old Suby owners" claimed this was normal and typical. I didn't buy it; and after two clutch replacements, the second one as a result of the bulletin mentioned by Juice, the problem was resolved.

    I have since owned an '03 Impreza, and it did not have any of the clutch chatter problems. I have also owned several other Imprezas, dating from the 2000 model through the current 2006 model; and I have not had any clutch chatter problems with any of them.

    You didn't say how many miles you have on your wagon, but a good service manager may get the problem resolved for you under the old service bulletin. Unfortunately, this didn't ever become a "recall" item. You had to ask to get the problem resolved. So, you've got nothing to lose by asking about the fix at your local Suby dealer.

    Good Luck..........Terry
  • ateixeiraateixeira Posts: 72,587
    2mm is a very tiny difference, you should be fine. My aftermarket wheels are 6mm different and I've had no issues at all, in fact the tires wear more evenly now than they did with the OE rims.

    -juice
  • juice,

    I appreciate your input. I didn't think it would be a problem; but wondered why the Suby shop manual didn't give a range of offset fits rather than a specific offset for each model within the same model year.

    Thanks again.........Terry
  • Thanks all for your input! I think I will ask the local Suby dealership about it. The car only has 45,000 miles on it. Way too short for the clutch to be going out already, I thought. I don't drive it like a nut either (all the time, anyway) :) Speaking of driving it like a nut I think I will ask the dealership AFTER the autocross this weekend! The clutch went out on my Isuzu Rodeo, and that just started slipping like crazy. This was something very different.

    Thanks again!

    Ben
  • Hey everyone,
    It's been a while since i've posted but I'm the happy owner of a carolina blue 05 OS. I've got a few questions for all you Subaru gurus out there. First off, I've suffered a few scrapes on the grey/goldish plastic panelling that makes the car 'two-tone'. Any ideas on how to remedy this? I saw an older subie on the road with dings all over the plastic and I'd like to prevent that (it's black underneath the coating).

    Next, and much more painful to me, I suffered a horrendous ding on my hood driving on the interstate the other day. I saw the *#$@ing rock get thrown up by the 18-wheeler and watched in slow motion as it bounced once, twice, and then bang, right into my hood. Cut through the paint and I can see metal...:(. I ordered some touch up paint from Subaru but I think I want to take it in to have it professionally done...last time i did this (on a different car) it looked terrible. Any brilliant ways of doing this yourself or ideas on how much it should cost???

    Finally, when I shift into third, I hear a rather rough, metallic sound as the shifter slides into the gate (it's a manual). It doesn't happen all the time but when it does it's embarassing...the car is only 3 months old. Anyone experienced this or have any idea if it's normal? Thanks!
  • ateixeiraateixeira Posts: 72,587
    The cladding is painted also, so change your order for 2 bottles of touch-up paint.

    Add very, very little at a time. Let each coat dry. Some people even use toothpicks to hold less paint. Just take your time, do several thin coats instead of one big glob of paint.

    I'd report the clunky shift to the dealer, just in case the problem reappears later. Maybe check the gear oil level? It's the yellow dip stick on the transmission tunnel.

    -juice
  • Hi everybody. I have been lurking the forum since July of last year when I bought my brand new OBS '05 (now with 9200 miles on). Lots of friendly helpful folks in here.
    I did a search on my problem and either I dont know how to search in these forums or nobody has discussed this before. So here it goes:
    I was driving on an interstate last sunday doing around 70-80 mph. I started noticing the temperature gauge was going up. I stopped at a gas station and saw that the coolant plastic reservoir was empty and there was coolant splashed all around. I was kind of freaked out by this but being that I was 300 miles from home I decided to buy more coolant and added it thinking of taking it to the dealer on Monday. It worked fine for the next 290 miles or so and when i was almost home it did it again. I took it to the dealer on Tuesday and they told me that after all the diagnostics they couldn't figure out what the problem was. Head gaskets seemed OK, radiator OK, etc... even the coolant was withing the temperature rating required.
    Now some background. I noticed some 3000 miles ago (late oct 2005) that the coolant level was low so i took it to the dealer and they said that they found a loose clamp but they had tightened it again.
    Anyway, I am worried an almost new car is showing this problem, and even more worried that the dealer dismissed my claim. Anybody has some idea of what could be wrong? Thanks a lot in advance and sorry for the long post.
  • If the clunk happens when you let the clutch out, then your rear diff is hitting the bottom of you trunk. This is very common on Impreza's. There are some kits that prevent this by replace the weak stock bushings with harder ones. Look up Turn in Concepts, they make a kit called Klunk Killer which fixes the problem. I do not work for them, but I have the kit on my car.
  • ateixeiraateixeira Posts: 72,587
    Keep the receipt, the dealer diagnosed a loose clamp, but if they missed something, you're covered.

    -juice
  • I just bought a 2006 OBS last week. Three days after driving it off the lot, a rock hit the windshield while I was driving down the highway. I called several glass places to get estimates for replacement, and one of them told me that in the past 2 weeks he has had 10 '06 Subaru's come in with cracked windshields.

    I called the dealer and of course they did not have any info about possible issues.

    Has anyone heard anything about windshield issues with new 2006's?
  • ateixeiraateixeira Posts: 72,587
    I have not observed a pattern yet, but call 800-SUBARU3 to report the problem, so they can start tracking it.

    Does your insurance cover glass? In MD it has to, by law.

    -juice
  • dstew1dstew1 Posts: 275
    Not for the OBS, but I had about 5000 miles on my 06 Forester when I got my first cracked windshield about a month ago. It's not uncommon at all for rocks to hit my windshield; I don't know if it's aerodynamics, windshield height, or what.

    Does the OBS windshield have the heating elements in it for the wiper blades? If so, I hope for the sake of your checkbook that the insurance is covering replacement...

    Doug
This discussion has been closed.