Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2010 Chevy Equinox Problems

12627293132116

Comments

  • tanastanas Posts: 8
    edited September 2010
    This is my story so far: (4 cyl. 2010 equinox)

    When starting the engine (not always) I can hear a short sharp noise coming from the engine
    Dealer service department solution:
    - CAM phasres replaced and R&R the CAM actuator solenoid checked for debris (no debris found)
    - CAM positioning actuator (exhaust) replaced and checked for debris
    After that the noise was gone!

    Two months later:
    - When accelerating on uphill from 0 mph, between 1500 and 2000 rpm I can hear a repetitive clatter (knocking) noise coming from the engine (left side). The noise is louder when the AC is ON.
    - When starting the engine (not always) I can hear a short sharp noise coming from the engine. Same problem as two months before. I think came back at the same time when I noticed the other problem.

    First visit at the dealership service: They drove the car and said that they couldn't hear any noise. I got in the car with one of the technicians and after the test drive he agreed that there is a noise coming from the engine area and suggested replacing the AC pump, although I knew this was not the problem.

    AC pump replaced, I took the car and when I got home I heard the same noise again.

    Went back and the technician suggested top engine cleaning.

    Cleaning completed, and according by the service manager they drove the car and the noise was gone.

    BUT when I took my car and went home the problem was still there.

    Back again and when I got there they were upset because I was back with the same problem and almost blame me for the problem. We got in the car (me and the service "manager") and drove the car so he can see that I'm not the liar. He remained without words.
    After that he said: "I will call GM to find out what is the problem but now there is nothing I can do"
    Next day :
    The service manager said that GM is working on updating a software to recalibrate the spark plug which sounds good (for the pinging noise), but I don't think that that kind of noise at certain rpm can came from the spark plugs.

    The engine works differently (worse) than 6 months ago, sounds like a diesel engine, is much louder and mpg is getting worse (was pretty good 6 months ago).
    I have been having trouble with hard shifts between 30 and 40 mph.

    It becomes more frustrating.
    Saying sorry all the time is not helping at all
  • When starting the engine (not always) I can hear a short sharp noise coming from the engine
    Dealer service department solution:
    - CAM phasres replaced and R&R the CAM actuator solenoid checked for debris (no debris found)
    - CAM positioning actuator (exhaust) replaced and checked for debris
    After that the noise was gone!

    I also hear a sharp noise sometimes like the starter is scraping or something.

    I have been having trouble with hard shifts between 30 and 40 mph

    I have posted on this one twice. Took it to the dealer and they reflashed the ECU worked for about 2 weeks and started doing it again. I have decided that if GM does not come up with a fix before March of 2011 I am getting rid of my Equinox. Better hurry up GM or this will be my last GM purchase ever!!!!!! My father retired from GM so considering getting a GM rep. involved soon.
  • Wonder what GM is saying to this dealership service department that is (allegedly) changing parts left and right, THEN calling GM "to find out what the problem is".

    As for the "sharp noise" when starting the engine, have you tried starting the car with someone underneath or looking over the top of the engine while turning the key? Have you tried changing the motor oil and running it through a screen mesh (much like what is done to catch a kidney stone)? Sounds like a metal to metal noise of some kind. Misaligned starter motors can cause a metallic shriek at startup when they engage the flywheel improperly, but I doubt that would be your problem on a brand new vehicle. I think this happens on a used vehicle where the starter motor has been replaced but a required shim plate was left off.

    I'd be screen-filtering the motor oil to see if there are any fragments in there from the factory.
  • elli2elli2 Posts: 14
    I am new on this board, but happy to have found it. I have had my 2010 Equinox LT2 for about 6 months and basically like it a lot. My biggest complaint is the jerky transmission and a hesitation problem. I notice it the most when I'm going reasonably fast (over 40) and then have to brake, like when traffic slows down. During the braking, if I then have the opportunity to accelerate again, the transmission often will hesitate for 1-2 seconds, and then the car bucks forward. This also happens, for instance, when I'm on a highway and want to change lanes if I get behind a slow driver. I slow down a little, and when I go to accelerate to change lanes, it hesitates and then bucks. The hesitation has almost caused an accident for me when it hesitated as I was attempting to change lanes. At first I thought that this hesitation problem was "just how the car is," but after reading this forum, I'm thinking that this is not normal. Have others experienced this? Is there something Chevy can do about it? I have not taken the car for anything but an oil change.

    Another transmission thing: I also find that when accelerating up a highway hill at a reasonably high speed (60+) the transmission whines really loudly until I release my foot from the gas.
  • They supposedly rolled out the "Fix" for the knock, but consequently there induced more problems as well. Since updating the cals on the ECM in my 2010 equinox, I know am getting "Service Power Steering Soon" displayed in the DIC, and my "ECON" switch is indicating a high voltage situation which in turn sets a DTC and the CE light comes on. Up until this point I was really satisfied with my 2010 Equinox, but I think when and if its fixed this time, I will drive it directly from the Chevy lot to the KIA dealership. I am really fed up with Government Motors and there lack of customer focus.
  • Yes - I as well have experienced the "bucking" problem with the transmission.
  • When was this update released, I was just at the dealership yesterday for the "spark knock" update and they said that nothing had come out yet, but that it should be soon?
  • I just picked up my car from the dealership where I had them look into why my car was stallling. They replaced the exhaust acctuator and so far it is running a bit better. Will keep everyone informed....
  • Call from a GM customer specialist (more like a middleman) today:

    "Spark knock" update in the next 6 - 8 weeks

    If you ask me I don't think that something will happen before New Year
  • Last fall they approved a new transmission calibration in late Sept. I got it from a GM engineer literally the day after it was approved. It started to go into production vehicled supposedly the week following that. It was supposed to be available to dealers by late October. If you look at the technical service bulletins, this particular TSB (for the tranny cal) is dated as being available on Jan 1, 2010, about two months after it was supposed to be. That is, of course, if the date is right. I have no way to know if it is or not.

    I'm not worried about the knock sensor update, though I'll probably get it when it comes out. It is fine using premium, and Shell V-Power has way more detergents in it to keep injectors and such clean. So I'm OK paying the extra $4.50 per tank for that. Replacing bad injectors (which is necessary withing 100k miles if you use bad gas) is very expensive (often $1000 or more).

    What I REALLY want is for them to come out with another tranny calibration that makes the thing drive normally. The six speed in the Malibu, for example, is silky smooth, but it has a normal calibration. The downshifting characteristics, (including the "bucking", as some have called it, at times while downshifting) are the only complaints I have about this vehicle.
  • rockiesfanrockiesfan Posts: 3
    edited September 2010
    Update on the sticky steering. GM replaced entire steering rack, module and pump and so far..........no sticky steering. Airbag light continues to come on and GM is having trouble locating a new part (airbag sensor). Had rental car for over a week while they worked on steering and tried to fix airbag light issue. Was pushing 2 weeks when GM called and had me come pick up my nox until the new part arrived. I also reported that transmission is not shifting correctly on interstate while cruise control is on. The 4 cl is having trouble upshifting into the higher gear after passing or cresting hill. They drove and couldn't replicate. Anyone reading all these posts, looking into buying one of these, heed the warnings. DO NOT BUY THE EQUINOX.
  • hi ,i am from canada i have this noise from the engine too, the dealership said is normal for this car ,i do not trust them, this noise sound like problem engine , i see so many people in this forum having this kind of problem .
    Anyone with this problem ,fixed the car yet?Did the GM came with the software that they were talking about?Can some one please, reply with any advice or info.... Thanks.
  • gmcustsvcgmcustsvc Posts: 4,055
    Hello Nbildan,
    I apologize that you are experiencing a concern with your vehicle. If you don't trust your dealerships opinion you could take it to another GM dealership for a second opinion. Thank you,
    Mariah GM Customer Service
  • kristy8kristy8 Posts: 72
    I have already just this past week had my update done......it was done so
    unofficially, according to my dealership the official update to the software for the misfiring spark is out in November. I had mine done because I had made so many complaints to the consumer action council here in my state and I think they wanted to shut me up and get rid of me. I have to say since I had the update done the noise is very, very, very minimal and I hardly notice, I think I may have heard a slight knock and I had also went back down using the lower grade fuel. I also have to add since the update was done it doesn't seem to down-shift as much and less bucking. We shall see
    though I have not opened it up on the highway yet since I got my nox's back.
  • kristy8kristy8 Posts: 72
    I had mine done already unofficially, the official update is due out in November
    I have to bring mine back in November again for another update, since the update so far so good!
  • kristy8kristy8 Posts: 72
    I wanted to keep you posted since we have spoken before regarding the spark/knock problem.....I had my software update this week, Now the dealership said pretty much I had the "unofficial update done and I will have to return back in November for the official update" whatever they did it definatelty is running better and so far I haven't heard the secondary noise that we have spoke of in the past. I did mention that it down-shifts weird( before the update was done ) it bucks and also vibrates like crazy......have you experienced the vibrating? He said well lets see how it runs after and let us know. Since I just got it back this past Tuesday I really have not had a chance to "really" test out the car and have not opened it up on the highway to truly to test the downshifting and the bucking/vibrating. BUT i do have to say the noise that was there is gone so far...I thought I may have a heard a slight one knock? but that's debatable. I also went back to the lower grade gas. So far so good...let's see
  • kristy8kristy8 Posts: 72
    read my post ....we have had the same problem,
    I had my update for the software, next update is in November
    I went through the same hassles as you....keep on them :shades: :)
  • kristy8kristy8 Posts: 72
    I had my software update for this problem done already Unofficially
    the official update is coming in November., maybe I was their guinea pig
  • kristy8kristy8 Posts: 72
    Hi
    I have too dealt with this same issue...I have been complaining and complaining and finally the dealership had just completed the "unofficial" software update for my nox.
    The official update is due in November
  • kristy8kristy8 Posts: 72
    POSTING ON MY OWN POST
    *************UPDATE*************
    had the software update done
    so far so good...according to
    the dealership the official
    update is due NOW in November :confuse:
Sign In or Register to comment.