Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2010 Chevy Equinox Problems

1343537394078

Comments

  • ray80ray80 Posts: 1,239
    Hope you get the oil problem resolved if it beyond acceptable range.
    Also I would never wait for an oil light to come on to add oil, by the time it does you are way low.
    Its the owners responsiblity to periodicly check the level and add as needed in between changes.
  • Your claim is extremely serous and I find this very hard to believe, if this is really what happened, you should let GM know with the person's name and phone number.
  • I have had the knocking-like sound on my 2010 Equinox for sometime and the service guy told me the same lie (fuel pump noise) which I don't believe it (if this is fuel pump noise then every Equinox should have it, which is not true). The sad thing is that you almost have to pin-point the problem before they can help you resolve it. I took it to my dealer three times for this problem and finally gave up (Every time I take my car for dealer service, I'm afraid that they will screw up something else). I would be interested to know what happen to you next.
  • Smc8888 (and other posters, as well),
    If we can be of any assistance (help work with a dealership towards resolving a concern, looking into warranty/recall information on your vehicle), please email us your name/user name, contact information, the last 8 digits of your VIN, and your involved dealership.
    Best,
    Sarah
    GM Customer Service
  • dmathews3dmathews3 Posts: 1,739
    edited November 2011
    Did GM call or your dealer? If dealer than I suggest that you find another dealer as I have never heard of such a thing and the way the dealer is screwing you around it aint going to get any better. He sounds like he should be working on lawn mowers instead of cars. I sure hope there are other dealers not to far away.
    And by slight chance if it really was a GM bigwig than I sure hope our customer service rep here steps in and straightens it out and if they can't they need to just go away slso as they aren't any better than whoever gave you the bull about the sensor. Customer Service you need to make this right as if what she has posted is even near the truth and I believe it is all the truth you need to see she gets this fixed NOW with another engine installed somewhere else besides the fly by night dealer she is using now.
  • gmcustsvcgmcustsvc Posts: 4,064
    cgallo2,

    Thank you for taking your time to explain to me your concerns, frustrations and experience. I apologize; can you please send me your complete contact information, VIN and current mileage? I look forward to your response.

    Christina
    GM Customer Service
  • Hi,
    I have a 2011 with exact problem. They changed out the two front speakers on left side and the problem remains. 3000 miles. This is really bad. Any word on yours?
  • kynoxkynox Posts: 17
    The dealer heard the noise and replaced the speaker. The noise stopped with the new speaker .Noise came back two weeks ago in the new speaker and car is going back in tomorrow to address.I called customer assistance and they said they had no known problems of this nature reported to them. They did say if a TSB has been issue the dealer would have that info. I will post if I find anything out. A few posts on GMInsidernews.com shows there are a few with the problem but has no remedy posted.Good luck with yours.
  • I have a 2010 and had the speaker problem. Crackling on the left side and sound going off randomly. They never could figure out what the problem was, replaced channel and left speakers. The last thing they did was take everything apart to see if they could find anything and they couldn't. After that, the problem was gone and now if has not happened again and it has been quite awhile. All I can think is that the wires were screwed up somehow and when they took everything apart, it fixed them.
  • Thanks for your response, the dealer is working on the car as we speak, the engine has come back to the shop and they'll be putting it back into the car - under warrenty but really, the issue started at 20,000km and I'm now at 65,000km - the dealership knows this, weather GM acknowledges this is their issue - that's my issue, their ignoring the fact that I've been working with the dealer on my time for months, for a brand new car?. I've let them try to resolve the issue which I believe was a defect. I will take your advice and check my oil level 100% for sure going forward to ensure the issue was correct, so what do you think is normal burn? Honestly, I would never think that this would be something I should check, no one I've told this issue to has ever had a car that burned to much oil within the 5000km between oil changes? Please keep the advise coming cause my lemon's unfortunatly paid off so I'm suck with my junk :(
  • I have sent you a message at your request, welcome to my pain :(
  • Do you know that they upset me so much I asked to speak to a supervisor, while at work balling in my bathroom(I'm so senetive - side issue) and was told they won't do anything for you, I don't know what you want - Um, to be treated like I just purchased a product that I'm not happy with, talk to me like your listening, acknowledge the issues, acknowledge if it's happened in the past with the same line/shift - but I got nothing. As a consumer, honesty - I'm shocked at the service you get, like if I knew they were gonna treat me like dirt, why spend money on a car, buy used? They still come with warrenties, and it's like I paid to do all that extra service to get more life outta my lemon(I now refer to it as a $30,000 lemon). Like, I'm stuck with a car that the manufactor doesn't care, and now by involving GM - how do you think the dealer is gonna treat me, like honestly - welcome to my hell on earth!! I was so happy with this purchase and now it sickens me thinking about going into the shop and having to ask the service manager why I would have to pay extra for a censer for the oil light to come on - like again, I'm doing all of the work and getting no where.
  • I know right, but what could I do - this guy went from explain that the light would only come on if the car touched it's 2L reserve but when I told him that when I took it in and said the car was shaking - they told me I was runnin on empty basically, and when I said the light never came on they bruched it off - maybe cause they knoew I never paid for the extra feature? I'm stuck and can only hope that the car is fixed and I get a decent life out of it but I tell you - I will use my car to advertise my problem if I have to cause they didn't want to listem so as long as my story can be heard - I will continue to tell it and provide updates to others.

    Still, not sure why allowing them to try and provide more ansers cause I believe in playing fair so the ball is now back in GM's court - my dealer, I had a good relationship but the CSR from GM I was working with who was talking to my dealer lord only knows what damaged he's done cause if they talk to me the way they did - can you imagine how they talk to the dealers selling their car.

    I feel like I'm stuck in the middle - the dealer believes I had a right to ask for the new engine because they've actually been dealing with me for months but you get GM involved and it becomes a it's the dealers problem, it's GM - and somewhere, they forgot all about the poor consumer who been nothing but patience until she finally held up her hand only to get rejected at any claims that the car was defective?
  • It was the GM rep who told me the censer was extra - cause I said when I start the car the light it their, I see it - but then I was told - ys, you need to pay extra for the censer. They should have the call recorded cause I started crying the second time I talked to them so I would imagine they must have a policy when the customer are that upset they should record the calls wish I did though.
  • Thanks, Yes my dealer replaced my speakes noise back next day. I am going to make another appt as well. I have found many having this same issue. Kind of funny they say that its not a big issue, but yet a TSB is out. I will also update you ASAP. thanks
  • Looking forward to hearing how your next appointment goes.

    Best,
    Sarah
    GM Customer Service
  • Great to hear that the speaker issue was finally resolved for you!

    Sarah
    GM Customer Service
  • ray80ray80 Posts: 1,239
    edited November 2011
    Good to hear they are getting it back together for you. I see you are talking KM's and Liters so I assume you are not in the states so excuse me if I mess up on the conversion. Its would be very difficult to determine 'normal' oil usage as it can vary quite a bit from one vehicle to another, its better to think of 'acceptable' usage.
    GM used to state a quart of oil every 1000 miles was acceptable (although this would generate quite a few complaints from owners), I think that would be roughly a liter every 2000KM.
    Engines should be better then that now.
    Once you do get it back I think I would be checking the level every 1000KM for a while and add (plus write down) oil as needed. Hopefully it will be a lot better for you.
  • kynoxkynox Posts: 17
    Hi.. My Nox when in yesterday for the speaker noise. When I first took in the Nox for the speaker the dealer told me then that he wasn`t sure if it wasn`t a vibration from somewhere resonating thru the speaker. Yesterday as they were digging around trying to find the noise they found a place inside the door right behind the speaker where the safety bar did not look like it was insulated against the door skin as it should be. The safety bar has foam in between it and the door skin in spots along the bar. Behind the speaker he found that the foam had run down the inside of the door at that spot as if it would look if you came to the end of a tube of foam (runny). So they put in insulation at that spot. He assured me that he did not know if that would fix the problem or not. To bring it back in if it continued.
    My Nox has had this problem and a problem with a power window motor since I have had it. I now have 22,000 miles on it and it gets 30 mpg on the interstate and 22-24 around where I live. I use Shell gas exclusively and conventional motor oil I have changed every 3000 miles.
    I have read some of the horror stories about some dealers on here. I have to say the dealer I take my vehicle to make my experience nothing less than great. They listen, make no excuses and honestly try to correct the problem. Those of you that can`t say that keep looking . There are good ones out there.
  • I recently bought a 2010 equinox, I've had it for less than a month and am taking it in to be serviced for the fifth time. The fuel pump has been replaced three times (to "fix" random acceleration after the vehicle was turned off), the window regulator in the rear driver side window is going in to be fixed for the third time on Monday, and the thing still runs like a farm tractor. I bring the engine noise to the attention of the dealer and get told it's normal, but when I have them bring up a new Equinox and run them side-by-side they sound like completely different vehicles. I've sent GM an email today, if they don't fix the fact I paid $25,000 for a product that is clearly defective, I'm filing a claim with the CAMVAP. I suggest that everyone having similar issues look into your state/provincial/federal "lemon laws" and start making GM pay for their disloyalty to their customers.
  • dmathews3dmathews3 Posts: 1,739
    Sounds more like a worthless dealer to me. Is there another dealer near you could try? I guess I'm lucky as there are about 8 dealers within about 20 miles of where I live but so far after a year only one small problem and I haven't taken it in for it yet. Got to wait for cold weather. It seems my radio locks up first thing after starting if weather is real cold like 10 degrees or so. does it a couple seconds after start and I shut down. open the door to cut power to radio and restart and all is well till next start, days, or who knows how long.
  • i have the answer, my 2010 started running like crap around 12000 miles.. i was on a trip when i slowed to stop at a light and the thing started bucking and sputtering, it stalled and i got onstar on the phone.. they ran a diagnostic and it came back as the fuel trim being rich and they recommended i use a fuel treatment and that if the problem persisted to take it to the dealer .. it didnt persist.. jump ahead a couple months, my check engine light came on and went off, came on again.. i called onstar and they ran a diagnosdtic which came back with an engine code of p0172 which is, fuel trim is rich... i am at 33000 miles on my nox and over the past couple months have been battling the engine light .. every time i called the dealer they told me the problem was probably dirty gas or something else so give it a fuel treatment and it should fix itself.. i did this and it worked.. well guess what, if you have this problem and you are getting crap mileage, car exhaust smells like a 72 pinto and your idle is rough, check your oil, does it smell like gas? if so it is your high pressure fuel pump malfunctioning..it is over pressureized and is basically flooding your engine.. the excess gas is going into your crankcase and disslolving your oil..... i took mine into the dealer and insisted that they find the problem.. they couldnt.. i searched on line for technical service bulletins pertaining to the 10 NOX and i found out that a TSB has been posted for the high pressure fuel pump being faulty in some !)'s .. i took my car back and cornered the repair tech.. i told him that we need to stop F**** around and fix the problem.. it old him that i had found a service bulletin online and he seemed completely surprised and after 20 minutes they told me i would have to schedule an appointment to have my high pressure fuel pump replaced because it was faulty..had the work done on tuesday the 15th of november and i got 27.5 MPG as my average MPG after driving 400 miles..
  • Way to much drama..You really need to focus and communicate the mechanical issues with this 2010 SUV!!!
  • On two occasions upon starting, I get engine noise that sounds like low or no oil. It clatters loudly for about 2 seconds then it is fine. This generally occurs after the vehicle has been sitting for 24 hours or longer. From past experience with other cars it sounds like all the oil has drained from the engine and it is replenished during those first 2 seconds. At any rate, I doubt this should be happening. I have the 2010 I-4.
    Anyone else notice this?
  • My 2010 nox dose th same thing; has never been an issue for me....This is normal for this 4 cyl engines when first started; there is never any oil pressure till the engine is running in any engine. I'm surprsed someone from edmonds did not fully explain this non-issue matter for you.
  • I'm well aware that oil pressure is created by a running engine, but this is the first vehicle (of many) I have owned that routinely does this.
    The noise is similar to what occurs when a vehicle is started immediately after an oil change.
    If indeed this is a nonissue as you say, then GM apparently found a way to prevent engine damage during those 2 seconds of clatter.
    Be happy to hear an explanation from Edmunds as you noted.
  • Why do you assume the specific sounds / noise during engine start up is causing internial damage? These raspy 4 bangers are known for not being very quite; you can't compare this engine to a V6 or inline 6 Cyl....If the car is running well and getting better that average MPG enjoy it...You have 100K warranty for drive line issues. I'm approaching 40k on my 4 cyl Nox and no real issues that have me concerned to date. I'm concidering buying new one in the near futrure.
  • The reason I suspect damage may be occuring is because what I'm hearing is an engine running without oil for a few seconds. It is important to note that this only occurs when the Nox has been sitting for over ~24 hours. Normal operation where it is started and stopped several times in a day is not a problem. I would not give it a second thought if it rarely happened, but it happens often. I'm not confusing this sound
    with the normal raspy 4 banger sound.
    I'm not complaining about the overall Equinox experience, just what I suspect is a future problem in the making.
  • Michaelrussell,

    I see you've already contacted GM. Looking forward to hearing how things go.
    Best,
    Sarah
    GM Customer Service
  • Nox2010,

    Looks like things are taken care of. If you need any help from Customer Assistance, please email us more information.

    Best,
    Sarah
    GM Customer Service
Sign In or Register to comment.