Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2010 Chevy Equinox Problems

1383941434478

Comments

  • If you can bring your equinox back and get another vehicle DO IT! I drove my equinox 2000 miles since I bought it in feb 2011... Been in the shop otherwise ...worse car I have ever seen. Best of luck to you :lemon:
  • I have a 2010 NOX with 50M and really wish I wasn't writing because I like the car. I am 6'6" and fit well in front or BACK seat! Also the service manager Bob at Novato, CA Chevy is a great and helpful guy.
    My troubles started almost immediately. At 10M it was sounding like the engine was going to blow. When I got to the dealer I was almost out of oil after only had 5 or 6M on the change. I have been using about a qt every 1100 or so miles mostly ever since. My lumber has broken twice and was fixed both times even though the 2nd time was after 36M. My steering box had the sticky problem and was fixed only because the service manager Bob drove the car home, about an hour commute to recreate the problem. That problem has now come back after 4M! I have always had the rough start with high RPM (1200) any time the car sits for several hours even in warm weather. As I read the posts it seems that this could be related to my oil consumption problem and the high pressure fuel pump failing and leaking fuel into oil. Funny because the dealership said my problem was fuel contamination and switch gas stations! It is inconvenient for me to go to a dealership out of town to continue to have my oil checked. I don't understand why they don't check plugs and see what's up?
    I also complained about the fact that I was loading the back and my knee went though the deck! Twice! It is just thin plastic and was not covered, cheap.
    I would be much angrier if the service manager wasn’t so dedicated to making me happy. I am sorry he has such an uphill task.
  • nailsgirlnailsgirl Posts: 13
    Had fuel pump replaced last month, 63K. Yesterday, engine started ticking, checked oil, no oil on dip stick. The oil was changed Feb 14. Dealer said probably needs new engine! Got a rental, will hear final analysis next week.
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    I'm sorry I didn't see your post sooner, jpol4!

    In the time since your post, have you been able to find a solution to the stalling condition you described? Don't hesitate to get in touch with us (socialmedia@gm.com) if you would like for us to pursue this further with you (please include your name/Edmunds username, phone and address, the last 8 of your VIN and current mileage, the name of your dealer and a description of the visits you have made).

    Best,
    Sarah
    GM Customer Service
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    I'm sorry I didn't check in sooner, jec10. Sometimes the tool we use to catch posts on the different social media sites we work on doesn't catch everything.

    It looks as though you've had your vehicle back for over a week - how has everything been running?

    Sarah
    GM Customer Service
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    Have you ever contacted the Customer Assistance Center, starsmyles? Do you have any cases open with them (71-**********)? If we can get one going for you, let us know!
    Sarah
    GM Customer Service
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    raynman10,

    I'm sorry that you have encountered so many difficulties with your Equinox. Have you worked with Customer Assistance already? We can get a case going for you if you haven't. Let us know!

    Sarah
    GM Customer Service
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    Looking forward to hearing more about what the dealership finds on your Equinox, nailsgirl. If we can be of any assistance in the meantime, please contact us at socialmedia@gm.com.

    Sarah
    GM Customer Service
  • Hi Sarah
    No, I have not. Only with Bob at Novato Chevy. I am taking it back again Monday for the two issues described above: oil consumption at about 1 qt every 12oo miles and the steering is sticking again during long highway drives. I really like the car, roomy front and back, great MPG but the troubles are mounting up. I am 63 and have never had an experience like this. What is the difference with a case vs using the dealership?
    Ray
  • kwnoxcakwnoxca Posts: 8
    I've also got the sticky steering feeling. Here is the "INCREDIBLE EXPLANATION" from the GM mechanic:
    "It is absolutely possible that you are experiencing a condition which is normal to the Electric Powersteering system (EPS). The sensation and experience is much different in ways then old conventional Hydraulic systems."
    I am suprised that I have driven this car under the abnormal condition for 2 yrs, and just recently felt the "normal" sticky steering. My car only has 20K and is mostly used for carrying my 2yr old daughter. I would think it is a potential risk of safety.
    Does anyone here have luck in fixing this issue? SERIOUSLY :confuse:
  • rski43rski43 Posts: 13
    The oil consumption problems all seem to be on the 2.4 4 cyl, does anyone know if the 3.0 v-6 direct injection engine has similar issues?

    I use a quart every 1200 or so w/ present 2010 2.4.
  • carguy05carguy05 Posts: 30
    Does not sound normal to me. I have a 2010 4cyl Nox 42,000 miles and only use 1 quart every 2500/3000 miles.
  • smc8888smc8888 Posts: 25
    GM has already acknowledge this problem by publishing a technical bulletin (I don't know the number), the cause of this was in the gear box, ask them to replace the gear box and the problem will go away (my GM dealer fixed mine). You need to publish the name of your dealership to expose utmost incompetence, or they simply don't give a damn for customers once a vehicle is sold?
  • Sadly, it looks like this is a common story. My 2010 Equinox was purchased new. I have a long commute and was attracted by the gas mileage. I now have 91K miles on it

    Since buying my car, I am on my 3rd fuel pump, 2nd timing chain and now, due to it overheating for no apparent reason last week, I'm getting a new engine. The thing sounded worse than an old school diesel. The first time my fuel pump went, I had to fight to get it covered. They let me off with just paying $50. Second time they covered it completely- because it was within 12 months of the first one going. This time everythign is covered under powertrain.

    The best part this time- the only thing the dealership has for me to drive is a giant minivan with 250K miles on it. Last time it was a Jeep Liberty that was clearly used for food runs by the service staff- evidenced by the amount of fast food wrappers my husband cleaned out of it.

    And before anyone asks- yes, I've talked to the wonderful folks at Chevy Customer Care. I get a call about every other day. We never seem to reach each other though- just play a lot of phone tag. I am beyond done with this car. We were looking at buying a Chevy Cruze, but I think I will test drive the Ford Focus for good measure.
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    Hello Ray,

    I am truly sorry that I didn't respond to your post sooner! Sometimes the tool we rely on to catch posts across the different forums we monitor doesn't catch everything. I hope your appointment yesterday went well -- do you care to share any details?

    A case with us would allow us to follow up with you to make sure you were satisfied, and to then take action to see if there are any other avenues we could explore if you weren't.

    All the best,
    Sarah
    GM Customer Service
  • esperinosesperinos Posts: 18
    I still have one 2010 and one Chevy Cruze, and so far no major problems, but recently got rid of my other 2010 Equinox because I really couldn't depend on it
    Being reliable after 2 major engine problems in a month. And, no, I didn't buy another Chevy or GM product.
  • UPDATE!!!!
    Thanks to Bob Spomer, service mgr at Novato Chevy I am getting a new engine and new steering box in my NOX! This sure beats having to buy another car. In fact we ordered a Volt for my wife today after we received the news. It feels good to buy from a US company and have them stand behind the product.
  • dmathews3dmathews3 Posts: 1,739
    You must have the same tool they use at the end of line to catch problems. Looks like neither works very well.
  • jpfjpf Posts: 496
    I believe the 3.0L V6 is based on GM's 3.6L V6 that was originally used in Cadillacs and is now found in many vehicles throughout GM's lineup. The 3.6L engine has a history of timing belt problems and oil consumption, usually at about 50k miles.
  • rski43rski43 Posts: 13
    JPF> The LFW 3.0L V-6 has timing chains, not belts. You may be thinking of another 3.0L from GM ??
  • 79corvette79corvette Posts: 1
    edited April 2012
    I have a 2010 Nox. Most of the problems I am having sound like everyone else. Had my POS in for oil consumption, engine noise (sounded like a diesel), poor fuel economy & poor shifting, the dealer to date has fixed NONE of the above except for the engine noise. They changed out some engine control thing for timing and replaced main bearings and connecting rod bearings at the same time. the rest of the problems are "acceptable" to GM. Yea? Well it's not acceptable to me. So with over 90,000 kms, I began to get the sticking steering. Went to the dealer, wanted to charge me over $700 to look over the POS. Meanwhile, all this stuff was recorded and attempted to be fixed before the Warranty ran out. GM customer care did NOTHING!, so I sent an email directly to the President of GM Canada. Next morning I got a call back from his assistant who said to take it back to the dealer, and they'd look after it.
    Soooooo. They fixed the steering by replacing the steering gear. Hope it's a perm fix, but not too optimistic. The rest of the things, still no solution. The dealer said they changed something on the cam, some solenoid and it should improve, so far, the range I normally get from a tank of fuel is unchanged. I don't think they have even opened the damn hood, they looked for leaks to explain the oil consumption and when I specifically explained that the sticking steering only becomes evident on long drives of more than an hour under highway conditions, the dealer came back and told GM Corp. that they could not reproduce the problem after a 15 minute drive in the city. Duh! Hello? are you hearing impaired?
    Will be speaking next week with Presidents assistant and have found evidence on this forum to explain the oil consumption. Apparently it's a problem with the gear box. Some GM bulletin somewhere says so.
    This is such a waste of time for each of us. This is BY FAR the worst experience and vehicle I have ever owned.
    Message to GM: You folks better tighten your financial belts, cause according to everything I am hearing about these sub-standard vehicles and the lack of concern for customer retention, you'll be back at the governments doorsteps looking for another handout. This time, I hope you all go down with your corporate ship. When I am in a position to get rid of my POS, i'll be going back to the imports. Their engineering standards are clearly much higher.
    Scott MacDonald
    Pissed Off Owner!
  • Still no vehicle back from the dealership. They put the new engine in, but it wouldn't start. Uhhh, problem? Evidently they needed different cams (some obscure technical bulletin they found somewhere). So now we had to wait on those. At this point, I really don't care. They finally gave me a loaner vehicle so I told them to take their time. I'm really hoping it's right this time. Chevy Customer Care called- they were under the impression I had my car back and seemed surprised when I told them it was still at the dealership with issues. I'm trying to figure out the purpose of Chevy Customer Care. They just seem to be a middle man and I tend to have more info than they do.
    Meanwhile, I'll be test driving a Focus and Prius this weekend...
  • ajmcajmc Posts: 3
    2010 Equinox... heater just blowing cold air, then message center says engine over heating, no ac, idle engine, had towed to GM dealer ...worked on for several hours , tried new thermostat, still same problem....dealer no idea of cause ???? still looking .....any ideas out there ??? Thanks
  • nailsgirlnailsgirl Posts: 13
    Had the same problem, dealer put a new water pump on. One month later it sounded like a diesel engine....now it is in the shop getting a new engine! Check your oil. I had no oil on the dip stik, and no warning lights, 66K miles. Tell the dealer that there is a lot of info on the web about these problems. They are covered under your warranty. good luck
  • nailsgirlnailsgirl Posts: 13
    Same prob with my Nox. Dealer is replacing the engine. 66 K miles. They gave me a brand new Buick Regal to use. It has been 1 week, still haven't heard from dealer! How is your Nox?
  • That's exactly what mine was doing. I couldn't even limp it home- had to trailer it. after being in the shop for almost 2 weeks, I just got it back yesterday with a new engine. Sounds great now, but I'm worried how long this will last.
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    Has there been any progress since your last post, ajmc?

    Best,
    Sarah
    GM Customer Service
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    What great news, and congratulations on your new Volt!
    Many happy miles!
    Sarah
    GM Customer Service
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    nailsgirl,

    Have you heard anything yet?

    If we can give your dealership a call to find out more about the progress, please email us at socialmedia@gm.com with the following information: your name/Edmunds username, phone and address, the last 8 of your VIN and current mileage, and the name of your involved dealership.

    All the best,
    Sarah
    GM Customer Service
  • 58mga58mga Posts: 8
    My Story..64000 km...Lumbar screws broke...fixed.
    126610 km-ABS/Stabilitrac light on....Replaced Front Wheel Bearing and Hub....not covered under warranty.
    140000 km ?? Timing Chain, Balance Shaft Chain and Water Pump....covered under warranty
    152441 km-Complained of Excessive Oil Consumption...Consumption Report opened
    152441 km-Replaced Left Front Sway Bar Link...not covered under warranty
    155618 km-CEL light on constantly....Catalytic converter replaced.....covered under Dealer goodwill warranty. CEL still on after.....Charcoal canister to be replaced...not covered under warranty.
    165222 km...Replaced left wheel Bearing...not covered under warranty
    177731 km...seat cover has come loose from original lumbar repair..fixed
    177731 Km...Manual shift button does not work....Broken wires from Switch.....Not repaired, not covered under warranty, $ 700 Approx to repair.
    178990 km...Dealer confirms oil consumption, will need to tear down engine and rebuild. All covered under warranty. 3 Weeks to do rebuild. Called to pick up, hour later called not to pick up. Engine making noise under load. Spun bearing damaged crank....another week.....

    From the Work Order:
    ""Poor Retention on Piston Rings allowing oil into combustion chamber and burn oil. Found large amounts of coking on all valves, large amount of Carbon build up on piston and rings""

    187000 km.....Right front Wheel bearing and Hub.......not covered under warranty

    189000 km CEL flashes.......misfire # 2 cylinder...could be coil, could be a fowled spark plug ( 4 new spark plugs were not included in the engine rebuild ) Replace spark plug...$175 done

    189950 km...CEL flashes.......to be continued..........

    I will say thanks for the forum as it is what I used to convince my dealer to take me seriously about the oil consumption.

    This is my first and will be my last GM product......my old solara still ticking at 450000 +
Sign In or Register to comment.