Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2010 Chevy Equinox Problems

1444547495078

Comments

  • nana04nana04 Posts: 1
    took mine in a couple months ago with noise and rough running, hesitaiton. they replaced the timing chain and the high pressure fuel pump. took it back in yesterday with similar symptoms and also talked about oil consumption and decreased gas mileage.....two men looked at each other and said 'zebra striping' apparently chevy has decided to replace the engines on these cars that are affected rather than fixing one thing after another. its a manufacturer defect involving the cylinder walls and the oil......if your dealer doesn't want to fix it call another.....
  • I don't have to worry anymore about them not listening to me. The issue got so bad that last Friday (after only having my car back from the shop 3 full days after them replacing the timing chain for the 2nd time) I blew a bearing in the engine and it is toast (metal shavings in the oil, crazy metal-on-metal squealing noise). They have no choice but to replace it now. I have a rental now and it will be a few weeks they said before I get it back. It is still sitting outside the shop in the parking lot (I drive by on my way to work everyday). I even sent them the service bulletin and he said that I didn't have those issues (however they never scoped the engine to look at the cylinders). I would LOVE to have a look at it when it is out of my car.
  • klm56klm56 Posts: 15
    Ask to look at the cylinder walls...the service bulletin we have a copy of had a picture of the zebra-striping. Looks like lines on the walls. We were able to look into our engine's cylinders. But the good thing is...you are getting a new engine...hopefully one of the new kind of ones with no problems????

    BTW, ours took about 1.5 weeks to be fixed.
  • salacompacsalacompac Posts: 1
    edited August 2012
    Hey I was having the same issue with my Equinox 2010 29260 miles and what I did is remove the Ground cable from the Battery for 5 minutes and that solve my problem i put it back and now is working perfect well after 2 day I did not have any problem. if you need any help please send me a e-mail.

    Regards
  • dnydny Posts: 8
    Thanks, but the hub sensor assemblies were falling apart so no choice in the matter but to replace the hubs. Fortunately after complaining to GM, I managed to get them to cover most of the repair costs even though they don't normally cover the hubs under the power train warranty.
  • klm56klm56 Posts: 15
    We were using too much oil but I believe we did get some code early on before the oil usage was too much.
  • I've had a 2011 equinox 2LT with the 4 cyl engine and have had 29,000 trouble free miles on the vehicle. It"s one of the best vehicles I have ever owned and I like it so much that I just ordered a 2013 LTZ with the new V6. I also have a 2011 Chevy Cruze that has 17,000 trouble free miles and I really like the vehicle a lot. Great cars from Chevy.
  • Congrats that your 2011 is problem free. Us 2010 owners are the ones who got screwed.
  • smc8888smc8888 Posts: 25
    I'm glad for your good experience. I had engine oil consumption problem for sometime and started an oil consumption test with my dealership around June, after that I noticed that the oil level stopped going down and I smelled strong gasoline odor in the oil. I took it to the dealership and they claim that it was caused by failed fuel injection pump and replace it, together with few other things. I took my car back to dealer two days ago because I still smell gasoline in oil, they claim it is normal and checked the oil level and add 3/4 quarts to top-off the level!! While looking at the service person adding oil, I commented that I had a lot of problems with this engine, he shook his head and replied "nothing but trouble", I asked him if 2011 and 2012 engines are better and he said they are also very problematic, with other problems. Just to let you know.
  • roho1roho1 Posts: 317
    Speak for yourself, my 2010 has been problem free also. You just don't hear from us since there's nothing to complain about :)
  • roykulproykulp Posts: 52
    WOW...I'm also an early October 2010 owner and to date have no real serious issues to complain or cry about!!! The minor NOX Concerns I experienced have been addressed and resolved by GM Dealer to date. I have owned 8 New cars and 1-12 used cars & trucks over the last 40 years and they all have some sort of issues; this is just how it is! Anyone looking for a trouble free non-issue man built machine should proably walk or engineer their own machine. Have you ever wondered why there are so many service centers, car lifts, warranty companies and technicians...Cars, Trucks, SUV's Etc have issues and need to get repaired and serviced!!!

    So far, I'm pleased with my 2010 Nox 4 cyl. and the local dealer Dimmitt in Clearwater Florida has done a great job with my few concerns and NOX warranty matters.

    Glad I have a 100.000 Mile Drive line warranty in the event its needed!!!!!!!
  • brad5879brad5879 Posts: 12
    edited August 2012
    Update on my wife's:

    Checked the oil level about 2-3 weeks ago and it seemed alright. This was at about 3,000 miles after the previous oil change. Checked it yesterday, 660 miles later and the dipstick was bone dry. I am sorry but I wasn't taking it for an oil change at 3,000 miles since I was told to bring it back when it needed topped off. My buddy has a tow truck so I had him tow it to the dealer today. I have called GM Customer Service and they set up a case #.

    The first time this happened was back in April with 30,360 miles on it - we were told the car was equipped with Mobil 1 oil and the oil life monitor reflected this - but roughly 6,000 miles after we bought it, we were driving and the check engine light came on - checked the dipstick and it was bone dry.

    Took it to the dealer, they put regular oil in it to do the consumption test and we then took it back at 33,180 miles when it was looking a little low and they claimed the oil level was okay - I personally checked it before I took it in and thought it looked a little low, so don't believe them.

    Well yesterday at 36,860 or so miles, the dipstick is dry. 3,600 miles after the oil change. This is ridiculous - 5 months of aggravation and constantly worrying about oil level. I got a 2010 Camaro and I never have to worry about checking the oil level because it never drops this drastically. We traded in my wife's 2002 Honda CR-V with 152,000 miles on it because we wanted something new - for goodness sakes we NEVER had to deal with these problems. The 2002 Honda ran and sounded newer than this car between 30,000 and 36,000 miles. I should have known when I bought it at about 24,000 miles and I mentioned that it sounded like a diesel and the salesman blew it off as normal.

    I will update tomorrow after the dealer looks at it and Customer Service is in touch with them. I am really hoping for the best right now. This car has been such a headache and a bad as I want to say good things about GM and Chevy, there isn't much to say right now with the way they've handled this issue and not stood behind their product. I know the car probably needs a new engine and I'm pretty sure they probably know, too - why is it such a battle? I'm hoping they finally make this right with a lifelong loyal customer. It took all I had to convert my wife from Honda and now I'm looking like an idiot.
  • stephcpstephcp Posts: 9
    Good Luck! We traded ours due to that constant worry of whether the engine was going to lock up on us or not because of it burning oil.
  • roykulproykulp Posts: 52
    I would like to hear about all your 2010 Nox Issues; other than the oil consumption issue. I'm also a early 2010 Nox owner 50K miles and curious what type of issues you are having with your Nox; that you are so frustrated with.

    We look forward to hearing about your positive and negative experience with this GM Vehical.
  • Thank you for taking to time to post your positive experience with your Equinox, chevyfan4! Wishing you many more happy miles!

    Sarah
    GM Customer Service
  • brad5879brad5879 Posts: 12
    Update:

    I was just told today that the oil "was a few quarts low" (dipstick was dry) and was given the same song and dance about 1 qt. per 1,000 miles being normal. This is the third freaking time I have had it in the shop. They told me they are going to give me the service bulletin and a chart to fell out every week or so documenting the oil level. The dealer told me this is what they were instructed to do by GM Customer Service. They said by the next oil change they will see what next steps to take and said "I know that's not the answer you want" and let me know that the car was well within the 100,000 mile warranty. The continue to say the diesel sound is normal.

    Don't these people know the internet exists and I can clearly see many people have had the same issues I'm having? When does this ever end? Are they going to give me the same crap next time? Fix the problem. This is the third damn time and it's going to take a 4th???? I was told the first time it would be 3 rounds - and now they're adding an extra round? By the time I am ready for my next oil change it will be around the year anniversary that I've purchased the car. Ownership of this vehicle has been such a nightmare and such high maintenance - now I am going to have to worry about checking the oil every week? My gosh it's a 2010 model. I bought this car because I wanted something new, not something that feels 25 years old.

    I was expecting a little more now that GM Customer Service is now involved. Instead I have to ride this problem out for another 3 months or so? I just want a real answer already. A real solution.
  • I'm glad to hear that you've begun the oil consumption test with your dealership, smc8888. I hope that we're able to work out a resolution on this with you! Please keep us posted, and we're here to look into anything if you need us.

    Sarah, GM Customer Service
  • gmcustsvcgmcustsvc Posts: 4,134
    brad5879,
    Thank you for taking the time to post your concerns. Please feel free to email me directly with your case number and I will look into it. If you have any questions comments or concerns, I am always just a post or email away. I look forward to updates on your concerns and experience at the dealer.
    Christina
    GM Customer Service
  • brad5879brad5879 Posts: 12
    edited August 2012
    Thanks Christina, email sent.

    Just received a phone call from the person assigned to this case.

    I was under the impression from the dealer that they had spoken with GM Customer Service from their wording, but there was a misunderstanding.

    I just picked up the car and got paperwork showing the guidelines that state the "accepted rate of oil consumption or engines used in the referenced vehicles is 1 qt in 2,000 miles. (Document ID 2714857). They claimed they added only 1 Qt. The dipstick was bone dry after sitting for several hours so I really don't know if I believe all it took was 1 Qt. to fill it.

    It's just amazing that it's accepted that this car would lose 2 quarts of oil, or 40% of the oil in the crankcase, over a 4,000 mile stretch - under NORMAL driving conditions to boot! My 2010 Camaro hardly loses a half quart of synthetic oil over 7,500 miles.

    And the reply to me stating the engine is loud was "road test operating as designed". So this was designed to sound like diesel engine? It sounds horrible. I am not shocked these are the answers I am getting though - I see the same stuff all over this forum.

    And the real question is, why did it take the 3rd time taking the car to the dealer to give me an Oil Economy Test Data Sheet to fill out? Shouldn't they have done this all the way back in April when I first took it in with a dry dipstick??? Or in June??? They wait until the third time.

    I appreciated GM Customer Service taking the steps to get to the bottom of this. It's not some minor problem I'm scheming up. Believe me, I don't want any problems with my car. I can proudly say my Camaro has been very easy to maintain through 62,000 miles.
  • We're glad to hear that you're having such a great experience with your Equinox, roykulp! Wishing you many more happy miles!
    Sarah, GM Customer Service
  • I bought my 2010 equinox brand new in august 2010 and have had nothing but issues. BIGGEST issue has been with the engine and brakes. After multiple visits to the dealership most of the problems have been fixed but now there are a few new ones. I went from driving a Honda with no problems to a car that I don’t trust to take on a long road trip because I don’t feel safe and I LIVE at the dealership. At this point, I wouldn’t know how the car should run because I have had nothing but issues. Has anyone else had issues with the rear brake pads and rotors? They replaced them and then put some kind of adhesive on them because it was still doing the moaning noise when you would let off the brake but not hit the gas. See below for engine/diesel sound.

    1)(parking Brake) First time it went in the shop was approx 1,500 miles because you could hear something hitting under the car. As always they said they couldn’t duplicate the problem (it had been going on since the day I bought it). I took it back at 2,631 miles and they determined that the parking brake cable was loose and hitting under the car. Back to the shop at 2,927 miles because of the same exact issue and was told that the parking brake shoe was deformed and parking brake cable spring had excessive clearance. They had to order the parts and I had to bring it back in to be fixed. (4 trips to the dealer for the same exact problem)

    2)(Wipers) The wipers have always skipped across the windshield and is hard to see out the passenger side of the windshield. Dealership inspected , cleaned wipes and said everything was normal. 7,378 wipers were replaced and then again at 16,000. Replaced again at 25,000 miles and was told by the service manager that the part has changed and that it should fix the problem.

    3)(Headliner) 8,653 miles Entire headliner in the car was sagging. Dealership inspected and found that the magnets on the headliner had detached due to insufficant adhesive. Had to order parts and bring car back for fix.

    4)HUGE PROBLEM (Engine ticking) This is something I have been battling. The car sounded like a 1982 diesel car. The idle was really ruff and at times would drop down so far that it felt like it was going to die. Ive almost rear ended cars in stopped traffic because I would have to hit the gas to keep the car alive. The first time I took it to the dealer for the engine ticking and idle very rough was at 8,653 miles. I was then told that the problem was told that the problem was with the High press fuel pump. They replaced the fuel pump and lines. This didn’t help anything. Every time I would take it to the dealership for maintanice I would tell them about it. I was once told that this is normal for a 4cyl. Finally at 25,621 miles it was determined that the issue was with the timing chain and tensioner. After 16 days in the shop and work complete I got my car back and it now seems to have transmission issues….

    5)(outside temp Gauge) Would stick on one temp and never change. They verified and replaced part. 16,000 miles

    6)(Rear Brakes) reported at 25,000 because it was a moan that would happen when you would let off the brake but not hit the gas. It was a high pitch noise that could be heard inside the car. I even stopped at the dealership and had the service manager drive with me so he could hear it. We didn’t even have to get out of the dealership and he told me that it was the rotators and it was completely normal. That made me feel really unsafe to hear its your brakes but its normal. It went in the shop and I received a voicemail for the service manger that they had to replace the pads and rotors. Really at 25,000 miles? That actually didn’t fix the problem so they said that they had to coat the back of the brakes with some kind of noise reduction adhesive. Now when I brake it feels like the car is skipping… Doesn’t feel so good.

    7)Front speakers- 23,000 miles there was an internal failure
  • My wife and I bought a used 2010 Equinox 40k on the odometer. The vehicle is pinging sometimes just at pulling away from say a stop sign. Dealer (who lost his Chevy franchise) said they all do it and according to him unless the CHECK ENGINE light comes on nothing can be adjusted or checked.
    Oil consumption seems ok so far. Time to check with the local independent garage. All of the posts on this whole subject are pretty scary.
    Is this the son of the QUAD 4?
  • Use 91 or 93 octane and the pinging should go away, as well as the fuel pump ticking (can notice at a stop light with radio off). I think there is a computer update you can get that will allow you to use 87 octane without the pinging, but you lose 1-2 mpg. They just have the timing on the spark wrong on many of the 2010s. The cost per mile is about the same with or without the new update, so I just use higher octane since it gives better performance.
  • Good morning erinmarie94523,

    We're very sorry to hear about the concerns you've encountered with your Equinox. I see that your current, unresolved concerns include the transmission, yes? If you would like for us to look into the situation further with you, please email the following information to us at socialmedia@gm.com: your name and Edmunds username, phone and address, the last 8 of your VIN and current mileage, and the name of your dealership.

    Sarah, GM Customer Service
  • Good morning jdfrmcrssprgs,

    We're sorry to hear that you're having this pinging concern with your Equinox. I see that wallyuwl made a suggestion about fuel - if you wanted more information on that check out 8-54 in your manual. Also, it looks as though the dealership you're working with is no longer a GM dealership, is this correct? Let us know if you need any assistance in locating one of our dealerships nearby or if we can look into anything for you! Our email is socialmedia@gm.com

    Sarah, GM Customer Service
  • GM replaced my engine @ 66K. My 2010 Nox also sounded like a diesel. Continue to check your oil. I had none on the dip stick after a 3 week oil change! Runs well now but I only get 26.5 mpg!I got 32 with the old engine. I haven't gone back to the dealer.....I will prob get rid of it soon!
  • Dealer continues to say diesel sound is normal.

    Completely forgot about the sagging headliner because of other major issues at hand. But yeah, they said that was normal as well.

    I have a feeling that if I was out of warranty none of these things would be "normal" and instead would be expensive costs absorbed by myself.
  • cbfcbf Posts: 1
    For roughly the first 60,000 miles, I didn't have any real problems with my 2010 Equinox - or so I thought. Friends had told me that my car sounded rough or was too loud, but when I asked the maintainers at the dealerships, I was told it was normal. At roughly 60,000 miles, I had a new fuel pump installed after my vehicle stalled at a stop light. For a little while it ran fine; however, it still sounded rough and I was still told it was normal. At about 74,000 miles my check engine light came on and within ten miles my vehicle lost engine power and turned off - while I was on the road driving. The dealership found that my vehicle was 4 quarts low on oil and replaced the fuel pump, timing chain, tensioners, etc. After all this work, the vehicle was quiet for a day or so, but then started the ticking sound - which it has done since the beginning. At 75,000 miles my ABS light and StabiTrack light came on, so I returned to the dealership. I'm awaiting an update on the current issues; however, I've had GM vehicles in the past and never had so many problems as I have with this one - and those vehicles had double the mileage! I'm not really a "car person" - although I'm getting a crash course now - any helpful hints/advice/suggestions on what I should ask the dealership?
    Thanks!
  • jpfjpf Posts: 496
    With that mileage, I would trade it in before something else goes wrong. After it's fixed, look for a more reliable vehicle. Good luck.
  • Good morning cbf,

    If you would like for us to check in on the progress at the dealership on the repairs to your Equinox, we'd be happy to get a Service Request set up to do so. Please email us the following information at socialmedia@gm.com: your name and Edmunds username, phone and address, the last 8 of your VIN and current mileage, and the name of your dealership.

    Sarah, GM Customer Service
Sign In or Register to comment.