Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2010 Chevy Equinox Problems

19293959798116

Comments

  • gmcustsvcgmcustsvc Posts: 4,001
    edited April 2013
    Hello dan2330,

    I've read over your post regarding the issues with your 2010 Equinox. If you need any further assistance regarding this issue we are here to help in any way possible. Please keep me updated on the status of your vehicle.

    Amber N.
    GM Customer Care
  • alamo3alamo3 Posts: 3
    The radio and camera on my 2012 Equinox stopped working on two different occasions around 19,000 miles. Both times I continued to my destination without the use of either. Each time after restarting engine, both worked. The service tech at the dealer couldn’t duplicate the problem. He contacted GM. GM said that to fix the problem the radio needed to be reprogrammed with updated software. Both are working now. I’ll be very disappointed if the problem reoccurs. This is the first warranty issue that I’ve had with the Equinox.
  • rebcky27rebcky27 Posts: 3
    Update: I started the oil consumption test with my local GM Dealership 2 weeks ago, directly after discovering the issue. They had me come in every 500 miles to check the oil status. Friday was my second visit, 1,000 miles on a fresh oil change, they were able to confirm my Equinox IS consuming oil (down 1 1/2 quarts). Their solution is to replace parts in my engine, I asked specifically what but the technician wasn't sure, and I will have to pay a $200 deductible to them to perform the repair since I'm over the 100,000 powertrain warranty (105k).

    I'm praying that this will solve my issue and without breaking my bank account!
  • catobearcatobear Posts: 1
    Bought my 2010 4-cyl brand new. At 24,714 miles, the high psi fuel pump was leaking into crankcase. They replaced high psi fuel pump and changed oil. At 36,263 miles, the car died in the middle of an intersection and wouldn't move. The cam actuator solenoid valve was replaced. They noticed it was 2.5 quarts low on oil (and, looking back at past oil changes, it has been low nearly every time). Started the oil consumption test. Took it back at 38,363 miles for the oil consumption test, and they said they were going to replace the entire engine.

    Must give props to Heritage Chevrolet in Battle Creek, Michigan. They scheduled time to drop off my car and gave me a free loaner. I was expecting it would take days to get it back, but they put one mechanic on it and it's ready in 24 hours. Paul, the service manager, is fantastic. He said they have now replaced five engines in my model year at their facility.

    I hope this is the end of my equinox troubles. Every car I've purchased myself has been a GM vehicle; the last two were purchased brand new. I want to stay GM-proud and feel confident with my vehicle's reliability. Please, please let this new engine be everything the original one wasn't!
  • gmcustsvcgmcustsvc Posts: 4,001
    Hi rebcky27,

    Great to hear that you were satisfied with your dealer service visit. If you have any further questions don't hesitate to contact us.

    Amber N.
    GM Customer Care
  • eb1021eb1021 Posts: 2
    edited April 2013
    I got my 2010 Equinox LTZ slightly used in 2011. It has 60,000 miles on it. Now the mechanic tells me the A/C is going out and there's a part on the motor that needs to be replaced at a total cost of $2500. We've been going to them for 20 years so this isn't something they would lie about. We're a military family and we can't afford to sink money into a car that won't be reliable for us. We want to trade it in just to break even but with the problems, we're going to be under water if we try to do that! I will never ever buy a GM made product ever again! Someone needs to let others know that this car is a lemon and we were duped as consumers!! My tax dollars went into bailing this company out and I think others would agree it was clearly a mistake.
  • eb1021eb1021 Posts: 2
    To be more specific, the mechanic said the timing chain and the timing chain compressor are going out. It makes a weird raspy rattle when the car is on. He did mention he doesn't know how much longer it has until it fails completely. Also, the A/C compressor is going bad and he said it won't last until summer. Before I bought this car, we put a lot of research into it because like everyone else, we are on a budget. We were looking to stay with an American car maker that was reliable. I'm extremely disappointed in the quality of the car after only having it for 3 years. Our mechanic says if it were him, he would trade the car in now. He sees it being a potential money pit. And as I stated earlier, being a military family, we don't have that kind of cash to be throwing away on a car that could breakdown at any minute. At this point, even if it were under warranty, they would just fix it and I would be on edge waiting for the next part to break. I've lost faith in GM as a company and I'm leaning towards jumping ship now. On a side note, I posted this whole rant on facebook and 2 other friends have had to trade in their 2010/2011 Equinox! They made a lemon. Period.
  • It's funny that you post this, cause my car is in the shop for the same thing. Not to mention it was just in the shop 2 months ago for a thottle body, which I had to come out of pocket for. This is the 4th trip to the shop for me this year. This is crazy! I went to trade back and they say I owe to muc, NO you guys just don't want it LIKE I DON'T!
  • gmcustsvcgmcustsvc Posts: 4,001
    Hi eb1021,

    I am really sorry to hear of your issue and can understand your frustration. I would like to look into this for you but need a little information from you to do so. Can you private message me your full name, address, phone number, Vehicle Identification number, and approximate mileage on your vehicle please? My email address is socialmedia@gm.com "attn Crystal" in the subject header. I look forward to hearing from you.

    Crystal L - GM Customer Care
  • gmcustsvcgmcustsvc Posts: 4,001
    Hi eb1021,

    I would first like to thank you and your family for your service to our country. I can understand your frustration with unexpected car repairs. I would like to look into this for you. Can you private message me your full name, address, phone number, Vehicle Identification number, dealer your visited, and approximate mileage on your vehicle please? My email is socialmedia@gm.com "attn Crystal" in the subject header. I look forward to hearing from you.

    Sincerely,
    Crystal L. - GM Customer Care
  • genaggenag Posts: 1
    We just bought a 2010 Chevrolet equinox and noticed the little red light to the very right on the Onestar's mirror comes on intermittently. When I asked Onstar what that meant, they said "take it to a dealer". I asked what it could be and they wouldn't answer. I don't want to go to a dealer since they would want to charge me and face it, they all stretch the truth a bit. What could it be?
  • That red LED is letting you know something isn't connecting correctly. This could mean there is a connection error within the mirror or a temporary signal loss.

    If the light does not stay on long enough for you to have an OnDemand Diagnostic pull up any information, you can take the vehicle to your dealership to have them check it out.

    If we check all the settings and determine that the issue might be a physical concern, we refer to the dealership. Our dealerships are our physical counterparts to resolve concerns. We know that customers have varying levels of knowledge and experience involving vehicles and due to liabilities we want trained specialists to work on the vehicle.

    I hope this helps!

    -Jessica, OnStar Advisor
    Social Media Team
  • drummojtdrummojt Posts: 1
    edited April 2013
    I purchased my 2010 equinox LT brand new with 17 miles and during the purchase bought the extended bumper to bumper. I then ONLY took my car to Chevy dealers for ALL work done including maintenance. I thought, by doing everything right, and being very careful with my first new car, all would be good. However, I have also succumbed to the oil consumption issue that I continously read about now online. I noticed first an increasing engine noise with what seemed to be a knocking sound, almost like a diesel engine. At that time, I replaced 3 qts of oil to go back to normal level on the dip stick (about 3500 miles after my oil change = about a qt per 1000mi). That day, I made an appointment at my dealer, Jim Ellis Chevrolet in Atlanta, GA. On my way to the dealer the engine went into limp mode, which required me to be towed. There, I again reiterated why I was there for the oil consumption, and now this engine that failed. I was informed that it was the throttle body sensor and they said they would replace it, but the part was on back order and it could be awhile. They told me they would look into the oil consumption while it was there. Unfortunately, on return for pickup, they stated that they did not change the oil (dip stick at time of my personal additional 3qts had what appeared to be metal shavings/deposits) and that I should drive an additional 2k miles for an oil consumption test. I was obviously unhappy with this plan as it did not make sense to drive with oil that was likely not appropriate. Additionally, the engine was never inspected as promised. Two weeks ago, I noted the sound of my engine started to increase again and with checking my oil dipstick regularly with this test, I noted another quart was gone after only 750 approx miles. I called the Jim Ellis dealer again and spoke directly to a tech after asking the original operator for further information concerning the plan of action. At that time I was told, by the tech, to fill the engine with another quart of oil and to NOT exceed the 5k mile limit from my previous oil change. I was told that "GM is watching closely" how dealers are dealing with this issue and that it needs to get fixed. Now (one week later), I am trying to get the dealer to look into this further and called again only to be told that I should never have put another quart of oil in the engine and that it needs to be looked at and done exclusively by the dealer. I was informed that I would have to get an oil change this Saturday and RESTART the oil consumption. My argument is that I have proven over 4.5k miles that I have now required 4 quarts of oil that there is a MAJOR problem that cannot continue to be ignored. I am incredibly disappointed in this service from GM and have now heavily reconsidered further purchasing another GM vehicle. Let this be added, that when the original oil issue was noted, I personally called GM and spoke to customer service, which offered to call the dealer and make sure they are doing the correct thing. Nothing more heard from them and am now questioning whether I can give this car to my expectant wife as this is probably less safe than her current 12 year old car. Sad in my opinion. Shame on GM for this level of care to their customers.
  • rebcky27rebcky27 Posts: 3
    edited April 2013
    Update 2: After opening the engine up they found zebra striping and significant scratches on the cylinder walls. They sent photos to GM and they approved the installation of a brand new engine with a 12 month/12,000mile warranty! Four days later and $200 out of my pocket I am one happy GM customer. My car is now running much smoother and so quiet in comparison.

    Thank you GM for replacing my engine out of the 100k mile warranty without giving me any grief or hassle. Customer service really shows the true side of a business. I just wish the resolution wasn't so 'hidden' from other owners so they too can have a safe car to drive.
  • lsb1955lsb1955 Posts: 17
    I had zebra striping and scratches too. I don't understand the 12 month/12,000 mile warranty. I have a new engine too. My car had approximately 73,000 miles on it when I got the new engine and the warranty is good up to the 100k mile powertrain warranty. I didn't pay anything out of pocket.
  • I had zebra striping and oil consumption at 39k. Engine replaced. At 83K, same issue. Engine will need to be replaced again. not good gm.
  • I am having the same problem with my 2010 Equinox, Unfortunately my car is now 3 years old and is not covered, I could not afford the extended at the time of purchase, nor can I afford to purchase a brand new engine for my 3 year old vehicle. Any suggestions would be greatly appreciated.

    Thank you
  • I have he same problem on a 2010 equinox. I only has 37 k miles and it burns oil. This is ridiculous for a farly new vehicle and absurd that burning 1 qt every 1k miles is acceptable. Chevy need to do th right thing or lose me as a customer.
  • gmcustsvcgmcustsvc Posts: 4,001
    Hi guill1234,

    I can certainly understand your frustration. I would like to get you into a dealer to get this issue look at, and stay involved throughout the process. Can you private message me your full name, address, phone number, Vehicle Identification number, and approximate mileage on your vehicle please? My email address is socialmedia@gm.com "attn Crystal" in the subject line. Look forward to hearing from you.

    Crystal L - GM Customer Care
  • elli2elli2 Posts: 14
    My 2010 will do that when it is at freezing temperatures. Turn the car on, radio doesn't come on. If I turn the car off and turn it right back on the radio works. Try that. Chevy could never figure out how to solve it, but since I came up with this easy workaround, I didn't force the issue. This "solution" works every time.
Sign In or Register to comment.