Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Subaru Legacy/Outback

1561562564566567574

Comments

  • Its a standard. it happens at about 2200-2500rpms. how long should a knock sensor last? like i had mentioned it was changed about 1.5 years ago. also would a new pcv valve help? its going to the shop tomorrow to check on the check engine light issue, most likely the rear o2 sensor
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,276
    I doubt they have a set life, but I would expect 150,000 miles out of one barring any problems that bring about abnormal wear. But, from your symptoms, it sounds somewhat like the car is receiving too much fuel (or not enough air) under those loads. If it came on suddenly, then something changed over night (clog, bad sensor, etc) rather than a more gradual change, like reduced power due to engine wear with high mileage, etc. Replacing normal wear items like PCV valve is a good start; also check to make sure there are no vacuum hoses clogged. My 2.5L '96 had quite a bit of crud in the vacuum lines near the PCV valve at 196K miles. You might consider checking the knock sensor to determine if it is within specifications. Work through the components that are taxed when the engine comes under load.
  • Go to a Subaru dealer and sit in a GT and other models to see if you like the comfort. Ask how much for the foam bottom. Ask an upholsterer how much if you give him the foam.
    Just re-covering your seat would NOT solve the problem.
    The problem is the cushion design, not the fabric.
  • bestdevbestdev Posts: 1
    Hi all,

    I have just bought a 99' Subaru Outback Limited Wagon 4D, 80 ,000 miles on it for $4,600 (I am located in the Bay Area). It has a salvage title.

    It was in the front car accident (the Air Bags did not blew up).

    The condition of the car is very good. It looks great and drives great as well, that is what actually made me to buy it. I have done some drive testing today for couple of hours everything was great.

    My question is: "Is there a way for me to make sure that the car is not dangerous for driving? So far everything is fine? Can there be some hidden defect?

    Thanks for your replies,
    Pavel
  • Hi!

    I don't know if this is something harmless or common, but I couldn't find anything like it here.

    My OB2002 drops water underneath the engine. It's not much and stops after a while when the car is parked - but it's weired. It does not smell like coolant - it's just water (no overheating problems encountered so far). My old '94 Legacy did the same thing but only when it was hot + the water would come out of a little pipe. Now it seems to drop from a connection point of a much bigger pipe.

    Could it be some overflow mechanism ? Also my AC cannot be switched off in the moment, it's always on, but I can't draw a connection here.

    Any ideas, experiences are greatly appreciated - because I do not want to turn it in and pay a whole lot of moeny it it's something 'normal'

    thanks
    Johannes
  • Nothing to worry about, just condensation from the A/C.
  • ateixeiraateixeira Posts: 72,587
    That's nothing, my van does this in 2 places! :D

    Seriously, it has dual A/C, so I get one puddle under the engine bay, another behind the passenger side rear tire.

    Strange location, I know!
  • ateixeiraateixeira Posts: 72,587
    Well, that should have been asked before the purchase, not after, but you could certainly pay a mechanic to perform a complete inspection.

    I'd have him focus on the areas that may have been damaged in the collision. Check the alignment, steering, the boots, etc.
  • paisanpaisan Posts: 21,181
    Yup I get 2 in my Armada with the rear A/C as well. The rear condensor is behind one of the rear wheels too.

    -mike
  • Puhh, that is a relief.

    I was hopping/guessing it might be something harmless, because it drives just fine - now I need to get the AC fixed....it's advantageous to be able to switch it off from time to time :)

    Johannes
  • famof3kidsfamof3kids Posts: 160
    I have to agree with this post. For the first few years of ownership, I've not driven my Legacy for over an hour at most. Recently, I've been making several 4 hour trips. Wow, I'm hating the seats now. It is hard and just uncomfortable for a long trip. My passengers have said the same. BTW, I'm 5'8" and 150lbs.
    I remember the Subaru seats of late 80's, now those were comfortable seats!

    Mark
    2003 Legacy Wagon Spec Edt
  • I have the opposite experience with my 2006 2.5i SE. I find the seats uncomfortable at first and then I get accustomed to them. I have gone on a 1400 mile road trip without any issues. Having the 8-way power drivers seat makes a big difference as I don't find the passenger seat to be as comfortable. The Lumbar support doesn't seem to hit in the right spot and they seem very firm. But for long trips it actually helps to straighten out my slouch and I can keep driving for a lot longer.
  • ateixeiraateixeira Posts: 72,587
    The 06 would have different seats than an 03.

    Basically the current Legacy came out in 2005. 2000-2004 were the years for the previous generation.

    I do not like our 2002 Legacy L's seats much, either. I loved my '98 Forester's seats.
  • paisanpaisan Posts: 21,181
    Yeah my 05 LGT wagon seats are great, even though they aren't even power. My favorite all time seats were the SVX leather seats. We did 1500 miles in 2 days in the SVX and didn't feel a thing :)

    -mike
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,276
    We did 1500 miles in 2 days...and didn't feel a thing

    Sometimes numb is the best way to go! :P
  • paisanpaisan Posts: 21,181
    Nah those SVX seats really were awsome! I should get a set for my dad's new 95 impreza.

    -mike
  • I bought an 08 outback a couple of months ago. The front seats are the most uncomfortable of any car I've owned. In particular the head rest tilts so far forward it gives me a pain in the neck. I've had comments from passengers (my wife in particular) stating(unsolicited) the same. Anyone else having the same problem? I was talking to the salesman I bought the car from and he stated he's heard several comments on this same issue. His pursuing this issue.
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,276
    It all depends on the person. I found the seats in my 07 Outback to be the most comfortable. I could drive from Anchorage to Fairbanks (6 hours, 350 miles) or vice versa without a bit of fatigue. That is the first car in which I was able to lay such a claim.
  • argonargon Posts: 1
    I don't know if you got this addressed or not. I had the problem with the same car with the last year, at 3,000 rpm, going up hill. The car would sputter and lose power, but never die. Grannies passed me on bicycles, but it never died.
    And since the engine light came on (and stayed on, in my case) I couldn't pass Virginia emissions, for my plates.

    One timing belt, a knock sensor, and three ignition coils later, the car still had the same problem.

    But at one trip to the mechanic, he had an idea it might be a fuel injector problem, so he switched out the number 2 and 3 injectors, because the computer said it was missing on number 2.

    Well, the problem remained, but then miraculously cleared up a couple of days later. Here's what I think happened:
    I run a low tank constantly (aversion to and denial of high gas prices). I think i had sumped up some blockage into the #2 fuel line into the injector, and that the injector itself was partially blocked. When the injectors were switched out, I think the force in the unblocked line in #3 pushed any gum out of the injector that was switched there. And, I think, the unblocked injector that was switched to number two allowed the line to eventually unblock over a couple of days.

    In other words, my fuel line was constipated.

    I can't verify this was the case, but can offer no other explanation, and the fuel injector switch-out was the last thing we did.

    So, if you haven't pushed the car off a cliff or fixed the problem in another way, I suggest you check your injectors and the fuel lines immediately before them.
  • bes001bes001 Posts: 6
    I am in the process of buying a 2001 Subaru outback. During the discover process it was said that when the second owner recieved the car from the dealer. The dash had to be replaced and the milege was set back to zero. The dealer said there was no way for them to reprogram the dash to account for the 53000 miles originally present. So a statement was issued with the new dash. Is this normal???!!? I can't believe they are unable to reprogram dashes to the the correct mileage. Is this so???
    Thanks,
    Ben
Sign In or Register to comment.