Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge/Plymouth/Chrysler Minivan Problems & Solutions

1177178180182183203

Comments

  • mojdodyrmojdodyr Posts: 22
    Anybody know where to get second row captains seat for my 03 Gr Caravan? Can I easily replace bench seats for those captains one?
  • shiposhipo Posts: 9,152
    Given that the DC minivans are some of the best selling cars in the U.S., I'd think that any good bone yard (junk yard or auto salvage yard of you prefer) would be able to locate a set of captains chairs in the same color and covering as what you already have. As for ease of installation, as far as I know, the floor tracking is the same regardless of which seats you have, so installation should be a simple matter of unlatching the old ones and snapping in the new ones.

    Best Regards,
    Shipo
  • I just check the codes, the light blink 12 then 55, Does anyone know what it means. :confuse:
  • My wife bought the 2001 DGC 3.3L while I was deployed. I must say that so far I am rather pleased with it. I have been looking it over and cannot find the pcv valve. I know that most vehicle have them in the front valve cover by the oil cap. Can anyone please tell me where it is?

    Thanks
    Jon
  • hayneldanhayneldan Posts: 657
    is located in the center of the front valve cover on th 03 3.3 and 3.8. Follow the hose from the air cleaner to the valve cover. pull off the hose and the PCV valve should be screwed into the valve cover.
  • gino45gino45 Posts: 52
    Consider yourself lucky, at least you still have warranty coverage. I on the other hand do not :cry: I am sure that I had this problem while the van was under warranty, but the the steering shuddered only a couple of times and I thought that the problem was with my tires. My advice to anyone reading this is that if you notice similar symptoms even if it only occurs once in a blue moon, take it to the dealer and make sure they document your complaint. That way you have a fighting chance of recouping your cost if the pump or rack goes out after your warranty has expired.
  • I have looked there and there is nothing in the hose that goes from the airbox to the valve cover.
  • :sick: Just curious if anyone else is having all these problems..?
    We bought our Caravan a year ago now. We bought it New/Used. It ran great when we got it. Starting in July1, 2005 we started having problems. It has now been in the shop 6 times including today. We had an AC problem which they pushed off, Door closing problems on the sliders (pushed off for a later date also). Things they have replaced so far include...2 headlight switches and wiring because they just went off while driving at night with our to little kids in the middle of trafic. Swaybar bushings, power steering pump and rack and pinion. They can't seem to fix the awful odor that makes you want to throw up. It is in for the 4th time now on that. The last time it did not want to start then did not want to stay running when it did start. Oddly enough no check engine lights or computer errors. Since this happened we are now getting 4 mpg in city and 6mpg on hwy. Chrysler can not provide any resolutions and the dealer is stuck. I told them if it can't get fixed I want it bought back and want something different!!!! It is also in for a popping noise when you take off in drive after backing up and yesterday the trans hesitated/slipped. We are up in arms. Has any body else had this much trouble? We can trust our 190,000 mile 93 Honda civic more than our new Caravan!!!!
  • aprendizaprendiz Posts: 17
    I cannot get de computer codes by de off-on method, any help pls?
  • As per the Haines manual it's located on the rear valve cover for the 3.3 and 3.8 engines.
  • fish8fish8 Posts: 2,282
    AND....to add insult to injury, I have called and left 2 different service advisors messages asking them whether I should give the power steering system time to bleed the air from the hoses due to the continued whining/groaning. Or should I bring the van back in. I have yet to get a call back and it's been since Wed.

    If the noises continue over the weekend I will show up at the dealer Mon morning and talk to the Service Manager.
  • Thanks. I couldn't see back there. I'll have to figure out a way to get to it.

    Jon
  • I have the same problem with my 96 3.0 it may not be the injectors take a hollow hose place one end on the injector and listen to the other end if you here it tick its fine if their bad im sorry they are around 130 dollars a piece (i bought 2)still not fixed if you find the answer let me know if i find it i'll let you know (my motor is now in 3 parts trying to find it :mad:
  • appieappie Posts: 2
    As I was travelling I-75 North, at the start of my day the heater system stayed cold for the longest time while the engine temperature was approaching the red. I stopped on the side of the road and checked under the hood. I carefully released the pressure under the rad cap and found the level to be way down. Further inspection revealed that the expansion bottle was filled to the top and appeared to have overflowed. I manually blew most of the contents of the bottle back into the rad and topped
    up the rad, after which I replaced the rad cap and restarted the engine. While idling I checked for external leaks and found none. I continued on my way and had no problems the rest of the day. The following days the same thing happened. Every morning after the engine had cooled I had to go through the same procedure. I installed a new rad cap, but still have the problem. The engine oil does not show any water ingress. Whenever I bring the engine to operating temperature, the coolant backs up in the bottle but will not go back in the rad when cooled down. Low rad level seems to keep the thermostat closed (not sure). The exhaust does not show any steam. What can be wrong..?
    Can anyone help me..?
  • kkirbykkirby Posts: 1
    I want to post this in case anyone is looking for positive feedback on Grand Caravans, model year 1999. (Mine was made in Windsor, Canada.) I bought it "pre-owned" with 24K on it -- it was a fleet vehicle that came to a local Dodge dealership. I compete actively in the sport of dog agility; because of this, I drive alone with my dogs far more than the average number of miles per year. From March 2000 when I bought it until two weeks ago (March 2006), I put 150,000 miles on my van. I never had a single bit of trouble with it--ever. The only "issue" I dealt with was brakes--I did have to have brake work done periodically. But the engine ran like a champion, and the transmission was perfect. It never seemed to need tune-ups, although I was diligent about maintenance servicings. I changed the oil every 3,000 miles, and rotated the tires every second or third oil change. I loved that van and had planned to drive it another 50,000 miles and then trade it in. Unfortunately, I had the bad luck to have my very first traffic accident two weeks ago. I was behind an SUV in stop and go traffic. He suddenly hit his brakes and I didn't have time to stop my van before I hit him at about 10 miles an hour. There wasn't a mark on his SUV, but the entire front end of my Grand Caravan was crumpled in. Because of the height of the SUV's bumper, it also caused internal engine damage, and with the age and mileage on my van, my insurance company wrote my Grand Caravan off as a total loss. I can only hope to be as lucky with my next vehicle, because in terms of reliability and dependability, I couldn't ask for a better van than my 1999 Grand Caravan. I'll miss it.

    -- Kip
  • shiposhipo Posts: 9,152
    Ordinarily symptoms like yours indicate that you have a bad radiator cap. I'd start by replacing that.

    Best Regards,
    Shipo
  • I don't want to look back there. If you find a way to change it let us know.
  • rickyd3rickyd3 Posts: 1
    This is driving me mad! The cruise keeps cutting out momentarily when the engine is cold (in the first 30 min), not very interesting you may think BUT the rpm and the speedo needles both fall to zero and the 'check engine light appears'. All of this only lasts for around 1/2 second (as if the van cuts out)with the van then cutting back in and the needles resuming normal positions/check engine light going out.

    Incidentally the only way to then set cruise back on is to cancel it and then turn back on.

    This only seems to be happening when cold (and is getting more frequent) but if taken for a long trip (over 2 hours) the thing runs faultlesley!!

    It has recently also started to just cut off when idiling........I would be grateful for any advice as all the mechanics and Dodge dealers in the area are at a loss to the fault!! :confuse:
  • willemwillem Posts: 16
    What you found are MIL codes (Malfunction Indicator Light)
    12 means 'battery disconnect within the last 50 cycles', and 55 is 'End of code' display.
    You can find those codes in automotive manuals like Haynes.
    My '97 T&C shows the #12 code for a long time now, even though the battery has not been disconnected in the longest time.
    If you do an OBDII scan, you get more precize pinpointing to a specific problem.
  • ledfordledford Posts: 2
    I have a 2002 Dodge Grand Caravan. I have about 60k miles on my van and so far I've had problems with the sway bar bushings, tie rods, sliding door wiring (chain) instrument cluster and transmission leak in a cylinoid. That being said, Question #1. Does anyone know if there is any maintenance you can do for the sliding door chain? I just paid to have one side replaced and the other door is making the same noise (gritty sound) the other side made before it broke. The dealer said to "wait untill it breaks". Because the chain is plastic I wasn't sure lubrication would do any good? #2 The lighting on my instrument panel is fading from about 0-40. The dealer said I needed a new Instrument Cluster and quoted me $552.00! Any advice?
Sign In or Register to comment.