Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge/Plymouth/Chrysler Minivan Problems & Solutions

18788909293135

Comments

  • conwaconwa Posts: 1
    How did you fix the ghost wipers?
  • dougd7dougd7 Posts: 71
    There is another black box below what your husband unbolted. That is where the air filter is located. The cover to it is held by a clip if memory serves. The top box is some sort of air mixer prior to the intake to the fuel injection.

    Hope that helps.

    :)
  • marssoinmarssoin Posts: 1
    Plymouth Voyager 98, V6, 3.0 L

    Since I bought the Van I have this problem. No one can find the problem. The engine will start, will run idle and acceleration is good. The problem start when the veh reach a constant speed "on highway" The engine will start to stutter for few second. It feel like pushing on the break, then il will do it again and again in different interval. If I pull a trailer or if the Van is full of people it won't do it. What can be the problem ?
  • I have a 2002 Grand Caravan Sport that has about 50,000 miles on it. It runs great, and doesn't act like it has a problem in the world. However, the Malfunction indicator light came on about a week ago. We were do for an oil change at that time, and thought maybe that was why. We changed the oil, and the light went off. It stayed of for about three or four days, and now it is back on again. I have had an engine go out in a car in the middle of the winter when it was just me and my son in the car. I live in the middle of nowhere and have about a 30 mile drive into town. What I am getting at is I am scared to death to drive the van while that light is on. Does anyone have any idea why it is on? Also, is it serious, is it my engine? I don't know much about cars, but I know that when that engine went out in the car, it was making all kinds of sounds. The van isn't making any sounds. Anyway, I am to scared to drive, so I am stuck at home. Any help would be WONDERFUL!!! phantomj_99@yahoo.com :cry:
  • dougd7dougd7 Posts: 71
    Best thing to do is to have your 'local' dealer scan the engine computer for fault codes. There is usually a nominal charge for this. Then go from there.
  • rubberduckrubberduck Posts: 5
    Is that the sensor on the trans?. Will there be any codes if the speed sensor has failed? Can the speed sensor be tested with a multimeter to see if it is working?

    Thanks
  • ntbillntbill Posts: 20
    My husband is thinking it might be related to the oil filter, which probably needs changing. The car has about 90K miles on it.

    What? At 90K miles you never changed the oil filter? For sure it can help, change that oil filter and your engine will be happier. It doesn't mean that it will solve your problem, but replace that filter as quick as possible, maybe it is clogged. You should replace the filter at each oil change.
  • fish06fish06 Posts: 4
    Hi, This might seem like a dumb question, yes, I am a newbie... anyhow... I was planning on replacing the OEM cassette player with a store bought stereo of some kind, and I dont want to break anything taking it out and was just wondering what the dimensions of it were(LxWxH), or the dimensions of the opening in the dash that it sits in would also be a great help...

    Thanks in advance, any help is greatly appreciated :blush:
  • ClairesClaires Chicago areaPosts: 979
    Welcome, fish06!

    No such thing as a dumb question :-) You might want to post your question in the Aftermarket Sound Systems & OEM Upgrades Forum, where there are a lot of experts who can probably give you the answer you're looking for.

    ClaireS

    MODERATOR
    Need help getting around? claires@edmunds.com - or send a private message by clicking on my name.

  • badgerfanbadgerfan Posts: 1,565
    If you leave anywhere near a major city, I would just watch the ads at the local big box electronic places. They run specials about every week on several CD/radio decks that include installation labor. You will still pay some for adapter wiring harnesses and the adaptor mounting plate, but the advantage is you do not have to mess with sorting out the OEM wiring and hooking it up properly.

    You can usually get the whole unit bought and installed for about $200-$250 including a radio/CD player that runs $100-$125. The low end Pioneer unit put into our 1996 Caravan works just fine, though the buttons are smaller than the OEM unit. and the display sometimes is to faint in bright sunlight, but hey it is a 9 year old vehicle, so I don't expect it to be pristine anymore.

    If you feel adventurous and want to do it yourself, Crutchfield has an on line store with lots of information, though their prices can be beat elsewhere.
  • 97xpresso97xpresso Posts: 249
    I replaced the AM/FM/Cass unit in my 2001 with an inexpensive Sony unit. Don't worry about the size, you will also have to purchase an install kit which comes with a bezel for your particular model year. Also comes with a harness so you don't have to disturb your vans wiring, should you ever want to re-install the original unit.
  • PROBLEM 1: I have a 96 Chry. T & C Minivan. The power rear windows operate intermittently. Sometimes fine, but other times they open only a small amount, if at all.

    PROBLEM 2: The rear wiper motor blows the fuse after just a few sec./minutes of operation.

    Anyone had these problems on similar vehicles? Any thoughts on how I should precede?

    Jim
  • vchengvcheng Posts: 1,284
    ... is well known. It is due to faulty motors for the rear windows. The cure is replacement. There was a TSB on it, but I doubt that it will be covered now under warranty for a 1996 van.

    Problem 2: This one I don't know specifically. I would think a regular diagnostic tree would turn something up in that particular circuit.
  • fish06fish06 Posts: 4
    Thanks for all your help, I am actually starting to understand this now!

    Thanks again,
    Oliver
  • Thanks for your input on these problems. I was hoping for the "rear wiper" problem to be common also and would save me the time of trouble-shooting the entire circuit for the shot.
    Thanks,
    Jim
  • vchengvcheng Posts: 1,284
    ... on the rear wiper problem. Check the bulbs in the center mounted third brake light. It has three bulbs, and a defect in one (or more) of them can *sometimes* cause a problem with the rear wiper motor.
  • brandyhagzbrandyhagz Posts: 1
    Hi,

    I purchased by pre-owned 03 Dodge GC Sport last year. After a week of ownership, I started having brake problems, so I took it in. They turned the rotors, replaced the pads and checked the lines. Six months later, they did it again, because the vibration was back...all was fine and dandy until about a month and a half ago.

    I was driving to the store when I heard a *crunch* followed by *click click click* any time I applied my breaks... additionally, my pedal would go all the way to the floor. Lucky for me, I was very close to the dealership, so I pulled in.

    After some testing, they said it was some sort of probem with the ABS Sensor on the front driver side wheel, so I had it fixed.

    Tonight, I was on my way home, and the ABS light came on again. This time, there is no crunch or clicking...just the light...my brakes also appeared to be working fine.

    I've had a lot of problems with the dealership regarding my breaks... :lemon: and finally got the BBB involved around Christmas time.

    I know there are no recalls, I'm just wondering if I'm alone here...is there an ABS problem with the 03 DGC Sport?

    What can I tell my dealership when I go in? I kinda feel like this should have been addressed the last time I was in there (six weeks ago) when they replaced some part of the ABS and charged me the deductible for my EW.

    I guess I'm just looking for some advice...I'm ready to drive the darn thing thru their fancy schmancy plate glass window and walk away...

    Thanks in advance :)
    Brandy
  • shiposhipo Posts: 9,152
    Hmmm, our 2003 GC ES has nearly 50,000 miles on it already, and the brakes (4 wheel disc) have been flawless so far. I just swapped the front rotors and pads at about 45,000 on general principal; however, they could easily have gone another 5-10K.

    One thing I have noticed from our 1998 GC Sport is that if the wheels are mounted with an impact wrench instead of a torque wrench (lacking a Dodge specified torque setting, I use the one from my 530i, which is 88.5 lb-ft), the brake rotors have a tendency to warp and cause the pedal to pulse under braking (the harder the braking, the more intense the pulsing). Since I've done all of the work on the 2003, I have no idea if it is as susceptible to the rotor warping as the 1998 seems to be (btw, this issue isn't just a DC issue, all cars are going to lighter rotors, and the problem is very wide spread). With that in mind, who has done the work on your GC? The dealer? An independent shop? Do you know if they used a pneumatic impact wrench to mount the wheels?

    Best Regards,
    Shipo
  • vchengvcheng Posts: 1,284
    ... for the Dodge GC Sport is 80-90 ft-lbs for factory alloy wheels (and 100-110 ft-lbs for steel wheels eg if using snow tires on a separate set).
  • shiposhipo Posts: 9,152
    Hey Thanks! "80-90" huh? It sounds like the 88.5 that I've been using is pretty much right on the money. ;-)

    Best Regards,
    Shipo
  • I just had my front brake pads changed on my GC 2001 ES at the Merlins shop. Now you all have me wondering if they used the right torque on my lug nuts. I don't want to have a problem down the line because they weren't adjusted with the right torque. They used one of those pneumatic wrenches on it, but I wonder about their intelligence there as is because I had paid for an oil change and when I got home discovered they had never done it. Had to go back. Anyway, is there a way I can check this and is it necessary? Thanks. :shades:
  • shiposhipo Posts: 9,152
    "Anyway, is there a way I can check this and is it necessary? Thanks."

    Yup. Buy one of these:
    http://www.sears.com/sr/javasr/product.do?BV_UseBVCookie=Yes&vertical=TOOL&pid=00944642000- -

    The cost is $27, plus the cost of a 19mm socket (and an optional 6" extension) and retorque your wheels to 85 lb-ft.

    Best Regards,
    Shipo
  • masterpaul1masterpaul1 Posts: 421
    Thanks Shipo, I have one of these and never used it. I will have to try it on our two vechicles to make sure the lug nuts are torqued correctly. :)
  • shiposhipo Posts: 9,152
    Don't forget to loosen and tighten in the "Star" pattern.

    For those who may not know, the star pattern can best be described this way:

    If you number the top lugnut #1, and then continue numbering them in a clockwise fashion, you would then loosen 1,3,5,2,4 in that order, then retighten them in the same order.

    Best Regards,
    Shipo
  • Thanks for the info.
  • ironsjironsj Posts: 1
    I have a '98 Grand Voyager. Whenever I attempt to use a power inverter through the front power outlet, I blow the 20 amp aux. fuse. The power inverter has a 15 amp fuse that does not blow. I cannot find anything else that does not function properly after the fuse blows. I can get the power inverter to work if the engine is running when I plug it in. However when I accelerate or turn the engine off (or plug the inverter in and start the van), the fuse blows. Any suggestions?
  • jjtjjjtj Posts: 103
    Hi Shipo,

    Hoping you might be able to answer a question for me. I also have an 03 GC, but mine is a Sport. I'm trying to replace the front pads/rotors & I can't for the life of me get the old rotors to budge. The calipers, bracket & old pads are out of the way. I've soaked it with liquid wrench but nothing moves. I assume the nut in the center is holding the axle in place and does not allow the rotor to slide off. Looking at the new rotors, it appears that there is a center hub with a larger area behind the rotor that holds the wheel lugs? I've tried hitting the rotor with a rubber mallet, prying it off, etc. Hard to get much leverage. My question is.. is there a trick to this? I also have the 4-wheel disc brakes (with ABS). I have had some pedal pulsation & this really annoys me, and this is usually a couple hour job, but I'm at my wit's end. Plus, my wife is without her van so as you can imagine this doesn't help matters.

    Thanks in advance for any advice you could pass along

    Jason
  • shiposhipo Posts: 9,152
    If I recall correctly there is a..., errr, well, I don't actually know the name of it. There is a type of a retaining washer that screws down on to one of the five lug studs. Said washer has a smaller inner diameter than the threaded diameter of said lug stud, and because the inner area is serrated, it is able to be screwed down onto the stud in such a way that it will hold the rotor in place come hell or high water. I suppose that this retainer is used during manufacturing as an easy/cheap way of holding the rotors on the hubs while the vehicle moves down the line and before the wheels are mounted.

    To remove this annoyance, I used a small sharp cold chisel and a small hammer and simply split the outer washer-like portion of the retainer. Once split, I used a pair of pliers to rip it off of the stud.

    If that is your problem, you should be good to go once the retainer is removed (it is unnecessary/undesirable to replace it). If you've already removed it, and still cannot get the rotor off, let me know as I'll have a few other questions to ask.

    Best Regards,
    Shipo
  • jjtjjjtj Posts: 103
    Thanks for the quick reply.. I did not know about this washer, is it visible from the inside of the rotor? It was starting to get dark so I gave up for tonight. Any hints on where to look for the washer? I'm gonna start early tomorrow & maybe turn the wheel so I can get a better look.

    On a side note.. on other vehicles I've owned & maintained, I've always been able to find lots of useful info on the web. But it seems to be hard to find much info on the GC.. maybe it's a vehicle that owners don't do much of their own work? Anyways, I just found it interesting. I can't even find a Haynes repair manaul for the 01-up DCX minivans.

    I really appreciate your help because I am very frustrated as rotors/pads is normally a pretty straightforward job.

    Thanks again, Jason
Sign In or Register to comment.