Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Cavalier

1636465666769»

Comments

  • kuri2k6kuri2k6 Posts: 1
    edited April 2010
    about a week ago I had a battery so bad in my 96 cavalier that it was leaking acid and corroded the bottom negative cable (that was connected to the battery tray)

    After getting a brand new battery and connecting a new negative battery cable everything seems to be working except when I go to drive, the ABS/Brake lights come on and I hear a ticking noise and the stereo just flashes. When I remove the Abs fuse, everything is fine.

    I'm thinking the system just has to reset itself, but I'm not sure. On the positive battery cables I cleaned off the corrosion with a wire brush and STILL get the ticking noise....can anyone help?
  • Hi all, i live in Dubai the hottest country in the region , I Own a 2001 Chevy Cavalier in dubai ...the weather here is too hot for an american car especially when its 4 cylendrs , however, its runing properly , i have the TC and the Check Ngine lights ON ... the car is making me feel cold in the summer despite of having the Climate controler on the full power am not feeling hot so i think tht its fair for a black old car , the car's electrical system is a bit poor and it has lack to reliablity but overall its way better dodge neon !!

    anybn questions abt anything abt the cavalier just let me knw
  • just above the battery there is a fuse box , however . seek it in the engine once u find it , remove the positive cable cord of the battery , take off the fuses one by one , clean the metal spins of the fuses it self with adding some pure gasoline on a textile and rubbing it gently after that shine it and clean it with a dry cotton textile as well , do this to each fuse u got including the big square black ones , now open the door of the driver u will see a fuse box at the side , do the same to these as well .

    if the problem resist i would belive that the wiring of the battery which goes to the DINAMO/Generator has got a short-shock and im sure that if u will not fix it any soon u will have the problem bigger , it will coast u like around 100 Dollars to change the wires and/Or to re-arrange them at a very proffisional W.Shop
  • So i have a 97 cavalier 2.2L 5spd. I recently had to replace the clutch. What started happening was the clutch pedal was sticking a bit and the shifter was difficult to well shift. It was very hard to shift, and at one point it was impossible. thats when the pedal stuck and did not come back up. Now i was advised to replace the clutch which is what i did but it still will not shift. It seems to be stuck in first and second and will not even go into neutral. I am not really sure what else it could be... I thought it was the clutch cables but i was not sure because then i was told that there weren't any. But that was from somone in another forum. I don't know what the problem is! Anyone have ANY ideas????????
  • Could use some advice if possible.

    I have a 94 Chev Cavalier with 110,000 kms (68,000 miles)

    'New' rad, brakes, muffler etc but has been sitting on driveway for a year.

    I wanted to fix it up for my son, but wondered if there may be major problems after sitting for so long.

    Would it would be worth it for him to put effort into renovating it? I saw that 94 was a good year for this model. Is that correct?

    It has always been quite reliable.
  • When I start my 1996 Sunfire convertible when it's cold (2.4L, manual transmission, 152000 miles), my Check Oil light stays on. If I turn the car off and back on, or if the car is warm, the light does not stay on. I had a sensor (Sorry, can't be more specific) replaced without any effect. Any ideas on a fix? BTW, there's oil and an OEM filter.

    Thanks for looking into this.
Sign In or Register to comment.