Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Cavalier

18889919394103

Comments

  • I have a 97 Cavalier, 2.2L, 150K+ on the odometer. Overall, the car runs okay, but I am having several wacky issues that have cropped up over time: When I park and turn the AC off, the engine stalls. When turning at low idle, such as pulling into a parking spot, the steering is sometimes very tight. When I hit a puddle, something from the engine compartment "screams" for a few moments, as if the belt is slipping.

    Last night I changed the oil and filter, installed new plugs, air filter, and replaced the leaking #1 fuel injector. (Over the last year, I had already replaced 3 of the 4 fuel injectors, due to leaking.) After all of that was complete, the engine initially did not want to start. I finally got it started, but it stuggled somewhat, and the check engine light was blinking. I rechecked my plug wires to make sure I had not mixed them up, and I'm 99% sure they are correct. I started the engine again, and it ran better, but the check engine light is now lit steady. I test drove the car, and it stalled as I was slowing down and starting a turn.

    I'm going to drive it to the auto parts store to have the code checked, but I wonder if any of you have any ideas or have experienced similar performance??

    Thanks,
    KJ in Orlando
  • You can relieve the belt tension by using a really long socket wrench(no socket). on the end of the belt tensioner is a place to put this( a 1/4 in. square) you can also get a serpentine belt tool at autozone, they'll let you borrow it with an I.D. of course. or you can always do my favorite, take a crowbar and put it on the top of the tensioner pully and push down.
  • Any recommendations for Batteries and Throttle body's? Plus, my CD player takes 10 seconds after I open my door to shut off normally. My battery died the other day, and ever since then, my CD player won't shut off... Think I should just unplug the CD player to reset it? Or is there something that I'm missing? Thanks!
  • I recently changed-out the fuel-injectors due to fuel leaks, I repaired the problem. Only now the car runs terrible. At start-up the car now stalls but does start. Also the car now hesitates when you accelerate after stopping at a red light or stop sign. These 2 problems were not present before changing out the fuel-injectors. I have also changed-out the fuel filter to see if it would help but it did not. Runs great on the freeway. Please help....
  • I recently had my 04 cav in for its 12000 mi. service, I told them about a "thud" in the front end when turning the wheel completely L or R. they informed me that the bolts on the left of the sway bar were loose and about to fall out. they said they never heard of such a problem w/ 04 cavs. has anyone else had a similar problem?
  • gonogogonogo Posts: 869
    Pull the radio fuse for 10 seconds. :)
  • Oh, good idea... Didn't even think of that. So much easier than opening the dash up again. Thanks, I'll post back whether or not that works!
  • Hmm. My 2004 Cavalier has 14,500 miles on it, and there is a clunk in the left rear wheel area when hitting a bump, turning tightly, or hitting the brakes hard. I don't think it is a big deal, though.

    Could it be the same thing? :confuse:
  • gmoudygmoudy Posts: 67
    No, it is not the same thing. Your rear axle does not have a sway bar unless you had an aftermarket one installed. It could be a loose or worn strut mount. Check out to insure that the strut is mounted properly and all hardware is tight.
  • Sorry. I meant to type "Front left wheel area" in my previous post. I was distracted at the time, and for some reason I typed "rear."

    Thanks
  • bdawnbbdawnb Posts: 2
    I bought my daughter a 99 Cavalier Z24 in April. At the end of September the transmission went out and we replaced it. Of course when we got it back we needed to reset the radio, which I was used to because I have a Monte Carlo.

    However, her code no longer works. I know she has the correct one because we used the year she was born and we did it together, wrote it down, and put it in the car file.

    So, took it to a chevrolet dealership who said she tried so many times it is in "super lock" and gave me some instructions to try to get some codes of the radio. They aren't working.

    I'm not asking for any information on how to get the codes off the radio...but do you think I should go to another dealer? I have tried what he said several times, which involves several hours of leaving the car on in the auxiliary mode and it just isn't working.

    Thank you for any advice.
  • As aformentioned, my 2004 Cavalier has had a popping noise in the front area of the car. It seems like it comes more from the front-left wheel area more so than the front-right. It has gotten worse and now seems to pop and creak when turning or hitting any bump. I am taking it to the dealership next week. Could anyone tell me what it is? Could it be the sway bar bolts?
  • Worked like a charm! Thanks!
  • gmoudygmoudy Posts: 67
    I would say go to another dealer. I had the same problem happen to me a few years ago on my 98 Cavalier. Went to the dealership and they got the master code from the factory. This unlocked my radio. The service manager than gave me the master code in case I ever had any more problems.
  • gonogogonogo Posts: 869
    Thanks for reporting the results. Pulling the fuse will fix most problems with the GM radio, most dealers don't know that. :)
  • bdawnbbdawnb Posts: 2
    thanks for the feedback. I'll call another one tomorrow.
  • My wife's 1996 Cavalier heater fan will not come on at the first 3 speed positions. It kicks on when you turn the dial to the fourth (highest) position. Can someone advise what may need replacement and where to find it in the car. Thanks
  • gonogogonogo Posts: 869
    Need to replace the fan resistor, behind the glove box and behind the fan motor. It can be bought aftermarket.
  • Thanks Gonogo, I will look for that blower resistor behind the blower motor. I see by the wiring diagram that it has 4 different colored wires going from the blower switch to the resistor so I felt that might be the part I needed to replace. Hopefully I can find it without too much trouble and if so will disconnect the negative battery cable from the battery before taking out the defective resistor. Thanks again!!
  • I really want to put in a stereo soon ....well a deck for now and possibly speakers(tired of the radio). I've been told by a couple places that it will cost aprox. 130 for the the wiring harness plus installation plus the deck. Aparently it will cost this much for all GM vehicles year 2000 and up because there the wires are all hooked up to one spot (to air bags etc) and they need to be moved to the trunk?? I had a friend who would have installed it but because it need to be wired differntly he didnt want to touch it in case something important didnt work later. Now ive been told by a friend that i should go to Canadian Tire and buy the wires for 30$ and take that to the place for them to install, saving me $$. Can someone better expalin why it will cost so much to install a stereo so i can explain it to people cuz they think its crazy to be charged that much ...also what kind of deck and speakers/size preform good in cavy's? (thinking pioneer or Kenwood) Don't need anything to elaborate. Thanks alot! :blush:
Sign In or Register to comment.