Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Lumina

1293032343541

Comments

  • I have a 1999 Lumina and it was running absoultely fantastic. I had to evacuate from Marrero, LA due to hurricane Katrina to Mooresburg, TN and now my wonderful car's gages are a wreck. The car is running great but the gas gage started to show signs of dysfunction in MS and now when full shows it's almost empty. The temperature gage is now stuck on 260 even before I turn on the motor. There is ample water and antifreeze so I don't understand what is happening. I am homeless and without a job and I have been told you are on your own to find a decent mechanic here. If anyone can enlighten me I would appreciate it. I love my car it has been a very dependable machine.
  • I've had the same problem with my 96 Lumina driving me nuts for years, and no one has been able to fix it. Strange thing is if I turn the key and nothing happens, then wait a few minutes, it will suddenly start, but the length of time I have to wait is inconsistent, sometimes a minute, sometimes half an hour! At first I thought it was my Audiovox Pursuit alarm system, but the alarm guys can't figure it out either. Sounds like you're on the right track though about the passive system, but I can't afford a new ignition switch (or is it the key?). I'd sure like to find someone who's been able to fix this, but I'm glad to find out I'm not the only one who has this problem. It's been a great ride since I bought it in 96, but it doesn't make a very good getaway car...
  • I have a 1999 Lumina and it was running absoultely fantastic. I had to evacuate from Marrero, LA due to hurricane Katrina to Mooresburg, TN and now my wonderful car's gauges are a wreck. The car is running great but the gas gauge started to show signs of malfunction in MS and now when full shows it's almost empty. The temperature gauge is now stuck on 260 degrees even before I turn on the motor. There is ample water and antifreeze. I have also checked to see if the water pump is working so I don't understand what is happening. If anyone can enlighten me I would appreciate it. I love my car it has been very dependable.
  • patpat Posts: 10,421
    You could try posting in Got a Quick, Technical Question? since no one seems to have a suggestion here. Hope your home is okay.
  • pluto5pluto5 Posts: 618
    Could be a sign of alternator malfunction. The alternators on the Lumina are a weak point. Mine was replaced when the vehicle was about five years old but with very low mileage and the symptoms included gauge malfunctions. Get a good rebuilt one with a 2-3 yr. parts warranty since a new one is likely to be no better than the original.
  • dave76dave76 Posts: 1
    ok went to get my car inspected and the check engine light won't come off even with the computer being reset. any suggestions plz!!!
  • Had to install new brake pads,rotors last year.After this the orange ABS warning light would not go off--brakes felt fine,I didn;t worry about it.Last month the battery went and after installing the new battery the red brake light will not go off--still have good brakes.Unhooked the negative battery cable for 10 min.hooked it back,no difference---warning lights still on ???
  • mitzijmitzij Posts: 612
    The light is on because the computer got a funky reading from one of the sensors it checks when you turn the car on. You have an emissions problem that will need corrected before the light will stay out. Find a good mechanic with a scanner.
  • mitzijmitzij Posts: 612
    Something is screwy in your antilock brake system. I would guess a speed sensor got knocked loose (or broken) when the brake job was done. You should get your ABS checked out. Your regular brakes will work ok, but if you're in a situation when the ABS should kick in (slippin' and slidin'), the system might not kick in at all or be irratic. Find a good mechanic.
  • Hi
    Glad to know I am not the only one with this problem with the 96 Lumina. It has driven me nuts. But if it happens I wait about 5 minutes and it would start. Replaced the Ignition switch 3 years ago and same problem still happens.
    It has been a strange glitch.
    Now the ignition switch has gone bad at a cost of about 240 to replace again ouch.
  • Hi
    Turns out the Ignition switch is good. Time to lose the car.
    Ouch
  • Well I am pleased to say I got help from my brothers who found out my thermostat sensor was bad. I now have my dependable Lumina back. My family home was seriously damaged. We plan on staying here in TN to start all over again. Thanks so much for your information with regards to my gauges. Have a great day.
  • itsameitsame Posts: 1
    My 2001 Lumina tried to become the first GM submarine a few days ago and got caught in a flood. The start sounds like it's turning but I don't hear the egine actually trying to start. Where is the computer on this car? I pulled the kick panel beside the passenger door but evidently the sahpe may have changed because I didn't see anything that looked like a control computer. Has it moved? I replaced the oil, tranny fluid and both filters. What can I do to check out the computer and get this mule to start?
  • Thanks for the information on my gauge problem. I replaced the alternator @ 38,420 a couple years back with a new alternator. I only have 46,000 miles on it now. I will keep an eye on the alternator since you have shared your experience with me. I think I got the gauge situation under control by replacing the thermostat sensor everything seems to be just fine now. Good luck with your Lumina and thanks again for your info.
  • bbargbbarg Posts: 1
    I am having the hardest time getting my original battery out of my 97 chevy lumina. I have unbolted everything and the thing will not budge. Any help would be appreciated!

    Thanks,

    Brad
  • pluto5pluto5 Posts: 618
    I have the '97 but don't recall problem in getting the battery out except that I had to remove a bunch of stuff, e.g., lateral support bar over battery, washer fluid resevoir, and part of the the air intake assembly. Don't recall any clamps near the base of the battery, though.
  • jr223jr223 Posts: 1
    Help. Earlier today I was having trouble with one of the door locks not opening..then this evening my battery is dead. I was reading thru some of the other posts and it seems they might be connected somehow. I (my cousin and I) tried to get the battery out but it is buried under all that stuff.. lateral bar, washer fluid, some electrical doodah and the air intake deal. He gave up and I dont know anything about cars.. I will have to have her towed tomorrow but me being female, I dont want whomever gets her to try to railroad me.. what should I say in man to man car terms? :sick: :blush:
  • pluto5pluto5 Posts: 618
    How about, "please check my charging system and if OK replace my battery"?Sears may do this for nothing if you buy their battery.
  • pdanapdana Posts: 19
    I have a 1992 lumina eurosport and for awhile it has been making a thumping noise in the rear passenger area any time I drive over any bumps. Has anybody else had this problem? I can actually hear it by just pushing down on the back of end of the car.
  • hi, i bought a 1996 chevy lumina about 7 months ago, it only has the 3 standard gauges, i was wondering if i put the IP cluster of a 96 chev lumi LS in it with the tachometer, if it would work, my car is alo canadian built, the vin number starts of like 2G1 so if anyone can tell me if the car is max wire for this it would be greatly helpful thnx :confuse:
Sign In or Register to comment.