Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Lumina

13536373941

Comments

  • Hey everyone I own a 1996 chevy lumina with about 130k miles on it she's a 3.4 V6 she ran great until I notice oil spills and if I passed 60mph, it started to shake a little. Well today I tried to take her apart to change the spark plugs, I have a shop manual and I notice oil in the around the spark plugs and a lot of it I removed the head and two of the seals for the spark plugs where a little twisted out of shape one in the front and the other in the rear where the spark plugs went I was going to remove fuel rail because I notice oil and antifreeze moisture around the area but I'm stuck I don't know what to do the manual does not really tell me anything else ??? :confuse:
  • hi there, oil around the spark plugs is normal and commonly seen, and is fine as long as its in the threads or on the porcelain part of the plug only

    sounds like an external leak, valve cover most likely

    no need to remove the heads

    if you end up finding out the engine is bad then lemme know as i have a good running 3.4L in a 92 Z34 i may sell/part out

    make offer for engine or parts

    good luck
    randy
  • for sale for 650 bucks as is or may part out or trade for a good old work truck heavier the better,

    -needs head gasket or intake gasket it was burning some water, so i parked it
    -has been parked a few months,
    -everything is fine except for the head gasket, and the front bumper top side of it is sun faded, and the GFX below it cracked,
    -and it needs the carpeting shampoo'd
    -no sterio,
    -new windshield it was replaced last year,
    -good tires,
    -factory 16" mag wheels,

    pics:
    http://img.photobucket.com/albums/v298/fast68/randys%20vehicles/Z34Lumina001.jpg-

    http://img.photobucket.com/albums/v298/fast68/randys%20vehicles/Z34Lumina002.jpg-

    http://img.photobucket.com/albums/v298/fast68/randys%20vehicles/Z34Lumina003.jpg-

    it is in central IL on I-55 exit 123 betwene springfield and bloomington
  • ttt still for sale or parts :D
  • my 96 lumina has no ele power to the starter sometimes, it will not start. It has a factory secutiry system and an after mrkt radio. please help
  • 91euro91euro Posts: 4
    I have a 1992 Lumina Euro, I may be getting ahold of the bumpers, side skirts, trunk lid, hood and liscenceplate/revers lights form a 1993 Z34, does anybody know if all of those parts are interchangeable between the two?

    I know the reverse lights and bumpers are different, but the Z34 liscenceplate holder and reverse lights should bolt into place of my original revers lights and fit because it will have the z34 bumper right?

    I dont see why the side skirts or front bumper or hood wouldnt bolt up, but it anybody has any ideas or suggestions that would be great!

    thanks!
  • coderedcodered Posts: 43
    i have a 90 Lumina.....it has a noise that kicks in round 40mph......its not there when wheel is pulled to the right...i was told driver side wheel hub...but still not fixed .....any info would be great...thanks
  • deborahfdeborahf Posts: 15
    Hey Everyone,

    I recently purchased my Lumina. Had the oil changed. That's not the problem. After purchased (from Step-dad)I looked under the car and noticed that is had a bunch of oil underneith. It also drips a few drops after I drive it. Slow drip. When I had the oil changed I asked the mechanic if he would look at it. He says he "thinks" it may be the Valve cover gasket. How do I tell if it is that or if it is the head gasket? The car seems to be running fine and makes no unusal noises.
    Another question: I looked in the "Reserve tank"...for the antifreeze. It is extremely low and looks nasty. Planning on getting a flush. Can you tell me exactly what is done when they do this.
    I apprieciate every anwser. I am a woman and would like to go into this knowing like I know something about what is done. Thanks
  • jpfjpf Posts: 496
    Is the coolant green or red? I believe GM did not switch to Dexcool (red coolant) until 1996. Dexcool has been the subject of many complaints. I would get the flush and new coolant. If the leak problems persist (oil and coolant), I would get an oil analysis to make sure the coolant is not leaking into the oil. This would cause major engine damage. Also, GM vehicles with the 3.1 liter V6 engine tend to have a leaking intake manifold gasket. Most Lumina models used this engine. If this is the problem you need to get it fixed as soon as possible. Good luck.
  • deborahfdeborahf Posts: 15
    jpf....Thanks for replying. I checked the color in the reserve tank and it looks like it is supposed to be green. I rubbed between fingers and it feels pretty oily. :cry: It probably shouldn't feel that way...that's my guess. We are probably talking big bucks getting a dealer to repair...
    Deborah.
  • deborahfdeborahf Posts: 15
    Does anti-freeze feel oily to the touch? If I needed the intake manifold gasket replaced, should this be done before the radiator flush? Is there any other parts that would need to be replaced while repairing the above? Radiator hoses? Thermostat? Also...when checking the air-conditioner, what does that involve?
  • annalynneannalynne Posts: 1
    I need to remove the back spring system from my neighbors car. Dose anyone hava clue on how to do it, where the bolts are? What does it involve? Is it hard? Please help. :sick: The rear end of the car almost touches the ground and makes for a rough ride.
  • jpfjpf Posts: 496
    The best way to determine if oil is in the anti-freeze is to have an analysis done. If the oil and coolant are mixing you need to find the problem and have it fixed right of way. I suggested a leaking intake gasket may be your problem because this problem is common with GM's V6's. Changing the coolant without fixing the problem is just a short-term fix until the coolant got contaminated again. I would also change the hoses and thermostat. Good luck.
  • Does anti-freeze feel oily to the touch? If I needed the intake manifold gasket replaced, should this be done before the radiator flush? Is there any other parts that would need to be replaced while repairing the above? Radiator hoses? Thermostat? Also...when checking the air-conditioner, what does that involve?

    deborahf,
    when I replaced my intake manifold gasket, I had them change my thermostat as well. Only adds a couple dollars to the job.
  • peter6f2peter6f2 Posts: 1
    95 Lumina sedan.
    not able to put the transmission in Park any more.
    key cannot be removed from ignition.
    anyone know how the lockout device works and how to repair it?
  • jwtee1961jwtee1961 Posts: 4
    my buddy and I just bought a Lumina here in the uk,it went great for about 6 miles then cut out no amount of persuasion would make it start sounds like a sensor to me anybody got other ideas. p.s no bad noises or grinding or
    gnashing of teeth when she gave up the ghost p.p.s this vehicle has to get us from uk to the gambia(africa)any tips/advice?
  • mindmeldmindmeld Posts: 4
    So my wife has a 98 Chevy lumina which is up to about 210,000 miles now. Just yesterday she went to start it and all the electronics came up but it didn't start. The third try it started fine. When she was home from work where this happened I went out and tried my key with the same issue. The security light was coming on during these tests and a look in the manual pointed to a possible issue with the security system between the key and the engine.

    I've noticed some other posts on here with something similar although I am seeing people having replaced thier starters. It sounds like this is not as critical as I had originally assumed however has anyone else dealt with this and know a fix. Am I looking at just needing to clean the ignition where the keys go and then being fine. Or do I need to replace the starter or the security sensor? Thanks for the help.
  • jwtee1961jwtee1961 Posts: 4
    Addition to my last post,Lumina now starts but when put into drive it cuts again(do these things have "sense of humour" chip installed by chevrolet?).The only thing I can put my finger on is when she starts she is pulling about 2000rpm.Is there an inbuilt safety device to stop her taking off like a "scalded cat"?.Any help would be greatly appreciated.
  • jwtee1961jwtee1961 Posts: 4
    I had similar problem with a Ford here in the UK.I was told that when you insert the key the transponder tells the security system "Hi it's me", but the system is saying no its not.I know this sounds silly but the guy at the garage thought I was a retard.It boiled down to some water having got into the ECU I had to get a recon one and get it re-coded
  • mindmeldmindmeld Posts: 4
    What was the cost on that? I think i could replace one myself easily enough but recoding sounds pricy.
Sign In or Register to comment.