Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Suburban LTZ Power Running Boards

I recently had my battery replaced. After it was replaced, the power running boards do not work any more. I have tried switching them on and off. When the battery was replaced, the power running board switch was in the off position.

Comments

  • kiawahkiawah Posts: 3,666
    Did you check the fuse?
  • joeykbjoeykb Posts: 3
    Yes, Sorry I did forget to mention that I replaced the 30A fuse.
  • kiawahkiawah Posts: 3,666
    Make sure the ASC (assist step control) disable switch is not pressed.

    The ASC has an error condition fault detector, and if it detects an error, it will disable the ASC until it has had 50 error free ignition cycles. I'd go try that first, before going much further. I'm wondering if changing the battery created an error fault for you.

    If that doesn't resolve the problem, check under the vehicle, under the running boards. One side will have just a motor. The drivers side would have a motor and the assist step control module.

    It'll have two plugs, one plug is a 6 prong plug, the other a 10 prong plug.

    On the 6 prong plug, two rows of 3 pins. The pin #5 (a middle pin in one of the rows and a RD/BK wire), is the battery voltage. See if you have 13 volts there. If you don't, then you have a power feed problem to the control module. If you do, then you can choose to either take it to the dealer to see if they have a tool to run diagostics on the controller, replace the controller on the possibility that it has blown somehow, or live without the power steps.

    Good luck, let me know how it goes.

    I didn't get steps with mine, more to go wrong ;)
  • joeykbjoeykb Posts: 3
    Ok, I cycled the ignition 50 times, by that I mean, I started and stopped the engine 50 times, removing the key between every cycle. I also checked the voltage on the #5 pin and it did in-fact have about 13 volts. I guess I will need to bring this to a dealer to get fixed. Thanks for your input.
  • kiawahkiawah Posts: 3,666
    Rats....that is unfortunate. Might want to do a price check on the price of a ASC controller, to know that prior to going to the dealership.....just so you aren't surprised if that is what they recommend.
  • Well, after a few weeks of searching, I found the answer to the problem. After the battery has been replaced, the ASC controller goes into storage mode. To get them out of that mode, simply open all 4 doors and press the ASC controller disable button on and off 4 times. The running boards open and function properly. Thanks for everyone's reply.
  • brian_rbrian_r Posts: 4
    I also have a 2007 LTZ with Power Running Board issues. For about a week the driver and passenger side took turns on with board was going to work. Now for past couple of weeks only the driver side functions properly. The passenger side does not work when you open the door. Sometimes after starting to drive the vehicle the passenger side tries to do something, you can hear it trying to lower and retract.?? Could this be a aging battery issue? Or is there a more likely cause.
  • Same issue here. 2007 LTZ. Passenger side is fine. Driver's side was inconsistent for about two weeks, and now is stuck in the up position. Any easy fix? If the dealer needs to fix this, any idea as to the cost? Thanks.
  • brian_rbrian_r Posts: 4
    I still have not fixed this yet. To be honest, I'm a little afraid to see how much the dealer will stick me for this. I'm not really sure what I want to do with these boards yet. I've had the truck for just over 1 year, and really wasn't too pleased with how the boards performed in the slush and snow. I'm thinking of maybe locking them in the down position for the winter, but I really don't like how that looks either! ?? Please let me know if you come up with anything, I'll do the same.
  • sbradburysbradbury Posts: 1
    Did you ever get this looked at? I am having the same issue with my 08 Tahoe. My passenger side was working on and off, then all of a sudden started working great and my drivers side stopped. It is stuck in the out position. I can hear the motor click on to try and retract it but it doesn't move. I can't hear it try and move when i open the door, so it seems it alreadys knows it is out. When i close the door, it seems to try and retract it twice then i stop hearing the noise.
  • brian_rbrian_r Posts: 4
    This is what I did. Last fall my wife had ACL surgury so I opened the doors to get them to drop, then I pulled the fuse. I ran it all winter with them down so I wouldn't have to deal with it. This spring I decided to take another run at it. I put the fuse back in, opened the doors and flooded both hinged joints with WD40 several times. This didn't clear it up right away, but I continued to open and close the doors, re-appling WD40 until they ran smoothly. They have worked fine ever since. It's unfortunate that there are no grease zerks on these. My guess is that I will need to continue to do this as they get sticky.
  • andyp22andyp22 Posts: 1
    I am having problems with my powered running boards also. My drivers side will work every once in a while. It will sometimes come out and stay out and other times will make noises like its trying to come out but does not. So, I took it to a Dealer in Maryland and they said that they ran a diagnostic that showed nothing wrong so they thought that the motor must have a short or some problem. The estimated price for the motor was $901.00 plus $350.00 labor to install the motor plus $98.00 for the diagnostic. Well, I paid the $98.00 and said forget the rest. Does anyone have any ideas on how to get these things to work like they should. The passenger side works fine.

    Help!!!

    Andy
  • brian_rbrian_r Posts: 4
    Did you try the WD40 trick. I mean soak the pivot points. There are two pivot points on each mechanism. So, 4 on each running board. The one on the top is a little hard to get to. I had all kinds of problems until I did this. Mine has been working fine again for more than 18 months since the inital problem. I periodically do this to them when needed and they continue to work fine.

    Good luck-

    Brian
  • Andy,

    I have a 2007 Escalade with the same problem. Being an electrical engineer and familiar with electric motors, I decided to take the housing off of the passenger side articulating running board motor. What I discovered was that the carbon brushes were beginning to wear out and were not making contact. I moved them back and forth with their spring assists and put the housing back on. Well... :) after that they are working (with abnormal noise) but now the running board function is reversed. I am not sure if the computer is confused at their position now when the door is open or closed.. I will attempt to pull the fuse to the asc controller for a while to see if that resets things.

    I do plan to take the motor off and pull the carbon brushes out, measure them, and order new ones online based on the size. It appears to be a little tricky to pull the motor off as there are some star screws holding it into the mount that have little clearance to get to in front of the winding rotor of the motor. I fixed a power window motor on my mom's Toyota this way that would have cost almost $500 to replace.

    With a little patience, you can probably replace the brushes and avoid paying the ridiculous price of getting the dealer to fix it, or the price of a new oem motor which is circa $260. Hope this helps you.

    If anyone knows how to reverse the logic of the ASC articulating running board controller I would appreciate the info. Thanks.

    I'm getting really tired of the crap parts that GM put into these vehicles that appear to be manufactured in Mexico. As another example, I have also replaced all of the power door locks twice!

    Barry.
  • apulkkinenapulkkinen Posts: 1

    I just bought 2008 Yukon Denali and had the same trouble as many others with erratic driver side power running board. I did the WD-40 treatment suggested by brian_r and it worked great! Boards are back to fully functional. I highly recommend trying the simple WD-40 treatment before any major repairs because of erratic power running boards.

Sign In or Register to comment.