Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet (Geo) Prizm

1313234363747

Comments

  • I have a 92 geo prizm Gsi 1.6 Ltr, with an "automatic transaxle" Can someone tell me : What Part Number or Model: "..." it is.
  • kiaunakiauna Posts: 1
    Hello,
    I am a student who just purchased a 92 Geo for 650.00. I thought I was getting a good deal but the car needs work ex: alignment, exhaust or gasket leak, CV joint, rear tires, scratch on windshield, wiperblades... I just want to know is the car worth me putting in that much work or should I just resell it for 800.00 and buy another one.
  • dwellsdwells Posts: 2
    I HAVE JUST PURCHASED A '95 GEO PRIZM (4 DOOR) AND IT HAS NO OWNERS' MANUAL. DOES ANYONE KNOW WHAT I CAN DO TO GET ONE? I REALLY HAVEN'T MUCH MONEY TO BUY ONE. IF THERE WAS A WEBSITE, I'D BE HAPPY TO BE ABLE TO GO ONLINE AND BE ABLE TO READ IT. MUCH THANKS FOR ANY HELP AND GOD BLESS.
  • jakeb377jakeb377 Posts: 1
    I have a 1991 Geo Prizm GSI which has a 1992 LSI motor in it. It died when turning a corning and won't start. When it cranks over I hear a loud rattling noise. Like a marble in a tin can. Does anyone have any suggestions on what could be wrong with it?

    Thanks

    Jakeb377
  • prizmdanprizmdan Posts: 2
    I have not got really in to the cable thing but I will take your advice and change them out, I did it a little visual check but not a great check.

    Thank you !
  • mt700a1mt700a1 Posts: 53
    I'm not sure about the car's mileage or the overall condition so this is a general comment.

    Try to find a clean, 100% functioning car with a bundle of repair receipts. Owners who are obsessive about keeping their cars in a perfect shape all the time are the ones you should look for. Meticulous record keeping tells you what the car had gone through, and it also speaks of the level of awareness the owner has on the proper maintenance of the car.

    I normally stay away from cars that are in need of new parts to be roadworthy.

    Now for the specifics: Exhaust leak may be a cracked exhaust manifold, rusted catalytic converter, and/or the muffler. It is quite possible that more than one, or all, of the above need replacement. If so, it could easily run $400 or more.

    CV joints.. probably a few hundred bucks but not sure. Tires--spend at least $60/tire. It's a safety issue. Bold tires indicate negligence. You may need brake service as well.

    Wiper blades are only $10 or so, but again bad wiper blades say something about the level of care the car received from its owner.

    Unless you know exactly how much it will cost to put the car back on the road (or you can do the work yourself), I would not recommend you to put money into this car.

    Good luck,
    M
  • footpoundsfootpounds Posts: 22
    Go here and register to get an online copy of your owner's manual: https://www.mygmlink.com/main/US/en/gm/home?cmp=gmcomhp
    That's exactly what I did to get a copy of a '96 manual.
    P.S. See that "CAPS LOCK" button on your keyboard? Press it one time!
  • seanorseanor Posts: 1
    my friend had the same problem with his 94 prizm. The poor car has nickle and dimed him to death. He finally decided to just install a push button start. The only problem with that is you have to make sure that the steering wheel doesn't lock itself. so once he got the key turned he left it that way and installed the push button. Now he can start the car with the button but make sure you have an extra key made so you can lock the doors. since you have to leave the one in the ignition in the on postion to keep the steering wheel from locking. I hope this helps. sounds like al;ot of work but these carrs ignitions suck.
  • 95 percent of the time a check engine light comes on, it's because of an oxygen sensor. However, if your mass air flow sensor gets dirty, in addition to decreased gas mileage, eventually the check engine light will come on. the sensor can't tell how much air is flowing to the engine and the dirtier it gets the more gas the car will consume. clean the metal wires in the sensor and this should alleviate the problem. let me know if this works. it did for me.
  • dwellsdwells Posts: 2
    GOT YOUR MESSAGE AND LINK. VERY MUCH APPRECIATED. THANK YOU AND GOD BLESS.
  • imadad2imadad2 Posts: 79
    I just had a 2000 Prizm "check engine" light problem. I cleaned the mass air flow sensor and the problem was solved. The mechanic I talked to stated that he checks the mass air flow sensor first before anything else and 90% of the time, that is what it is. Good luck.
  • coleynacoleyna Posts: 3
    I have a 1997 geo prizm question....the knobs for the climate control broke off.so a friend brought me some misc knobs to put on there.they kept falling off.so another friend thought it would be a good idea to super glue them on.not a good idea.the knobs were froze.upon turning them they busted off with the male part stuck into the knob.will i have to buy a whole other climate control or can this be fixed? thank you
  • coleynacoleyna Posts: 3
    ok i am reposting this ....because i probably did it wrong the first time.
    I have a 1997 geo prizm question....the knobs for the climate control broke off.so a friend brought me some misc knobs to put on there.they kept falling off.so another friend thought it would be a good idea to super glue them on.not a good idea.the knobs were froze.upon turning them they busted off with the male part stuck into the knob.the fan is stuck on med-low. will i have to buy a whole other climate control or can this be fixed? thank you
    Colette
  • I recently replaced my 1993 Prizm with 160k miles with a 2001 Prizm with 60k miles, which I bought for $6000. It's the base model, though it does have the 4-speed automatic. I'm wondering if anyone else finds the last generation Prizm to be noisier, particularly clunks from bumps in the road. The new car is a perfect replacement for the old Prizm--a commuting appliance, boring but dirt cheap to own--except for the noise.

    I checked the spare in the trunk, and made sure it was tightly secured, as well as the jack, but whenever I go over a moderate-sized bump in the road, it seems noisier than the old car. I'm pretty sure it's coming from the back end of the car.

    In looking in the trunk, I noticed that there seems to be very little sound barrier between the trunk and the passenger compartment. I was wondering if it would make sense to bolster the barrier between trunk and passenger compartment with some kind of sound-deadening material. The first thing that came to mind was my wife's old yoga mat.

    Any ideas?
  • mt700a1mt700a1 Posts: 53
    The noise you described sounds like a bad strut (suspension component). If it makes a loud clunk only when going over a pothole or sharp speed bumps, you should suspect the struts.
  • Thanks for the suggestion. Is there a way I could visually check for a strut problem without having the car on a lift?
  • mt700a1mt700a1 Posts: 53
    I don't know of a way to test this for sure...
    Put the car on a jack, and try to push up the suspected wheel. Some say if you can lift the wheel up by hand, the suspension mount is worn. Can someone verify this?

    What you can do easily is to make sure that it is not the jack or spare tire in the trunk that is making the clunking sound over bumps.

    You could go for a test drive with a mechanic and see what he says. If a full replacement of strut assembly is recommended, you can call around and see if anyone will replace only the worn part.

    Good luck.
  • No u don't have to r/r climate control, use industrial strength adhesive remover to unstick climate control linkage, clean surface, then re-attach, with stronger adhesive, such as appriate type of Epoxy.Find Epoxy at Auto part store., If ur initial attempt fails to remove adhesive, because the glue has leaked into climate control linkage lever slot, remove dashboard and center console, to axcess climate control mechanism, take it apart, use adhesive remover on stuck or sticky parts, then wash off any adhesive remover with water, then dry, then reassemble ur unit minus the knob then put dashboard and center console back together...good luck.... :)
  • coleynacoleyna Posts: 3
    Thank You for your reply(answer).Sounds like I'm gonna need alot of luck.
  • cf_pcf_p Posts: 1
    In a Prizm (2000) with no ABS, does the ABS gauge light serve any function, and should it light up when the ignition key is turned (or ever)? IOW, does this light test anything at all about the condition of ordinary brakes?

    Thanks!
  • scarygirlscarygirl Posts: 1
    One word: ignition. The whole thing is likely to go out at any second. That's what mine did. Just last week. I had the exact same problem as your daughter. Until recently, I thought it was me! I HIGHLY suggest that she get rid of this car now while she's ahead!

    Within the last year and a half I've spent $3600 due to one break down after the other. That doesn't include all the other repairs that it needs that I can't afford. At about 120,000 miles, this car turns to mush. So what it has a toyota engine, it just isn't worth it. If you fix this I guarantee you have a host of other problems just around the corner. If you have't already. This car is a sinking ship.

    While I'm all for paid off cars, this is riduculous. I so wish I had traded it six months ago.
  • usa2usa2 Posts: 14
    I have a 1996 Geo Prizm LSI with tan leather "faced" seats. It just turned 104K miles.. great car without any mechanical issues.

    I have had this commuter car ever since 11,000 miles but now need to repair or replace the side bolster of the driver side leather seat because of wear (and a tear).

    Does any one know a site that I can find a replacement leather (not cloth/cover) seat or a shop that repairs/re-upholsters leather seats?

    Thank you very much. Good forum...

    Joe :)
  • Karen_CMKaren_CM Posts: 5,019
    This is an old topic in the archives, but it may have some information useful for you.

    Maintaining Leather Maintenance/repair

    Community Manager If you have any questions or concerns about the Forums, send me an email, karen@edmunds.com, or click on my screen name to send a personal message.

  • rep5858rep5858 Posts: 45
    I have a 95 prizm with the 1.6 and 3 speed auto. When the car accelerates, decelerates and rides at highway speed there is a loud dull roar coming from engine area.I had new tires put on and new exhaust system, still noise there. Mechanic said it is the noise of the air induction coming through the duct system. I insulated this area and the firewall. Still hear the noise plain as dayy the engine .
    Does anyone know where this noise is REALLY coming from???Are there any solutions to solve this obtrusive noise. ?
    Thanks in advance
    rick
  • I have a '96 Geo Prizm with 225,000 miles on it and I love it. It's hardly ever given me a problem. However, just yesterday my retractable driver-side seat belt went on me. I pulled it out to buckle my belt, heard a funny crunching sound from the mechanism, and realized that the belt wasn't retracting anymore. I have twisted it and turned it to try and get it to retract, but nothing works.

    I have priced replacement belts on the Internet and it looks like I can get something for $80 to $90 dollars. None of the Internet sites,however, give any hint whatsoever about removing the door post trim to get at the old seat belt mechanism. And I'm not finding anything helpful using Internet searches either. Is there anyone out there who can give me some tips on how to remove the trim without damaging it? I'm also a bit confused about how one gets at the upper anchor for the shoulder part of the belt. (It's attached to an adjustable post somehow, but for the life of me I can't see how to unattach it.) Any help would be greatly appreciated.
  • mt700a1mt700a1 Posts: 53
    Exact same thing happened to my car. Weird crunching noise and the belt does not retract...

    I ordered a replacement online ($80) so I'll post the result when I get the part.

    The plastic cover on the door post just comes off when you gently pull on it.

    The loop on the anchor for the shoulder part-if you look carefully you'll see that the anchor part can be popped open with a flat head screw driver. Once it is opened, you'll see a 14mm bolt (the same size as the lower anchor bolt) you have to remove and the thing comes off.

    M
  • mt700a1mt700a1 Posts: 53
    Hey I hope this is not too late.
    I bet the noise is coming from the exhaust manifold. When you open the hood, you will see a big cast iron manifold located at the front of the engine, covered with a heat shield. (The part that burns your hand when you try to remove/install the oil filter!) The manifold cracks often on these cars, and exhaust gas that would otherwise exit through the muffler can leak a little bit, causing a loud noise upon acceleration and deceleration. The part is available at Advance Auto Parts for around $150 I think. You might be able to spot a crack in it without removing it.
    M
  • sunyvelsunyvel Posts: 2
    Hi ppl,
    I have bought a geo prizm 97 model, 1.6L. It is so far running well. I was going to change the spark plug, when i ended up with some issues.

    According to Haynes manual, the gap is 0.031.
    According to automoile spare shops like, orielly, walmart etc, the gap is 0.042 for a 97Prizm and 0.032 for a 97 corolla.

    I am not sure which one is correct. Can someone help me here?

    If the walmart gaps are correct, then how come corolla and prizm have different settings if they are the same?

    Thank you
  • imadad2imadad2 Posts: 79
    Some plugs have a different gap than what the manufacturer instructs. Check with the auto parts store to see if that is the case. If not, your owners manual should have gap information in it. If that fails, I would go with the gap on the Haynes manual. That is the standard for the automotive industry. Unless the folks at the stores looked up the information on a computer, I would not believe their gap information. Good luck.
  • sunyvelsunyvel Posts: 2
    thanks for the reply. I bought the same NGK plugs specified in the manual (both user's and the haynes). the user'd manual does not does not have info about the gaps. the haynes manual shows 0.031. but the auto store computer shows 0.042 for prizm and 0.032 for corolla.
    My doubt here is whether the auto store database is wrong. This is because, if corolla and prizm are the same then they should have the same gaps. and 0.032for corolla is close to 0.031 from haynes.

    So I am a bit confused. :confuse:
Sign In or Register to comment.