Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet (Geo) Prizm

1404143454670

Comments

  • mt700a1mt700a1 Posts: 53
    Chapter 1, seciton 1-24, Figure 26.5b in Haynes manual shows the drain plug near the exhaust manifold. I believe that is on the front side of the engine. There may be a metal shield covering the exhaust manifold (because it get very hot).
  • kedrikkedrik Posts: 2
    Hey, all. I've got a '99 Prizm with 84k miles, and started having a problem yesterday.

    After driving for about 25 minutes, there begins to be what I consider a severe hesitation, rough idling, and reduced acceleration. The check engine light came on flashing once, but after I stopped the car to drop off my wife at work, looked around to see if I could see anything wrong under the hood, and started it up again, it was running fine and the light was off. I noticed the coolant recovery tank was low, so I put more in, but had the same problem this morning after dropping my wife off. So, to recap:

    After 25 minutes, rough idling, bad acceleration, rough idling. Turn car off five minutes, works fine for another 25. I have no idea, and since the "Check Engine" Light won't stay on, the OBD2 won't help, I don't think. Any help in figuring out what is happening would be appreciated.
  • patpat Posts: 10,421
    Hi kedrik - you may also want to post this in either our Got a Quick, Technical Question? discussion or the one we have on a "Check Engine" light since what's going on may not be specific to the Prizm. There are some very helpful and knowledgeable folks hanging out over there (the Maintenance and Repair board, that is).

    Good luck with it.
  • mt700a1mt700a1 Posts: 53
    Is the temp gauge working properly and showing normal coolant temperature? If the thermostat is stuck closed the car would overheat after a while and cause the sysmptoms you described. If it happens only in stop and go traffic the electric radiator fan may not be working. Check oil level also.
  • legomanlegoman Posts: 1
    Hi,

    I've inherited my wife's mint green 93 Prizm which now has almost 170K on it. It's been used almost exclusively for a 13K/year commute by me for the past two years. It had been running flawlessly until a few months ago it began to shudder at higher speeds while accerating (e.g. on ramps). I was about to take it in when I was swiped by a county bus. They took five weeks to tell me that the bus never hit me and I had stupidly waited for them to fix the bumper and still drove it with the shudder, now getting progressively worse. :sick:

    I took it in and the mechanic said they needed to replace both axle shafts, along with the necessary seals and boots for about $530. To make a very long story short, I kept getting leaks from the axle shafts and after the fourth time returning (and another replacement axle shaft), the mech said if it still leaks, it's gotta be the tranny.

    Yep, after a week, a small brownish/reddish puddle. I then took the Prizm to a tranny guy. After a horizonal head shake, he told me that even after replacing the tranny/differential and new seals (for a ballpark of $1800), they couldn't guarantee the seals wouldn't still leak. He said the Prizm/Corollas are great, but not the 3spd auto. He said they has just gone thru the same ordeal as me with another customer with no luck. He was also very helpful in showing me how to check the fluid level in the differential, which I'll probably need to live with until I can replace the car.

    I haven't seen anything like my story in this forum. Thoughts???

    Thanks,
    Rich
  • I was looking around on the web the other day and saw this product:

    Gauge

    It looked pretty neat, but then I checked the compatibility and I don't think it would work in my car. Plus it's $130.00. And since I have OBD-I, I don't think I'll get all of the functions. Is there any other product similar to this that would work in older cars (1993) and would be easy to install? I have a 1993 Geo Prizm LSi just in case you are wondering.

    Just to clarify I am NOT looking to save fuel. I just want a device that will give instantaneous MPG while driving. The connector on that device on that site looks different from the connector under my steering wheel unless I am looking at the wrong connector in my car. Is there any way that I can make sure of its compatibility with my car? I mean the compatibility listings only show as far back as 1994 and no Geo's at all.

    Thoughts?
  • rene01rene01 Posts: 12
    We have a 92 Geo Prizm. I was wondering if the altenator,a/c & power steering belts were easy to change? Also, when it's really hot outside, when we drive to town and shut the car off, sometimes it won't start again for 10-15 minutes. Could it be the ignition switch has gone bad? It has a brand new battery in it & it's been doing it for a couple of years now. It doesn't always do it, but it's often enough that we don't want to be stranded out in the heat. Any suggestions or ideas?
    Thanks, Rene'
  • Folks, I have a '97 Geo Prizm and it was broken into last night :cry:
    I need to replace the driver's seat window. I found one on Ebay
    from a guy who is selling a window from a '95 model.
    Do you know whether it will fit? Or, do you have any suggestion
    on where to find replacement parts?
  • iwantws6iwantws6 Posts: 26
    Hello everyone,
    A local dealer has a 90 Prizm hatchback for sale. The car has 168k miles, new cat-back exhaust and he is putting a new altenator on it (which is why I havent test driven it yet) I think it's a GSi but I'm not sure (14" tires and alloy wheels but I dont know if they're stock) the car has a few small rust spots, but nothing that's going through the body and there's a 30 garauntee on it, regardless of miles. He's asking $1,150 for it. Do you think that's a good deal? and what type of things should I watch out for with this car?

    Thanks!
  • rodallirodalli Posts: 1
    So I'm having some cooling problems with my '92 Prizm, which I've nailed down to corrosion\leaking of the cooling system. Apparently the previous owner wasn't taking good care of the car. Anyway, I want to drain the radiator, flush it out, and add some Bar's leak stop and whatnot. My problem is, I can't seem to get the drainplug OFF to perform this simple task. I believe I've located the correct drainplug(s), as there are two identical plugs on the left and right bottom sides of the radiator.

    The plugs both look like a + sign, set inside a circle, and seem to be made of plastic. I tried pliers, but immediately dropped that idea as it seemed to only be mangling the plastic. Is there a special tool or maneuver used to open this drain, or do I even have what I'm looking for?

    The worst part about this is that I cannot seem to find any documentation in the owner's manual or online about this procedure. Any help at all would be greatly appreciated.

    Thanks in advance,

    Michael
  • iwantws6iwantws6 Posts: 26
    Nova/Prizm engines have a drain cock on the side of the engine block, near the oil filter. This should be opened to aid in draining the cooling system completely. If for some reason the radiator drain cock can't be used, you can loosen and remove the lower radiator hose at its joint to the radiator.
    If the lower hose is to be used as the drain, loosen the clamp on the hose and slide it back so it's out of the way. Gently break the grip of the hose on its fitting by twisting or prying with a suitable tool. Do not exert too much force or you will damage the radiator fitting. As the hose loosens, you can expect a gush of fluid to come out — be ready.Remove the hose end from the radiator and direct the hose into the drain pan. You now have fluid running from both the hose and the radiator.
    WARNING
    Housepets and small animals are attracted to the odor and taste of engine coolant (antifreeze). It is a highly poisonous mixture of chemicals; special care must be taken to protect open containers and spillage.

    When the system stops draining, close both draincocks.
    In a bucket or similar large container, mix a 50/50 solution of antifreeze and water. Using a funnel, fill the radiator with this solution. Allow time for the fluid to run through the hoses and into the engine.
    Fill the radiator to just below the neck. With the radiator cap off, start the engine and let it idle; this will circulate the coolant and begin to eliminate air in the system. Top up the radiator as the level drops.
    When the level is reasonably stable, shut the engine off, and replace the radiator cap. Fill the expansion tank to a level halfway between the LOW and FULL lines and cap the expansion tank.
    Drive the car for 10 or 15 minutes; the temperature gauge should be fully within the normal operating range. It is helpful to set the heater to its hottest setting while driving — this circulates the coolant throughout the entire system and helps eliminate air bubbles.
    After the engine has cooled (2-3 hours), check the level in the radiator and the expansion tank, topping up as necessary.
  • rlindemanrlindeman Posts: 3
    Car doesn't run well when first started. If you hit the gas, it sputters like it's going to stall. If you let it run for a few minutes, it seems to run fine. Hooked up a code reader and found Engine code P0304, cylinder 4 misfire. Already replaced the spark plugs, didn't help. Should I replace the ignition coils next? Anything else to look for? :sick:
  • ufrichufrich Posts: 1
    There seems to be hesitation when accelerating and I lose speed going up tall bridges. It is a 95 Prizm with 230k miles and I have still been getting 33 - 35 mpg, but have seen a slight decrease in mpg since this problem started. Someone said put injector cleaner in the gas, another said change the fuel filter. Any help would be great.
  • prizonerprizoner Posts: 1
    no. unless it was a one owner w/extensive ie: complete maintenance history or you are an excellent mechanic, run.
    your original question really doesn't give enough specific info on car condition. btw how was the test drive?
  • hey guys!
    I own my mother's '94 geo prizm. she has 85,500 miles and I want to keep her going. I have no clue about cars I mean I just learned about the dip stick thingy the other day. Don't laugh. Someone please educate me I want to keep this car for another year or so if its possible. I do alot of highway driving by the way. I need to know what type of oil to keep in the car. I do get the oil changed often. how often should i change the fluids in my car? what fluids need to be changed? and with what kind of fluids? I just need to know the deal on my ride. thanks alot guys and you can stop laughing now...hehehe
  • geodrivergeodriver Posts: 1
    I was just wondering if anyone knew which years engines were interchangeable with the 1996 geo prism 1.6 liter. It has a lot of miles on it and the engine needs to be replaced, but I really love this car for the gas mileage, reliability, and most of all the turning radius. I found a guy who said he has a motor from a '90 being used for parts with 80,000 miles on it that he could put in as a replacement for a nice price. I've been looking around online and it seems to me that there are some differences. I haven't found anything searching this forum either. I've replaced things on my car myself before but I have no experience with something of this magnitude.

    Any thoughts would be appreciated.
  • crw7crw7 Posts: 5
    I have a 2002 Prizm. The day after I bought it, the "check engine" light came on for no apparent reason. The dealer said the fault code indicated an evap leak. They couldn't find anything, so they reset it and 1 week later, it came on again, also showing evap leak. This time they checked eveyrthing more thoroughly and tightened up all hoses, fittings, etc. One week later it was on again, so they looked and loked, got tech support from somewhere else and replaced a solenoid. Another week went by and now it's on again for a 4th time. I'm taking it back this Monday who knows what they'll come up with...

    It seems to drive fine, at least I haven't noticed anything that feels wrong in the little over a month that I've had it. But that light keeps coming on. And yes, I always tighten up the gas cap. And never fill up when the car's running. And if it was the O2 sensor (another frequent comment) wouldn't they have figured that out by now?

    Any guesses?
  • crw7crw7 Posts: 5
    OK, another question related to my Prizm, or Prizms in general. I've heard people comment that while the 4 speed automatics are good, the 3 speeds aren't. Other than the obvious difference in the transmissions, what is the big difference?
  • patpat Posts: 10,421
    Why don't you cross-post this in our "Check Engine" light discussion and see what those folks think.

    As for the 3-speed vs. 4-speed, the 4-speed will get better mileage. Perhaps others here have other thoughts on the subject.
  • mcdawggmcdawgg Posts: 1,667
    Also, the 4 speeds are quieter on the highway - reliability are the same. They are both Toyota.
Sign In or Register to comment.