Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet (Geo) Prizm

1525355575870

Comments

  • 2staffi2staffi Posts: 1
    :sick: I have a 1990 Prizm. I was wondering where I could find a good engine and what I could be looking to spend for it. I also was wondering if it would be possible to put a larger Geo engine in it. If anyone could help it would be great. I would love to keep this car on the road and need to do something fast or I will have to replace it.

    Jake
  • jlud82jlud82 Posts: 2
    Pierce7 Did you ever get to the bottom of this issue? i am having the exact same problem with my 95 prizm!! had the coil replaced but sputters between 2500-3500RPM. Any help would be appreciated....Josh :mad:
  • jlud82jlud82 Posts: 2
    My 95 prizm LSI was running great then started sputtering @ about 3000 RPM occasionally! It died one day and then the mech. put a new ignition coil in and it fired up! Now it sputters between 2500-3500 RPM unless you give it full throttle! Spark is good and fuel is good!!! What could it be????? Thanks Josh
  • mvftwmvftw Posts: 4
    I want to touch up my '97 Prizm with Green Mica (code 54). I have found some sites that carry it, but there is a bigger selection for the Corolla. One color sounds close, just like to know if there the same...
  • jad789jad789 Posts: 2
    The lady might have seen emissions coming from your tailpipe. Catalytic converter has to do with emissions.
  • 92geo92geo Posts: 3
    I have a 92 Prism with the exact same problem. These two lights are intermittently on, but the charging system is fine. Plus the brakes and alt are two separate system so I assumed it might be a short. Let me know if you discover the true cause.

    I have had an intermitent starting problem since November (went 7 months with no issue). When hot, it will sometimes not start. I'll add a separate post, but do you have this issue?
  • 92geo92geo Posts: 3
    Sometimes my starter will not crank when hot. When it first happened at thanksgiving, I tapped the started and it cranked. I replaced the started. No problems again until May. Same probblem when hot. After sitting, it will always start.

    I replaced the started again. This time it went 3 weeks and started the same problem. The solenoid is on the starter so it has been replaced twice. Also I noted in the maintenace papers that the prior owners had also replaced the starter a year ago. I also replaced the battery a week ago. No impact on problem.

    I loosened the starter to be sure it was in place and retighten. I looked ath the battery cable connection at the startedr and it was tight and looked fine. I know this is a common problem so hopefully someone has the answer.

    BTW: My son's girlfriend has the Toyota version of this (91 andd auto transmission though) but is having the same problem. Replaced the starter and after a few months had the same problem. All starters came from Advance Auto.
  • mvftwmvftw Posts: 4
    Does anybody know if the '97 Prizm & Corolla share the same front ABS sensor? I know the part numbers are different, but the difference could be the mounting hardware. The sensor and connector may be the same...
  • alpineralpiner Posts: 8
    My God....3000RPM, I didn't think the runts could turn that fast! Fuel filter?..... plugs often misfire at hi RPM.
  • alpineralpiner Posts: 8
    My 93 did the same thing until I broke down and removed it and put a heavier set of contacts in the solenoid. I couldn't believe how thin the off the shelf contacts were.
    What if your key switch has bad contacts and is not even switching on the starter solenoid/relay?
  • i am looking to buy my friend's early 90s geo prizm with 23000 original miles. he is giving me the car for $350 (three hundred fifty bucks). there is but one problem with the car but i dont see it as much as a problem since the car is a steal. the car doesnt go in reverse. he said that i can either get a used tranny or a pin that costs 50 bucks. i want to know if it is worth it and has anyone had the same/similar problem and what needs to be done to fix it.

    keywords: chevrolet, chevy, geo, prizm, toyota, corolla.
  • 92geo92geo Posts: 3
    Thanks. Can I buy heavier contacts at a parts store like NAPA? I replaced the started again about a week ago. For the moment , the problem has gone away, like it has done in the past with a starter replacement. I expect within a few weeks to a few months it will return.

    I think the key switch contacts are fine. With the switch on start, the dash dims. If I release the clutch it brightens. So I can get the same response as the keyt switch by releasing and engaging the clutch with the key in start.
  • gus711gus711 Posts: 2
    My 1995 Geo Prizm has 228K miles and still runs great. I'm having parting pains since I plan to get a 2008 Toyota Corolla soon. Yet, I still think that I want to keep the Prizm for a few more months (or years)...

    Has anyone driven a Prizm for 300K miles or more? Maybe an affirmative answer is what I need to hang onto my old friend!
  • califgeocalifgeo Posts: 1
    My fan is working intermittently and so far the mechanics haven't been able to fix it. The first one replaced a hose. The next one replaced the radiator. The third one finally listened to me and agreed the overheating problem is the fan. While they were working on finding out why the fan wouldn't come on it suddenly came on and they didn't know why. It worked fine for a few days and I got the relay replaced on it to see if that was the problem. It worked fine for another few days and now the fan isn't coming on again. I guess the next part I'll replace is the switch. Any ideas what could be causing the problem or which part to replace next?
  • schweikbschweikb Posts: 111
    I am loking at a 2002 Prizm base model w/stcik - does the engine have a timing chain (I hope :) ) or a belt (I hope not :cry: )? Thanks for any input.
  • Crayla,
    Did you ever get this problem completely resolved? I just bought a 95 Prizm with 90K miles with the same problem. I took it to a mechanic and he couldn't find the problem. He suggested I take it to a muffler shop and have them check the exhaust lines for any blockage as the problem only starts when the car is warmed up. He also suggested me having the fuel pressure checked. Any advised would be appreciated.
    Thanks.
  • Ihave a 93 geo prizm with 75k. when i start it in the morning it puffs smoke for about 30sec then stops? It also makes a ticking noise that is pretty loud at startup then quiets down as it warms up....any ideas???
  • My 90 is at 298K & counting.
  • Wire fan directly to the battery. If it still stops & starts replace the fan motor. If in runs fine. It is in the wiring. It could be a therimal switch.
Sign In or Register to comment.