Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Saturn S-Series

1313234363769

Comments

  • dhanleydhanley Posts: 1,531
    I took the doors of my SL2 apart to install speakers. I would NOT advise that anyone do this unless you already know how. If a part inside the door broke, i would smile and have the dealer do it. It's very hard to access much of the inside mechanics, and it's also hard to reassemble it properly.

    dave
  • floridianfloridian Posts: 219
    Tinker-toy door pieces parts. So much for LOW cost of ownership eh ?

    Floridian
  • 93saturnsl193saturnsl1 Posts: 27
    Does anyone know what would make my Saturn ping? It did it around 88k due to a bad coolant temp. sensor, which I replaced. Its started doing it again, and that sensor is OK. I know I could use premium gas, but I'd rather fix the problem than just cover it up with that. It's a '93 SL1 with 166,000 on the odo, and still runs great except for the pinging, and I still get about 35mpg in the city leadfooting it with some a/c use. Thanks for any info!!
  • floridianfloridian Posts: 219
    93saturnsl1: My 1998 has begun to do that too. Since it's goung back to the lessor (good riddence)I don't plan to do anything about it tho. From past experience it is most likely a bad EGR valve. Not real expensive to fix tho.

    Floridian
  • lvbearamlvbearam Posts: 3
    So,I bought myself a Saturn (and so far, no buyers remorse)!
    I owned a 1993 Ford Escort that has done well for me for the past five years, with nearly 100 thousand miles on the clock. I was going to keep it a while longer, but the automatic seat belt system broke on the drivers side, leaving me without a shoulder belt. I was given an estimate of 500 dollars to fix it! Forget it, I thought. It was time to buy a new car. I was going to buy a Ford Focus, but the Ford dealer didn't seem to want to deal with me (their loss). I checked out the competition--Civic, Corolla, Prism, Protege and Sentra. OK, but a bit on the boring side for me. On the way home, I decided to stop by my local Saturn dealer. Two hours later (with little BS), I drove away in a 2000 SL1 and got 25-hundred dollars for my Escort. I love the car; it's quiet (though a bit noisy when revved up); handles well (it has larger tires and wheels) and is comfortable. The car was owned by a couple who traded it in after 12-thousand miles for the larger L series. (It still has the balance of the factory warranty; I was pushed into buying an extended warranty but I've decided to wait for now.)
    I will check back in the months and (hopefully) years to come to let you know about the "Saturn Experience". One thing I was very pleased about: My new car will cost the same to insure as my old Escort did, thanks to its safety features. Believe me, peace of mind lets me sleep a little better as I make those payments for the next five years!
  • lnd1403lnd1403 Posts: 1
    I am going tomorrow to buy a 2001 SC1 coupe and I wanted to get some feed back has anyone purchased a 2001 and what do you think. What was you finally price and did you get the optional package on there?
  • dhanleydhanley Posts: 1,531
    Can be due to carbon build-up in the pistons.

    Supposedly the best additive is techron. Chevron markets it and pits it in their gas, though i don't know how much. I use chevron gas, and i have never had carbon build-up.

    Revign the engine high blows ther carbon out as well. As a frequent visitor to mr. redline, that's likely another reason i never have carbon build up. ;)

    dave
  • Congrats on your SL1. I have a 94 SL2 with 105 on it and it runs like new, the ride is a little harsh but it is a compact car. Don't bother with the extended warranty. For the money (what a grand or more) it is not worth it just to extend the warranty for another two years. Just absolutley change the oil/filter every 3k miles and your Saturn will run for a very long time.
  • salismansalisman Posts: 2
    I own a 93 Saturn SL1 that was bought new. It only has 60,000 miles on it and it still runs fine. Sure it doesn't have much power, but you know what, it's an inexpensive compact car. I've read so many posts by people complaining about how cheap it's made, how flimsy it is... please give me a break! If you wanted a top-line, no-problem vehicle, it doesn't exist. As for orangelebaron, you really shouldn't have taken apart your car. Just because you've had experience doing it on other vehicles, they are not all alike. Now you want to sell a car you messed up. Funny. For those of you thinking about a Saturn, I say do it. It may no be the absolute best vehicle out there, but for the money and service, you can't go wrong with Saturn... just my two cents :-)
  • Only 60K on a '93?? Mine just flipped 168,000 on a road trip the other day, and still running like new. I played leap frog with a new Focus on the interstate, steadily running between 95 and 98 mph for about 30 minutes with the a/c on.. and still managed to get 37.2 mpg when I filled up. I just replaced the EGR valve, which was making it ping.....thanks floridian. I always thought it was bad, but it's a heck of a lot harder to get to on the SOHC vs the DOHC... and more expensive also. This car still never ceases to amaze me; its been more reliable than some of my friends' '99 and 2000 vehicles.
  • danili16danili16 Posts: 3
    Hey everyone,

    I recently purchased a '96 Saturn SL2, 5-speed, 66,000 miles. I've heard very mixed reviews on it- especially that model year (being the first year of the redesign). I've noticed a few problems so far, and other saturn owners seem to have had the same ones over and over again, so I was wondering if anyone could diagnose exactly what's going on.

    1) from the day I got it, the idle has been rough. It idles normally at 700-800rpm, and the idle doesn't waver at all. However, when at a stop in Neutral when the car has been driven for 10 minutes or more, (especially rested on an incline), the engine seems to "sputter." It has never died, and the RPM's have never dropped significantly, but it shakes pretty badly every few seconds. It may be unrelated, but every so often, I lose quite a bit of power in the upper rev's, and basically all the time there's no power under 5,0000...I have had the plugs and wires replaced (bosch platinum +4)

    2) I think it's the heat shield, but whenever the engine vibrates (when you first rev the engine for acceleration or after you let off the gas and the idle returns to normal) significantly, there is a metallic "clanging" sound. I hope it's not the motor mounts...

    3) When coasting to a stop, only with the windows shut and the car silent, there is an intermittent "scraping" noise coming from the front left wheel well that speeds up/slows down with the speed of the car.

    4) I've heard these cars are naturally loud, but this is not normal...The exhaust has been replaced from the catalytic converter back, and there are no holes in the head pipe---yet especially when at idle, it sounds like there's a hole in it. Could it be the mounts or is this just a normal thing? I heard they improved noise for '97...

    5) Whenever I go over an uneven or ridged spot in the road when cornering at over literally 5mph, the car seems to lose control and "jump". Is this normal, or are my rear shocks gone?

    and finally,
    6) The brakes have a HORRIBLE shudder when braking from over 50mph...My friend has the exact same problem in his '93 SL2, as does my other friend in his '94 SC1...The front pads and rotors were just replaced. Is this normal?

    If anyone could answer any or all of these questions, I would really appreciate it. Thanks!!
    -Dan
    Dabuxba@ilstu.edu
  • dhanleydhanley Posts: 1,531
    I had almsot the exact saem car ( mine was an automatic )

    You definitely have warped brake rotors.. Happened to me twice, and i'm easy on brakes.

    Sounds to me like the engine mounts are bad.. Normal because the engine vibrates so much.

    I'd suggest fixing those, then seeing which other problems persist.

    dave
  • I think the 1st problem listed could be the EGR valve. They're pretty notorious for going out in Saturns. It went out in our '95 SL2 at about 50k. It all of a sudden lost power going up a hill, and idled pretty rough until we got it replaced. The 3rd problem is probably the wheel bearing, which also seems notorious for going out. Mine has never gone out, but it did on a friend's '92 SL1 with about 155k on it. It was so bad it sounded like a train....they let it go way too long. And lastly it does sound like the rotors need to be turned, that's usually the 1st culprit when there's shuddering from high speed braking.
  • soggydogsoggydog Posts: 67
    I have the same problem with my 96 SL2 with only 45K. It is the right rear wheel bearing. I jacked the car up so I could spin the tires by hand, I could hear the same noise and it does not spin as freely as the the Lt side. Just to make sure it wasn't the brakes dragging, I took off the brake drum, same thing.
    The bearing is pressed in and you have to change the spindle assy. I called saturn, they said $130. for the part and about $70. labor. He also said it is common problem, in fact on that day they had already replaced two spindles. Don't know if the spindle is available from other parts stores.
    I live about 50 miles from the dealership, It's such a hassle to make an appointment, take time off work, take the car in and then go back and pick it up. I'm going to see if I can have it replaced locally.
  • floridianfloridian Posts: 219
    soggydog:I have a 1998 SC2 that is about to go off lease. It has been a good, altho dull, ho-hum ride (for me anyway)and I won't miss it.

    I too live about 50 miles from the dealer. I have found that except for routine maintenance most local shops don't like to work on Saturns. They all say parts are too hard to come by and the cars themselves are "different"?? and they just would rather not 'fool' with them. Go figure.

    Floridian
  • ochsskochssk Posts: 52
    The automatic sifter on our '95 SL2 is sticking. When the car has not been driven for a couple hours, it is very difficult to press the button to enable the sifter to shift out of park. Our mechanic has checked the solenoid and could find nothing wrong. He applied some grease to the linkages which helped for a short time but it's getting bad again. Although we've never been stuck, my wife has been worried on several occasions. Usually if we jiggle the sifter (sometimes violently) the button will engage, and yes we are pressing on the brake pedal. Anyone experience this problem or have ideas?
  • afk_xafk_x Posts: 393
    Geez if you are going to post the opinion of one mechanic you have talked to you should advertise it as such.

    Many mechanics LIKE Saturns because they are easy to work on, and the parts are easy and cheap to get. In fact I have had several mechanics send in customers to get Saturns -

    Of course I'm sure there are mechanics out there who don't like Saturns....
  • floridianfloridian Posts: 219
    afk x: Well, I have a couple of very trusted mechanics here in my town that do the major part of the work on our fleet cars.Between them they have approx 20 ASC rated technicians on staff. It isn't that they don't like Saturns. It seems that what they object to is that there is so much exclusive parts content in them that they have to order a lot of stuff "special". Especially the transmissins. That tranny is not used on any other GM car. They have serviced all makes and models over the years for us and we trust them to the 'nth degree.

    It's a moot point anyway as far as I'm concerned as the SC2 is going back to "lease end heaven" in a few weeks and I'll not have to worry about it anymore.

    That 1998 SC2, loaded, original sticker almost 20K can be bought from Chase Finance for just a snick over 8K. WOW, some resale eh LOL.

    Regards, Floridian
  • soggydogsoggydog Posts: 67
    I called around to local parts stores today for the rear wheel bearing / hub assy. Auto Zone said it was a dealer only item. another store wanted $90. and the last one said $61.55, special order. I have one on order and will replace it myself.

    floridian: For someone who don't think much of saturn, you sure hang out here alot. Didn't you mention before about your company's fleet cars being the ford focus? Did you see the recent results of the 5mph crash test. cost about $2,500 to repair.

    You are right about the parts though. I tried to get the local chevy dealer to get filters for me but they said no can do. Come on GM, work with us. Another example is the alternator. I deal with a local alternator rebuild shop who has been able to repair just about any alternator including made in france stuff, however when I asked about the saturn alternator he said he just could not get the parts. That was two years ago, don't know if it,s still the same.

    A good reason why local shops don't care for working on saturn's may be that with exclusive parts, they can't make as much money on mark-up.
  • I am looking at a 98 SL1. The dealer let me take it home overnight. It has 29,000 miles, and is out of factory warranty by 2 months (it was bought in April 98). But I have noticed a possible problem. When I get it up to about 75mph it starts a slight occilating vibration. Like a wa wa sound. This only happens in 5th gear, and stops if I downshift to fourth or push in the clutch. Again it is slight I have to turn off the radio and fan to hear it. Any possible solutions or similar experiences will be greatly appreciated. I have not bought it yet, so I am trying to see if this a problem first.
Sign In or Register to comment.