Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Saturn S-Series

1565759616269

Comments

  • im wanting to turbo my sc2 and have already got a used turbo off of a friend that just wrecked his 92 dodge daytona. i found an intercooler off of a 92 toyota supra. and can't afford not to put it on too. im trying to figure out where and what needs to be done im firmiluar with turbos i have replaced the turbo on my 99 eclipse with no problem but it was just a bolt on thing. i have been told that i won't have to worry about the fuel part of it. my fuel injectors should be good up to 15 lbs. the only thing that i have done to the engine so far is intake and full exhaust minus replacing the stock manifold. i was also told that the dohc will be able to handle about 9-13 psi without any mods to the valve train or pistons.
    any and all help would be appreciated.
  • patpat Posts: 10,421
    You might also want to check out our Speed Shop: Tuning & Modification board.
  • Just bought a 98 Saturn SL1 with 99k, clean inside and out. after 1 month I smell coolent inside the car with no leaks showing inside the engine compartment or outside the car. Any suggestions? All fluids are level. Is this a sign of a small leak? Also, if so, where the heck could it be? and why does'nt it show?
  • I have a 1995 Saturn, DOHC, 5 speed with 125k miles. The vehicle overheated near the end of a 1,000 mile trip. Found a water leak from the water pump---Replaced It! Great Fun!!! Still...the vehicle overheats...Replaced engine thermostat.
    Still...the vehicle overheats.
    Marked and observed the radiator cooling fan function (or not) in a controlled "overheating" condition. THE FAN NEVER CAME ON.
    Then...I replaced the coolant fan swith/sensor on the side of the engine block under the plug wires. Still....the vehicle overheats. ONLY THIS TIME...the temp gauge indicator on the dash shows no active registration of the thermal state of the engine...zip...still...no cooling fan ON and the vehicle overheats.

    Help....Help...Help!

    signed:
    an "overheated" Saturn owner
  • after my dismal and very mediocre experience of driving my new "1 previous owner 80k mi." 97 SC-2 i suppose it shouldn't surprise me that this board seems to be the online equivalent...but seriously, this forum should just be deleted if there's no one here to help with ANYONE's questions (at least not anymore.) i know, i know, why aren't I helping...quite simply, i've never even owned an american car and my Haynes manual is still on order. i hate to say it but after riding in my dad's little 98 accord coupe (that's 1 year difference) and even my old 97 civic, it hardly surprises me that GM is doing so poorly. yes, i'm whining but it's not like i'm getting in the way of some answers for all these questions being posted...
  • patpat Posts: 10,421
    We're not going to delete this discussion. :)

    You might have a look at our Maintenance & Repair board - there may be a discussion there which will help you. I hope so and do keep us posted here. That will help others.
  • My daughter has a 99 SC 2 and it just started making a loud noise when she puts it in reverse and I haven't been able to find out what it could be. if it was rear wheel drive I would suspect bad u-joints, but have no idea on front wheel drive... could cv joints cause it? any help would be appreciated..
  • if it's a manual, it could be because she didn't fully engage reverse. cv joints would be the problem only if they made a clicking noise when she was turning. i would think the problem to be brakes or bearings.
  • i have a 2001 sc2 three door coupe. I bought it off a friend a year ago. I drove this car quite a bit before i bought it and loved it. 40 miles/gal and fun to drive Since I have owned it the air conditioner, key assem, sun roof broke and it has started eating passenger side wheel bearings to the tune of one a month or so. I have had new bearings and used hubs put in. My next step is a new hub also although I can't beleive that three hubs had something wrong with them Have a good mechanic and i watched him put the last set in. Does things right so i am not concerned with him, i.e. pressing on the bearing and not the race. Any suggestions? Saturn dealer has no info, mechanic is at a loss as am I.
  • :confuse: Hey, i have a 01 SL2 and i have had for two years now, wondeful car no complaints until now. My rear end of my car is making tons of noise, like creaking sound, its loud to, can't really ignore this sound. It isn't a banging but its more noticable in stop start situations. I was wondering if anyone has had this problem and if they have any ideas on what i can do to fix it.
  • boatman2boatman2 Posts: 1
    I also have a 96 SL with a cracked head. I heard there was an extended warranty or TSB associated with this. Anyone have any info on:

    99-P-01 JAN 05
    Campaign Cylinder Head Cracking/Warranty Extension
  • :sick: i am having trouble with my Saturn SL-1 1995 model.
    It stalls at intersections or when you have to slow down to turn actually when it drops down under 1000 rpm's.The service engine soon light comes on right before the car starts to act up..we have had it put on a computer check and it said the EGR valve but we would like to know if there could be something else that could be giving us problems...the car also revs up to almost 5000 RPM' on it own sometimes. :(
  • oreouckyoreoucky Posts: 1
    Ok i have a 2002 sl1 with 28000 miles on it and the other day out of know where my ac doesnt blow cold air so that could be in the need for some freon or it could be related to the second problem about two days later all of a sudden my emergency light comes on and gas gauge goes all weird and is usually at empty but sometime at other spots also my temperature gauge is only reading zero and it seems to bounce along with that the lights on the ac button and rear defroster doesnt work...so my question is is this a huge electrical problem or just a simple fuse problem...any help would be extremly greatful as i am a poor college kid and i am trying not to spend to much money...oterwise i love the car and have had other saturns in the family that are still running with over 120k
  • Symptom: Throddle hesitation on accelerations once driven enough for the engine to reach normal engine running tempature. Afterwhich I have to pump accellerator to overcome hesitation typically at every light, or place the car in neutral while slightly reving to maintain an idle
    state. Also if I turn the car off and attempt to turn it back on it has a hard time achieving an idle state with out some major pumping of the accellerator to get it to a point where the car can be safely shifted into the automatic gear needed.

    **Now heres what I got from my local Saturn dealer**

    Today I picked up my 1992 LKO 1.9LL4 Saturn SL1 Sedan from my local Saturn dealer and was told it seems my problem is the Fuel Presure Regulator. Great to know ... now for the bad part they (Saturn) no longer carry the part and know of no third party mfg. that makes it.

    So here's what I'm thinking: One I posted this message to see if anyone has any recommendations and secondly I figured possibly start looking at auto salvage places.

    Well thats my delema... Any better ideas are welcomed...

    Oh, and can some one describe where the Fuel Presure Regulator is located on this car... I just want to be sure of what I am looking for when I start my Salvage hunting...

    Thank you much folks...

    Pat thanks for the heads up for the need to repost this message...

    -Charlie
  • nsdemitnsdemit Posts: 1
    my roomates chrysler did something very similar. it checked all the fuses (there may be two or three different fuse boxes), but found that it was a bad connection at the battery terminal. it got corroded with a green oxidized coating. the green stuff doesn't conduct electricity.

    hope that helps.
  • I own a 99 Saturn SC2 and I LOVE it! Any ways, about a month ago I was driving when I heard this noise that only lasted a few seconds and stopped. It happened a few times after that, so I thought it was the brakes, (thats what it reminds me of). So I took my car to the shop and they laughed and said "ma'am, your brakes are brand new all around." I described the noise and they wrote it off telling me that sometimes brake dust causes cars to do that and not to worry. Well, I didn't hear that noise again until a few days ago when it was really warm out. It was loud and continuous and squealed louder when I applied the brakes. The next day it was cool outside and it didn't make a sound! I am soooo confused! has anyone experienced this before?? What is it??
  • Ok here is the thing.....My service engine light came on. Got the oil changed, it went off. Then it came back on and did not go off. This is when all the problems started. First it started jerking while we were driving. Thought it need injector cleaner. Helped a little. Then the jerking go worse. Thought the oil was low. It was, but only by a quart. Put that in, did not help. Jerking continued to get worse. Then the acceleration slowed down. The car did not want to accelerate. Once we got passed 40 it was fine. Still a little jerky but fine. Now, I can not accelerate past 25mph, it dies unless I keep my foot on the gas. The gas mileage is beyond horrible and I can barley go in reverse. The exhaust makes a muffle sound and it smells like fuel when the car is running. Oh to top it all of, this has all happened within a 2 week period. Oh yeah, we took it to get a diagnostic test run, they said egr valve or oxegyn sensor. Cleaned the egr valve...NO HELP. Please can someone help me. We are financially strapped right now, so we can not afford to take it to a "lovely" saturn dealership and be dicked around. If we just knew what we wrong we could fix it our self. Or our friend could fix it.
  • patpat Posts: 10,421
    Hi - welcome. While you are waiting to hear from some Saturn folks here, you might also want to post this in the Got a Quick, Technical Question? discussion. There are some gearheads hanging out there who may have suggestions.

    Good luck - hope we can help.
  • dolfdolf Posts: 1
    I HAVE A NOISE COMING FROM THE FRONTEND LIKE I HAVE HEAVY DUTY WINTER TIRES ON. (AT ALL SPEEDS) CV OR WHEEL BEARING?I JUST HAD THE ENGINE REPLACED 3 WEEKS AGO, TURNED THE RADIO OFF THE OTHER DAY AND NOTICED THE NOISE.
  • My 1992 1.9 Saturn SL1 (throttle body version) is encountering acceleration hesitation problems. It happens every time when I step on the accelerator to gain
    High speed it start to accelerate in a jerking fashion so I have to pump the gas as I encounter this to over come the jerking. Once underway at high speeds it does not happen but if I come to a full stop it will reoccur when I take off again.

    I’ve changed the following items: ERG valve, oxygen sensor, and FPR.

    But the problem continues… Any recommendation will come in handy.

    -Charlie
Sign In or Register to comment.