Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda 626

16162636466

Comments

  • chuck1chuck1 Posts: 1,405
    Thanks for the correction. I still believe someone on a budget should steer clear of a turbo.

    If has a turbo...there is an increased possibility that the car was driven hard and should not be purchased as a used car by someone on a budget.
  • p100p100 Posts: 1,116
    I am 4k miles away from the 200k mark on mine.
  • crvexl2008crvexl2008 Posts: 15
    I may be one of only a few hundred left but I am wondering if there is a unique forum for 1988-1992 Mazda 626 owners?
  • I've got a 99 - 626 - V6. Bought it new in 99. It's had all the maint. kept up ... maybe not by Mazda's schedule but I have a pretty good plan I use for all of our cars. I could have been a poster child for the 626 until about 90,000 miles then the problems started. It needed a new clutch. Ok, no big deal ... would have liked more than 90K ... but far from bad. It's now had 4 more clutches put in. You can count on it starting to shimmy when pulling away from a stop by the time it's got 8000 miles on a clutch. I'm not driving it any different. The dealer says they are using oem parts, turning the fly wheel, basically doing it right ... yet always a problem in 8K (+/-) miles. They've worked with me on it ... even paid for total replacement themselves a couple times ... that's all well and fine but it's a drag at this point. Anyone else have this type of issue?
    Second issue: At about 120,000 miles, right after replacing the front axles (for the first time) it developed a vibration mostly in second gear, under the pressure of acceleration. Again the dealership helped out by trying not one, but 3 more sets of axles .. all from different auto parts stores ... all had the vibration. What the heck happened I asked them ... I brought it in with one CV clicking but NO VIBRATION what so ever ... not I have new axles and a vibration. Honestly, seems to be getting worse the more we drive (130,000 on it now). Perhaps a trannie issue ... but this one came in out of the left field. Ready to rid myself of this headache ... really sad ... I praised that car up to 90K ... now I rarely have anything good to say about Mazda's. I've contacted many people on this, taken it to other repair shops ... everyone feels it, everyone is stumped.
  • I just completed a complete rebuild on my CD4E tranny. When I started the car and ran it through the gears everything was great. After I killed the car and then started it again the HOLD light stared blinking and the car wouldn't move in reverse. It will in Drive. I got in it this morning and put it in reverse and it'll move, but the HOLD light starts blinking again. What's going on with it? I rebuilt it step by step by the book. I also added a shift kit to reduce the pressure build up in the valve body. Any suggestions would be appreciated.
  • Hi I am currently reinstalling a reco engine into my mazda 626 98 and cannot work out which bolts go where on the engine mounts, some have torque rubbers on them, can anyone help?
  • dunin3dunin3 Posts: 2
    I have a great 1999 Mazda 626ES V6. Yesterday the guys servicing my car told me that I needed a new cap on my coolant system because it was "missing the lower part". I just figured that they were trying to sell me a part so I said I'd fix it later. I bought a a new cap at the auto store. The new cap has a lift up release tab and a lower pressure seal. I opened the hood and realized there were two (2) coolant caps.

    The problem is that they look like they have been switched, and the one on the engine will NOT come out. It will loosen, but not pull out. The spring loaded yellow lable cap is now on the engine and the red lable flat bottom cap is on the coolant reservoir. My diagram says that is reversed, so they must be switched.

    Is all that right? How do I get the stuck cap off? Does the loose cap make the coolant evaporate? Which cap really belongs where? Thanks for your help.
  • dunin3dunin3 Posts: 2
    I figured it out myself thanks. pushed down harder.
  • Can anyone tell me what they did to fix the reason for the transmission slipping from second to third only everything else works perfect
  • backybacky Twin CitiesPosts: 18,732
    Just got over 102k on my 2000 ES. Took it in today for an oil change. Had a $75 Mazda gift card (a customer service gesture from Mazda when I complained about having to replace the PVC hose again on my MPV, which I dumped shortly thereafter), and I had to use it all at once. So I thought, heck, change the air filter too--can't hurt. Those plus some touchup paint cost me $0.29. :)

    The car is a little over 8 years old because it was originally put into service in December 2000. I've owned it for a little over 3 years, only put 18k on it in that time. Car still runs very well. Engine is gruff, but the car is tight, no rattles, still handles well, leather interior is holding up well, and no rust yet (pretty good for being through 9 Minnesota winters).

    I haven't had to do much to it. Added a tranny cooler right off the start ($200), but that solved a balky transmission. Also had to replace some rear bushings because of a clunky noise, and the driver's power window regulator. Put a couple of new tires on last year also--one was punctured and kept losing air. That's about it except normal maintenance. My son rear-ended someone nearly 3 years ago, over $4000 in damage including the airbags, but he only got a scratch on his arm--and a greater appreciation for maintaining safe distance behind other cars based on conditions.

    I am hoping the car holds up without major work needed for a couple more years, until my son finishes school. So far, so good.
  • igachooigachoo Posts: 1
    Has anyone ever had the front bearings replaced on a 94 626 with a standard transmission? I think that I can do the job myself though I understand some special tools are required. I suspect the bearings because the car makes a noise like a giant impatiently drumming his fingers on a table whenever the steering is thrown over to the right or to the left. also, my engine check lite comes on from time to time; can anyone suggest where to buy the diagnostic tool necessary to check the sensors? thanks very much.
  • mikeg14mikeg14 Posts: 2
    Can anyone tell me what this is for (O/D Flashing)and can i continue to drive it like this?
    Any help would be great....
    thanks
    MIKE G.
  • You've got an anomaly which affects the transmission: it could be the trans itself, or it could be an electrical gizmo that's sending it bad data.
  • mikeg14mikeg14 Posts: 2
    THANKS.....I'M TAKING IT IN TOMORROW.......JUST HAD THE TRANNY REPLACED (USED ONE) IN JAN. 09
  • a93626a93626 Posts: 1
    Hi:

    I recently had a front wheel bearing replaced on my 93 626 ES. The noise I had was an annoying "humming" sound which oscillated slowly when the car was driven above 80 kph. Based on your description of the sound, it's more likely that it's a drive shaft (CV joint) issue. When the steering wheel is turned, the car is driven at SLOW speeds (it's easiest to hear when the car is driven slowly) there is a loud, almost knocking or clicking sound. This is a CV joint problem.

    Crawl under your car, check to see if the CV boots are torn. If so, then there's a high probability that the joints are gone. When the boots are torn, the grease is thrown out and sand/grit get into the joints destroying them. Replace the entire drive shaft; it's way easier.

    As for diagnosing the trouble codes, use a 12 volt LED test light (a test light with an incandescent bulb should work too but not sure if the "load" will be too high), put one side to ground and probe the terminals in the diagnostic (black) plug near the driver's side shock tower. Use the link below to get the codes, the associated faults and the diagnostic plug configuration. The mx-6 and 626's use the same fault codes.

    http://homepage.ntlworld.com/mx6-uk/maint/maint.htm#malfcode
  • I have had this mazda for a few months now. I bought it was a blown motor and bought another mazda wrecked and swapped motors. Has had normal issues with a motor swap like always, and have been fixed. I now have a problem me and my boss can't figure out. We are both mechanics but this is our first mazda issue like this. It runs great until it gets to operating temp. and then its rough all the time. Chugs, rough idle, and just won't stop acting up. Only when its cold it runs good, but as soon as it even starts to heat up, its on from there. Any help?
  • I have a 1992 626. My drivers headlight assembly was damaged in a small accident. Any idea on how much it'll cost to replace?
  • mazda626atxmazda626atx Posts: 227
    Well Guys and Gals its been a while since I have had any problems and posted in this forum. Well I am back

    The master switch at drivers door does absolutely nothing for any window, including drivers!
    The remaining 3 passenger windows operate properly from each individual switch.

    The only odd thing is when trying to lower any of the three passenger windows from its own switch, attempting to raise it from the drivers door master switch at the same exact time, blocks it from going down. So therefore I assume some current is being sent to the passenger window motors, which either blocks it creates a Mexican Standoff?

    Attemping to raise any of the passenger windows from its own switch is not blocked by trying to lower it from the drivers master switch. I have checked fuses in floor panel and moved the locking switch from locked to unlocked many times.

    I disconnected battery and depressed brake pedal fo 5 seconds to clear any codes etc., in an attempt to reset circuit breakers

    My wife said this happened to her once before and it came back to proper operation by itself.
  • e44e44 Posts: 10
    Looking for the installation instructions for the rear speakers on my '02 626. I assume that the rear seat sides have to be removed, then the deck under the rear window.

    Car is running great! As always, I keep it well maintained, in the past year having no major issues.

    However next month, I have to upgrade the suspension. Roads in Montreal are war-zone caliber, and with 170 000 km on the clock, the shocks and springs are to be replaced, or else the rest of the suspension components will deteriorate at a faster rate..

    The best thing about the car is the 5-speed with the 2.0 L, the engine pulls very strongly.
  • did you ever notice a gas smell like it was'nt burning completely on your 626? i seem to be getting the same code but i have'nt started running down the o2 sensors yet. what was your results after fixing?
  • p100p100 Posts: 1,116
    I still have the car which I bought new, drive it daily, have almost 240k miles on it now. No rust yet, the original paint still shines nice. I still have the original struts, axles(CV boots have been replaced), and all four original brake rotors (never been turned and are still good). No electrical problems whatsoever with the car, replaced the A/C compressor at 130k miles due to failed clutch bearing, new radiator and shifter bushings at 215k miles, new clutch at 230k miles, new front wheel bearings and engine mounts at 239k miles. The engine still runs strong and idles very smooth. I change the timing belt and water pump every 100k miles, and replace the plug wires and spark plugs every 60k miles. Still on the original ignition coil. I am on the third timing belt and third set of brake pads. I removed the intake manifold at 139k miles to clean the EGR passages from accumulated carbon. I am coming up on the 80th oil change. Every 3k miles, 10w30Castrol GTX dino oil, Mazda oil filters only. I wonder how long this car will last. The interior looks great, leather seats are holding up great, even the power antenna still works. The original Bose stereo with CD and cassette, and speakers still work great. No water leaks ever, the sunroof works perfectly. The car is still accident free.
  • I traded my '2000 Es/V6 equipped like yours at 100K. Wish I would have kept it. Although my '07 Accord EX-L 4 cylinder with 62K on it has been trouble free.

    I am in sales and now drive about 31K a year!
  • It happens when the level of your coolant gets low. Check your coolant system right away, because it might have a leak. I just had that problem the other day on a Mazda 626 lx 1996 and had to replace a hose, water pump and timing belt - quite expensive...
  • I'm trying to replace the tail light bulbs of a mazda 626.
    I removed the plastic trim piece the covers under the lower interior trunk rim and part of each tailight section.
    I also used a screwdriver to pry loose the rubber gasket that protects the hole in the sheet metal leading to the bulb and socket.
    I loosened the gray socket with the bulb but it won't fit through the hole in the sheet metal so I can pull it out and change the bulb.
    I would appreciate some advice.
    Thanks
  • harle11harle11 Posts: 1
    I have an engine knock on a 96 Mazda 626 4 cyl 5 spd 170k mi. Can't afford another car or engine right now. Any ideas? Thanks

    Symptoms:
    - Knock seems to start suddenly, seems just after I went over a road bump at around 35 mph.
    - Start: knock is pretty loud for a few seconds
    - Idle: knock is more like a tick
    - Gears 1-4: knock is most noticable at higher rpm
    - Gear 5: hardly noticable

    Tried:
    - If I pull the lead from the no. 1 cylinder, knock goes away.
    - Changed oil, spark plugs, leads to spark plugs
    - Tried Lucas oil additive - didn't seem to help.
    - Precision Auto diagnostics: said noise from lower engine bearings

    Note: timing chain probably needs replacement, should I spend the money?
  • backybacky Twin CitiesPosts: 18,732
    My 2000 626 ES 2.0 is due for a 30k interval service. Per the dealer, that includes oil/filter, tire rotation (which I don't want, tire shop does that plus balancing for free, but it's a throw-in since the tires will be off the car), transmission drain/fill, coolant flush/fill, air filter replacement, and lots of inspections. They will charge about $400 for it. I checked with a local shop I have used before and which seemed to have reasonable rates, and they also would charge about $400. Does this seem like a reasonable price for this service? The car does need the transmission fluid change--we know how cranky those ATs are on this car, and I am trying to make it last as long as possible by changing the fluid every 15k miles (which is nearly 3 years of driving for my son). I also put the external transmission cooler on the car when I bought it in early 2006, and so far the transmission has worked fine--car has 114k on it now. I had the selling dealer do the 60k service when I bought it, at 84k miles, because there was no evidence it had been done.
  • I got to this late, since I lost my 626 to a wayward deer some years back, but as I remember, 30k service ran pretty close to $400 at the local Mazda store.
  • backybacky Twin CitiesPosts: 18,732
    Well, late, yes, but that's the going rate it seems. Unfortunately, turned out the car needed a LOT more than the 30k service. About $1500 worth, total. Just a reminder that many things can wear out on a car that's 10 years old with 115k miles on it. Hopefully that will be it except maybe an oil change until I turn over the title to my son when he graduates from college in December. Then HE can keep it up... or sell it, his choice.
  • p100p100 Posts: 1,116
    Almost a year later, now at 279,000 miles and another A/C compressor due to failed clutch bearing. Just replaced clutch master and slave cylinders and rebuilt the rear brake calipers (fluid seepage due to a deteriorated O ring.) The engine runs superb still. No other problems.
  • joe323joe323 Posts: 1
    I didn't have the time to replace my starter so I had a stupid mechanic do it for me and he cut the wire in the process making my light constantly blink.
Sign In or Register to comment.