Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Impala Audio

17172737577

Comments

  • p62480p62480 Posts: 8
    I recently purchased a 2005 Chevrolet Impala LS with Onstar, but no factory XM. I want to purchase the XM direct kit, and I was wondering if anyone knows if the Onstar antenna also includes the XM antenna. If so how or where are the connections for the XM part?
  • pbaranellopbaranello Posts: 36
    Yes, the On-star and XM antenna is the same, located on the rear middle roof.

    The only other antenna you have is for the remote start feature and that is located on the top of the front wind shield where you see the web like design across the entire top of the glass with a small button located in the drivers side corner.

    When and if you replace the wind shield, this needs to be taken into consideration.

    As far as installing after market XM, I have no clue but I know others have done this with Sirius radio.

    Good Luck.
  • p62480p62480 Posts: 8
    Does anyone know where the wiring for the combined antenna would be if its available? Thanks
  • check out my previos posts i found the problem and fixied it
  • Chances are its wet because of your Hepa filter , Under the cowl sita a filter for the cabin , after time the ruber around filter weathers out and un seats from the box wher filter sits , get new filter and use black atv siicone and make sure when put back a perfect fit , Try this , we spent 2 months driving around with no carpet trying to figure out where teh water was coming from.
  • Chances are its wet because of your Hepa filter , Under the cowl sita a filter for the cabin , after time the ruber around filter weathers out and un seats from the box wher filter sits , get new filter and use black atv siicone and make sure when put back a perfect fit , Try this , we spent 2 months driving around with no carpet trying to figure out where teh water was coming from.
  • I have the 103 amp in my 2001 LS and my stereo has great sound and performance. I had it replaced over a year ago due to the original amp shorting out and it was replaced with the same amp # 103. The sound quality is excellent. Good deep bass with the setting set two notches positive from center and excellent highs three notches positive from center.
  • I cannot say what the problem with the locked radio is but allow me to give you my insight to GM dealers from years of experience. I know that Warranty's are a crap shoot but when you have a warranty on a GM vehicle, whether factory or extended warranty the dealers do what is required and whatever the repairs are it is paid for. If you don't have a warranty they take you to the cleaners.....

    I have never had a purchased extended Warranty from GM dealers that has not paid for itself, whether the repairs are actual, bogus, or pin the tail on the donkey repairs.

    I am not condoning extended warranty's but this seems to be the way dealers operate.

    Just a side note:
    MY wife lost her key and key fob to our 2002 Impala. (this is not under warranty)

    I called my dealer and they quoted me the following:
    1 Key fob - $63.00
    1 - Key, non chip type - $7.74
    Program new key fob - $40.00.

    Bottom line approx. $110.00 to replace a lousy key and key fob.............

    I went on line and purchased a key fob for less than $28.00 and programmed myself. I did pay $7.74 for the actual key but approx $35.74 is a far cry from $110.00 if I went to the dealer.

    For you anti American car buyers the foreign car dealers are no better...................
  • I have the same exact issues with my 06 Impala LTZ. The hissing, hiss, or distortion is to me unacceptable. When I buy a vehicle with premium sound I expect just that. Any reasonable person would agree that the amount of distortion in the Bose premium sound system does not fall within the specifications of premium anything.

    I have attempted to fix this issue though 2 Chevy dealerships. Each attempt brings no resolution just frustration and them telling me that I’ll just have to deal with it and there is no fix.

    This is why I am looking for people with the same problem willing to bring a class action law suit against Chevrolet. All I am after is a replacement radio or a monetary amount to fix the issue myself.

    Please contact me via email apetersse@gmail.com if you are interested.
    Andrew
  • prigglypriggly Posts: 643
    Hi Andrew,

    I am sorry that you are having hiss in your Bose system. I have an '06 Impala SS with the Bose system and it has no hiss or distortion or other problems. The sound quality has been truly premium from day one. I am very happy with it.

    Has either of the dealers you went to replaced the amp? If not, I would suggest this is a place to start. There must be a solution to your problem but I am not sure a class action suit is it.
  • quietproquietpro Posts: 702
    Andrew,
    Have you had any work done on the stereo in your car? There was a fix for the stereo and I had it performed on my car. While it did improve the problem, it was by no means a real fix. The hiss is still there and the overall sound quality still leaves much to be desired. I actually refrain from listening to much music, especially at higher volume levels because there are certain tones that just seem to resonate through my skull. This doesn't happen with any other stereo, just my "premium" Bose system. I've adjusted my bass, mid, and treble all that I can to try to alleviate the problem but it just doesn't help.
    As for a class action suit, it's a great idea in theory but I just don't think there are enough of us. Most of the folks who have shown up on this board either don't have the same problem or don't hear it. The Better Business Bureau may be a better option for us although I've pretty much given up. I will just never buy a Bose product again. Please let us all know if you make any progress.

    Thanks,
    Ron
  • I have an aftermarket cd player installed in my 2003 impala 3.4l.....well its been in for about 3 months now....i accidently hit a pothole the other day and all sound cut out....the cd player is still working and everything...so i am thinking it could be the amp....i want to do the bypass to see how it works but i have not found detailed instructions to this anywere even when i search...can someone help me out please....i need some music....lol
  • Why did you have to replace your amp? My sound recently died (radio.cd.tape still show as being on) and we are trying to decide if amp replacement in necessary.

    Jim
  • I own both a 2000 LS and a 2001 standard sedan and both have the top line radio with both CD & Cassett. I bought the LS for my son used after really enjoying the Wife's '01 bought new. Both sound systems were very good until I decided to fix the boy up for Christmas and get a stronger amp and better speakers.

    Knowing less than nothing about these super sound systems in cars I relied on a couple of my employees who were always installing systems in their, and their friends cars. (Bad move) They told me what to look for in equipment and off I went to the stores. I got speakers and a good amp and some supplies on their list and they were all fired up. A week or so later they still had the car torn apart and nothing was working at all. They had burned up the first amp and I got another on warranty. I realized that they had no clue how to deal with the stock system which I insisted on retaining since the thing programs the whole car!

    I finally made them put the thing together so I could take it to a professional shop and it cost me a ton to get it straightened out (suposedly) and it did work pretty well for about two days then one speaker after another quit. I'll not bore you with more details but I decided to try to get it back to the stock system with just some improved speakers (as the originals were destroyed by now) and it was restored by removing the output units needed to bypass the original amp. It worked for a few days then one side of the original amp fried. I called the local Chev store parts and found it cost nearly 400 bucks to replace the stock amp. NO WAY!

    So, you guys in Chevyland that know all the good stuff, where should I go from here other than to my nearest Ford dealer? I have checked around for a used amp and had no luck locally. I am soon going to get the car back from my son (and his wife now) and get them into a nice minivan for the new grand daughter. I recently dumped a load into the engine and accessories so I will probably hang onto it because it is such a nice ride for me. I do need sound, if for nothing more than to listen to Rush Linbhaugh on AM.

    I'll be listening to your suggestions.
  • jntjnt Posts: 316
    If the whole process has not fried your radio 's internal audio amplifier yet, you could just hook the 4 speakers directly to this Chevy radio and restore the sound without buying the new amp.

    This particular radio can drive 4 Ohm speakers directly since it has internal amplifier. Besides, the original cheapo amplifier is a lousy one so you will not miss it anyway.

    At the location of the original amplifier, you basically bypass the amp by connecting its inputs (from radio) to its output (to speakers)

    Four pairs of speaker outputs from radio :

    1. Left Front +, Left Front - : to Left Front speaker
    2. Right Front +, Right Front -: to Right Front speaker
    3. Left Rear +, -
    4. Right Rear +, -

    Each of these wires (on radio side) are has DC voltage on them. They are normally set at 6-7V (1/2 BATTERY voltage). If you have Voltmeter, you should be able to double check.

    To check if radio internal amplifier is OK: Since I do not know the physical connection at the external amp, my info is generic only.Amplifier box typically has inputs from radio and output (to speakers) located in the same connector. So you need to go to Chevy dealership to ask for help (electrical pin-out). This is available in their Electrical diagram

    Here are basic steps

    1. Turn radio on
    2. Find the Left Front + and Left Front - pins (from radio).
    3. Connecting each pin with each pin of speaker (known good one). If you hear sound , that radio speaker driver is OK.
    4.Repeat Step 2-3 again for the remaining driver pairs

    The above steps are to confirm that your radio internal amplifier is not dead yet.
    After that, just connect these pairs to the corresponding vehicle speakers directly. Again the connections to the vehicle speakers are at the connector. If you suspect original speakers are bad, disconnect them, then try one at the time. Note that two terminals of each speaker must not short together. If that happens for long, the radio amplifier drivers will be damaged. Bad blown speakers could have their terminal shorted (causing radio amplifier to shut down or burn up) or open (no sound)

    So basically, you need to get the electrical pin-out of the external amplifier's connector(s) for this experiment. Some people in this forum may be able to help. If not, stop by a Chevy dealer and ask them. From there, you could do your own experiment and save you $400

    Another way: stop by a junk yard and they may sell you an used one for a lot less. Make sure they can let you return if it is not working.

    Good luck

    jt
  • quietproquietpro Posts: 702
    Sorry to hear about your problems, kg. I love my Chevy and the one I had before it but one thing I decided early on after CONSIDERING a stereo upgrade was to forget it. The GM systems are just too integrated into the car's other systems and until GM separates them (which they may have somewhat with the '06+ Impalas), I will never mess with it. The repair costs of something going wrong just aren't worth it to me.

    One bright side to your story, though. You DON'T have to listen to Rush in the interim. :P Sorry...couldn't resist!
  • I read through some of the messages in the Impala Radio thread and am experiencing the same letdowns everyone else is.

    I decided, after owning my 2004 Impala, for the past three years, to finally upgrade to a touch screen.

    I heard through a customer in my store that the chevys have something called an information module/system that hooks into the factory radio. it basically controls the on-board monitor system/light in your dash about your oil/tire pressure/etc.

    after the guy installed the new system and amplifier, all of my speakers in the car died. the customer, who had been through a similiar issue with his malibu, told me i have to find an aftermarket information module so i can access my car's electronic functions.

    has anyone gone through this? and if so, did you you have to buy the aftermarket module, how much and from where?

    any information would be greatly appreciated. thank you
  • I am having problems with my 2004 impala ss i put an aftermarket cd player in and it worked for a couple months then it started to pop out at high volumes then it just completly went out and then i put my stock radio back in and it still didnt work . Then a few weeks later i shut my door hard and it poped back in and worked for a while and then only worked low it started to sound like all the speakers were blown then i lower it and it works again . I moved a couple wires and it worked perfect for a coupoe days now it makes a wooping noise and i lower it all the way it stops then i turn it up with no bass and it works almost all the way up then woops again. Does anybody know wtf is going on please help me im a music freak with no music. and i dont want to replace the stock amp and thats the answer i keep getting from everyone.
  • Hey...I can barely hear any sound from the speaker on the driver side of my 01 impala.....I can only hear a faint sound when I have my ear up to it and its set to the highest volume.....I know its not the actual speaker since i had two different ones installed and they both worked fine....I can hear the sound from all the other speakers just fine.....Everything in the car is still factory......I've heard it could be faulty wiring or the amp going bad.....Has anyone else had this problem or know how to fix it without my having to spend a whole lot of money?.....I need help please!!
Sign In or Register to comment.