Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge/Plymouth Neon

1404143454653

Comments

  • boyo3221boyo3221 Posts: 1
    hi going crazy, my 2000 neon has been doing this this week, and i can tell u a few tips to help temporarily. u need to pull the lights bulbs out of the rear view mirror andf overhead dome lights to stop the battery from draining, as i have done. the fuse whn pulled kills the radio, so i had to do this. feel free to email me with any questions, i might be able to help. boyo3221@gmail.com
  • patpat Posts: 10,421
    But what would be even better is if "goingcrazy1" has questions that they be posted and answered right here in order to benefit all of our community.

    It's not a good idea to post your email address on a public web page. You open yourself up to spam all kinds of other abuse. If you want registered members to be able to see it, just make it public in your profile.

    If you want me to delete your message because of that (you can repost without the address, of course), just drop me an email and I'll be happy to take care of it.

    Again, thanks for your help.
  • toyracertoyracer Posts: 1
    I am trying to replace my wives 2000 Neon timing belt myself. Has anybody done this. It is so darn tight in there, and I can't seem to get that big motor mount that is in front of the timing cover. Could somebody pleases help. I am a decent back yard mechanic, and would like to do this with out taking it too the shop.
  • teekteek Posts: 1
    I am hoping someone can tell me what is wrong here. I have had my car for a year and I have noticed that the lights fade in and our on the dash board. Also I have what looks like a picture of a head light on the dashboard, every time the I hit the blinker this lights up, same with when my lights blink out. I did not receive a manual when I bought the car and the guy who fixes my car can't find anything wrong. does anyone know what this means?
  • Hi Boyo3221... Thanks so much for the tip... I'll be sure to take out the bulbs temporarily. If you do find a permanent solution, please do fill me in. Do you have any idea what may be causing this???
  • oscarshsoscarshs Posts: 1
    I have a 2000 plymouth neon. The AC works (I can turn it on and air comes in). But there is no cold air. I think I should recharge the AC. Does anybody know how to do it? Where can I find the instruction for this? Can I do it by myself?
    Thanks.
  • oscarshs-
    Real easy to do. I went and bought a single 20 oz. can from WalMart for $20 dollars and it had its own gauge. After you've bought the can of R134A refrigerant turn your car on and your AC on high. There's a black knob on top of what looks like a thin pipe on the left side of your engine facing your car. Unscrew that and insert the gauge. Depending what R134A you've bought you either will have to turn the can upside down and push the button on top or you'll have to puncture the can with the gauge. Empty it's entire contents into the AC and after you've emptied the can, put the black knob back on and then check your vents and feel the COLD difference. :D

    -Rick
  • 71charger71charger Posts: 116
    There was a notice about this in Mopar Magazine a little while ago. When the antenna is installed there is supposed to be a gap at the base of the antenna on some Chrysler products. I don't remember off the top of my head if the Neon is one of them. I'll see if I can dig up the issue.. It looks awkward and some dealership lot monkeys have been tightening them all the way down. You may want to see if yours is tightened all the way down and, if it is, check with the dealership and see if it's supposed to be.
  • driesserdriesser Posts: 1
    Hi,

    I just bought a 2000 Plymouth Neon this past weekend from a wholesale used car dealer. The car did not include an Owner's Manual. Does anyone have a PDF or printable file I might be able to download?

    Thanks.
  • eBay has them for your year as little as $2.99

    -Rick
  • raf123raf123 Posts: 1
    I purchased a Dodge Neon from a salvage company that had a damaged computer.
    I replaced the computer with one with the exact part number purchased from
    a salvage company. The engine started and ran for a few minutes and then
    completely shut off and would not restart. It appears that the key that I was given by the company was not the correct key and the vehicle has the Sentry security system. I towed the car to the dealer and they are telling me that they will need to
    1) Make new a new key for about $100
    2) That the computer needs to be replaced for $800
    3) That they would need to reprogram the new computer to match the car.

    Someone else told me that they only needed to reprogram the security system for the new key and that it should cost about $50

    Does this seem right.
  • rodx77rodx77 Posts: 2
    HELLO I HAD THE SAME PROBLEM AND FOUND THAT IT WAS MY REAR DOOR SENSERS THEY ARE THOES BLACK BUTTONS IN THE DOOR FRAME
    ETHIER RE PLACE THEM OR DISCONNECT THEM :)
  • rodx77rodx77 Posts: 2
    REMOVE YOU'ER REAR DOOR SENSERS THEY ARE THOSE BLACK BUTTONS IN THE DOOR JAMS IT WILL FIX YOU'ER PROBLEM AND IF SO YOU THEN CAN RE PLACE THEM IF YOU WHAT. ANY HOW I AM SURE IT WILL FIX YOU'RE IT WILL WORK
    LET ME KNOW WHAT HAPPENS :)
  • mk7mk7 Posts: 1
    Hi, I'm trying to help out a friend of mine who recently had their head unit stolen, I told her I could put her new one in but the problem is that when they ripped it out the head unit the cut the wires off behind the lettering on them that tells you which wire is which. Now I know the basics such as the power and ground but i have know idea what the other wires correspond to and I was wondering if anyone here could list them and find a stereo wiring diagram for it online? I looked but I couldnt find anything and i figured i could maybe get some expert opinion as i've never put a stereo in a neon? Thanks to anyone that replies, the help is greatly appreciated.
  • mk7-
    The same thing happened to me. I went to a car stereo place and they sold me the entire wire set that goes to the neon. Color to color, perfect match. I then was able to easily match all the wires and connect the new connectors that came with it to my stock stereo. The cost was very reasonable. :)
  • Hey,

    I have a 1996 Dodge Neon Expresso. It has about 86,500 miles. In the past 2-3 weeks it's been doing some weird things. When I start the car, it makes a loud popping noise, like a tire has been popped. Then, when I put it in drive, the car does not move. It makes a loud whining noise. It is fine in reverse though. I turn off the car, wait about 5-10 minutes, start it again and usually it is fine. The first two times it happened after it rained. However, this past third time, it happened while I was driving! The loud popping noise happened and the car skidded and I lost control for a second...it made a whining sound when I tried to press the gas...I turned if off...turned it back on and it was fine again. Oh and no it does not happen every single time, although I guess maybe it started to happen more often after awhile. I've brought it to 3 places now. Two transmission places and one Dodge dealer. I've gotten 3 diff opinions now...one said my entire transmission was probably shot. another said it might be electrical. the dodge dealer wants to replace the exhaust doughnut, timing belt and spark plugs but he can't guarantee this will fix it. No one can diagnose it because of course when they test drive it nothing unusual happens. They say my trans fluid is clean and it's shifting fine. anyways I don't want to spend the money on this car if it might not even fix the problem...has this problem happened to anyone? Sorry so long, thanks for the help!
  • My neon is a '96 and it had the same problem as yours. It was the rear main seal. I took mine to a dodge dealership and paid $700 to have it fixed. Call around before you take it in. :)
  • I've known for quite sometime that I needed to have my front o2 sensor replaced, but everytime I took it in I was told it was fine. So I was driving last night and my Check Engine Light came on. I took it to Auto Zone and had it tested. Sure enough it is my front o2 sensor, but I don't have the money to fix it for a week. How bad would it be to drive it? :sick:
  • neo763neo763 Posts: 4
    I too have a 2000 Neon. I just replaced the large motor mount on my car that you are refering to and I found it pretty easy. Once the passenger side of the car is raised and on a jack stand you have to take the weight of the engine off of the mount first by using a jack (the scissor jack that comes with the car worked great) along with a piece of wood ( i used a 3-ring notebook) to avoid damaging the oil pan.
    I don't think I will be of much help but I was wondering how many miles your neon has on it because I have 77,000 on mine and I think mine will need replacing soon also. I was going to do it my self as you are but when I read the service manual it says you have to remove the water pump and power steering pump as well as drain all of the fluid out. I'm considering taking it somewhere but it costs almost $700 but that is replacing both water pump and timing belt.
    Do you have the service manual for the car? If not I have one with instructions on how to replace the timing belt. I will email it to you if you need it. Let me now
  • neo763neo763 Posts: 4
    No doubt. By the way nobody had my motor mounts except the dealer. I paid $40 for each one. I must admit though, I am a bit confused about the motor mounts. The service manual refers to the mounts on the passengers side of the vehicle (engine front) as engine struts but the dealer calls them motor mounts. ????
    Anyways, I replace both the upper and lower struts and the vibration is not as bad but it is still there. I can really hear it in reverse so I think there are two other mounts that I probably over looked?
    Other than the usual maintence that a car goes through @ 80k it runs great. I just took a 800 mile road trip and it did great.
  • Was wondering if anyone has experienced this before? My front tires only have 9,000 miles on them and when I get up to 75 MPH, my steering wheel vibrates for awhile and it will stop. When I take my hands off of the wheel it does not pull to either the left or the right. Goes over bumps with no problem and it started this when I checked my tire pressure and I noticed my front tires were 28 PSI. I wnet ahead and pumped them up to 33 PSI. I'll have to admit that no matter how much air is in them they still look like they are low. I believe that part is typical with Neons. I'm still in a daze as far as the steering wheel vibration. :confuse:
  • nbafan101nbafan101 Posts: 3
    I was driving on the high way and my plastic wheel well liner of my 03 neon came off and got caught in my tire and was shredded and i need to know if anyone knows a wedsite or anything besides a dealer to get a new wheel well liner for an 03 neon? :confuse:
  • capi1capi1 Posts: 1
    I really need help with this.
    I just purchased a 97 Neon from a coworker that uses it everyday. The radiator was bad so I took it out last week in order for me to put in a new one this weekend.

    I replaced the new radiator and now the car will not start. When you turn the key it cranks and turns the engine perfect, but the weird thing is it feels as if its not getting any fuel. Also, the radio, the headlights, the horn, turn signals do not work. And when you put on your blinkers a buzzing sound comes out. Oh the only thing that lights up in the dash is the oil light. Even when I brake the brake lights do not turn on but the oil light inside the dash does. Did I short circuit the car? Or did I mount the radiator on a wire, I checked but everything seemed to be ok.
  • highlinehighline Posts: 2
    I bought my 95 Plymouth Neon Highline almost a year ago. We bought it as is, for about $1600. It's my first car. Anyways, since then, we've had to replace the rear main seal, a tie rod, and recently, a timing belt. The timing belt incident happened on the highway, and as you may know, when a timing belt snaps in a Neon, it causes expensive engine damage. The final cost of fixing it was $1542.23. Earlier today, I noticed my air conditioning didn't come on when I turned it on, so I turned it back off, and turned it on again, and it came on. I had been very busy today going numerous places, and I kept it on a lower level of air just in case. Well, as I was leaving a friends house, I noticed that the check engine light came on for no apparent reason. I know it can't be the timing belt--at least it better not be! The car seems to be doing fine other than the air conditioning issue earlier. Any guess of what it could be now? :(
  • An easy and no charge way to figure your problem out is to get it to an Autozone and have them diagnose your "Check Engine" light. If you have an owners manual just put your key in the ignition and turn it 5 times without turning it over after the fifth time leave it in the "on" position and it will flash a series for you. Count the flashes after the first time and then count the second set of flashes and that number will be your error code to look up. It's pretty cool that the car can tell you what is wrong with it. Hope that helped you out. :)
  • highlinehighline Posts: 2
    Well, I took it to Auto Zone yesterday and the PCM kept saying basically that it couldn't detect the codes. They told me once before that they may not be able to detect a code because my car was a late 95' model and the computers weren't made to check codes on this model. So, I took it somewhere else, and I am awaiting a phone call. Thank you for your help!
  • veonveon Posts: 1
    Hi ,

    My neon lost first and reverse its realy hard to shift it The times I had to drive it all the gear positions felt like 2cnd gear there was no sound (my radios broke so I get to listen to ll the cars lil squeaks and pops)
    I smelt something like Burning electronics but closer to Burning rubber
    I had just pulled into my home parking lot everything was fine very little shifting from the from of the complex to the spot I made to back into my spot and reverse was gone so I tried pulling up a bit and discovered that first gear was gone
    any suggestions would help I've been told that I should pull up the center console and check the shift linkage But I'm having trouble doin that too
  • jwimmjwimm Posts: 1
    I took my Neon in to have the timing belt replaced and the guy at the shop told me the they were unable to remove the main pulley, thus they were unable to replace the belt. I'm certainly not an expert on cars, but what he told me was that they have a special tool to take the pulley out, and that they tried 1000 pounds of pressure and the pulley wouldn't budge...that it was essentially frozen in place. He said that the pulley is working properly . He said that usually they come out relatively easily and he had never seen this happen before. Is there something he is missing, like a locking pin or something else that would be keeping it in place? Is this known issue or problem that anyone has heard of before?
    The car has 101,000 miles on it, and this is the first time trying to replace the timing belt. I'm looking for things to suggest that he look at or try. Thanks for any input.
  • joeisgodjoeisgod Posts: 1
    Fuel pump it seems, check your Relays under the hood, i had same problem and jiggled them and it worked
  • My starter is not engaging but I don't know where exactly it is located in the engine. I was hopping someone could give me some direction.
Sign In or Register to comment.