Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2004 Grand Am, Loses power on Interstate

I have a 2004 Grand Am that i drive over the interstate for about a 2 hour trip a few times a week. Lately, after about an hour or so into the trip, the engine will seem to idle, the car will start to coast, and pushing on the gas does not rev up the engine. I will coast to the side of the road and as i slow down to 20 mph, the gas pedal becomes responsive again and i can speed back up. But at that point, it constantly sputters at speeds around 70 and does the same thing.

I took to a mechanic who checked computer codes and fuel pressure and his determination was a bad fuel pump. He replaced the fuel pump and it did not solve the problem as last night the issue happened again in the same manner after about 90 minutes into the trip. Another mechanic has raised the possibilty of a catalytic converter problem.

Does this seem likely?

Comments

  • I have a 2001 Pontiac Grand Am se, and it does the same thing. i dont know what it is neither. :lemon:
  • I have a 2000 GA GT and it does the same thing. Sometimes it takes 10 - 15 attempt to start then it would barely idle and go 4-500 ft then stop again? This happended twice now. It feels like not enough gas but when it runds it runds great. i did install some lucas FI cleaner and fresh gas. I havent had a problem for several days now but I'm going to install new fuel filter in the am. Pleae advise if you discover anything specific. Thanks.
Sign In or Register to comment.