Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Volvo S70

15354555759

Comments

  • qbrozenqbrozen Posts: 16,893
    65k is still within the limit (I believe it is 75k miles on the '98), but how much time has passed? You typically don't want to go more than 5 years on a timing belt, either.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '08 Town&Country

  • Hey thanks for your answer. I went to a garage where i've been told that the timing belt is still ok. These cars are great to drive. The car though has a big probleme, the valves are touching on the metal and it makes a little noise. As soon as the noise gets bigger I'll have to change the head of the engine...
  • qbrozenqbrozen Posts: 16,893
    ????

    Why are the valves hitting?? And WHAT are they hitting? If that is the case, something is out of alignment and really should be fixed immediately. What garage is telling you this? Is it one that specializes in Volvos?

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '08 Town&Country

  • Hi,
    well the garage is not specialized in volvos but he knows how to fix them ( he was working on a 850 when I went to see him ) . He is the one who told me that it could last even in this situation. I went to another garagist who never works on volvos. This one told me that valves are knoking on the metal and that it wont take long before the engine is out of order. I don't know who I should trust but the car makes this noise since a little bit more than 1 year. Its a metal on metal noise. It's not very loud but when you are outside the car you can hear it clearly. If the car lasts one more year like that it would be great, if not well I'm in trouble...
  • qbrozenqbrozen Posts: 16,893
    But did they say WHAT is hitting? Valves can make noise in a few ways. One is hitting the tops of the pistons. This is VERY bad and means the timing is off. Of course, the timing problem can be remedied. Another way is valve lash: where the noise is actually when the vavle hits the lifter. This could be caused by poor oil flow or bad hydraulic lifters. Possibly the valves are hitting the valve cover, although I'd be surprised the clearance is that tight.

    So, in short, if they are saying the valves are hitting, I'm pretty sure this is something that could be fixed now without a new engine, rather than waiting for further damage.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '08 Town&Country

  • volvomaxvolvomax Posts: 5,274
    Probably is valve lash. If you aren't religious about changing the oil it can happen.
  • Well, the previous owner changed it every 5000km.. but before him I have no idea...
    Next week i'll take it to a volvo garage, but in your opinion can it last for few months like that ? Some mecanics tell me that it can , some others tell me " you should not use the car anymore it's dangerous. " Since it lasted with that noise for 1 year at least, I guess it won't be a problem for the next months..
    Anyways thanks for all your help
  • volvomaxvolvomax Posts: 5,274
    Old Volvo's usually have some lifter noise. It's probably not serious.
    Have a real Volvo tech look at it.
  • I have a 2000 volvo s70 that has about 228k miles. I have never had an y problems with the car until recently. I can get it to start but then it dies after about 5-10 seconds. I dont know what could cause this. I was told about a recall for a sensor or something but i cant get that changed until i get the car running so i can get it to the shop. please help me.
  • qbrozenqbrozen Posts: 16,893
    MAF sensor.

    If you are so inclined and motivated, you can remove it and clean it.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '08 Town&Country

  • asikaasika Posts: 8
    I had the same experience on my 1998 Volvo s70. My 17 year old drives it and it started doing exactly what you described. Anyway, I spent $130 at Kragen for a re-manufactured Mass Air Flow(MAF). It took less than 20 minutes to replace at home.
  • chi9chi9 Posts: 1
    Does any body have experience an acceleration with the S70 SE? When you first step on the gas pedal, you have to really step on it, and the car would make a revving sound before it start to accelerates. However, once it gains momentum it accelerates smoothly. Is this a common problem? Is this means that there is something wrong with the engine? The pedal seems to resists. Please help.
  • qbrozenqbrozen Posts: 16,893
    if it is revving before moving, it is a transmission problem.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '08 Town&Country

  • jeff207jeff207 Posts: 2
    edited February 2011
    I disagree about the 1998 not being reliable. I have one with 230,000 miles and it has been wonderful. Actually my cousin is a mechanic and said that it is the year you want since after 1998 they made it so you have to plug the car in at the dealer to use their diagnostic system that has a proprietary uplink to Volvo in Sweden. Issues I have had are MAS air flow sensor replaced under warranty around 70k and really not much else. It's hard to believe but either I have a one of a kind or the car is just excellent. I have been in 2 not at fault accidents where I was struck on the rear bumper quite hard and there was no structural damage. Just replace the bumpers and voila! Back in business! Try that in a "reliable" Toyota or Honda. From those two accidents I seriously believe I would have had a totaled car (and thus a new car payment). Mine keeps on truckin' and I plan to keep it until I just get tired of it since I really have not been able to wear it out. I do drive my cars hard but keep the routine maintenance up. Avoid the dealer for service and ask around town whose work is good with Volvos. As a helicopter mechanic on Apache and Blackhawks for 15 years I know what good engineering is and these cars are made to last.

    Note: I have always used Mobile One Synthetic oil.

    1998 S70 GLT 2.4 liter.
  • qbrozenqbrozen Posts: 16,893
    '98 really is the one to have. '99 is still OK, but the electronic MAF in that one is problematic ... but a fix is available. '98 is also the lightest, which is a nice added benefit.

    If I ever come across a preserved low mileage '98 T5, I'd have to grab it, I think.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '08 Town&Country

  • jeff207jeff207 Posts: 2
    edited February 2011
    Exactly. A Volvo is not a Toyota or some other Asian cookie cutter. If you want to never have to do anything to it then get one of those.

    The tradeoff of buying the Toyota in my opinion is:

    1. A generic uninspired car. Looking like every other car out there.
    2. A car that is not built like a tank (more likely to get totaled in accidents).
    3. How many recalls are there out there for Toyotas lately?
    4. Crappy seats. (Volvo has the best- I have owned a Jetta with Recaro seats and also a BMW 325i and Volvo still beats them).
    5. Less than stellar handling (Volvos are great handling European cars-not every model but most of the newer ones).

    If you take care of it, it will take care of you. I will never drive a Toyota or any other mass produced, uninspired cars. No matter what the reliability is, if it is not fun to drive then it is just a waste of time. This is just my opinion so take it or leave it.
  • Hey guys- any help would be appreciated.

    Occasionally at low speeds (stopped at red lights, stop signs) when I step on the accelerator the car will stutter, like its choking. It has to be a misfire of some sort, I assume.

    It will correct itself within 5 seconds and ONLY does it after the car isn't moving. Once it corrects itself the car run perfectly and smooth.

    Any advice? I'm guessing plugs?
  • qbrozenqbrozen Posts: 16,893
    edited April 2011
    year? model?

    without knowing the answers to the above, I'm going to take a guess that you have a '99-'00 model and your MAF is going south.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '08 Town&Country

  • 1998 S70.

    Thanks for the reply.
  • qbrozenqbrozen Posts: 16,893
    ok, well then probably not a MAF problem. I doubt the plugs since you would have other issues as well. It could be something on the intake leaking or a vacuum issue.

    You didn't tell me the model, so I don't know if turbo or not. If turbo, that gives you many more possible places for leaks.

    On my '98, I one time had a plastic elbow connector inside the intake manifold crack. That caused a bit of a stumble at idle on occassion.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '08 Town&Country

Sign In or Register to comment.